Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] problema nella gestione degli aggiornamenti
#1
Ciao a tutti,

ho questo problema da ieri su ubuntu 12.04.
Se lancio il gestore degli aggiornamenti compare una finestra backend_Helper.py che mi segnala "Impossibile monitorare o controllare le attività. La connessione al demone è stata persa. Probabilmente il demone in background è andato in crash.".

Se provo a lanciare sudo apt-get update e sudo apt-get upgrade da terminale, nel primo caso non arriva in fondo al recupero pacchetti ed esce senza messaggi di errore, nel secondo mostra Lettura elenco pacchetti arrivando al 96% e poi esce senza messaggio di errore.

Da ultimo se provo a lanciare il gestore di pacchetti, si apre la finestra del gestore ma poco dopo esce senza alcun messaggio di errore.

Qualche suggerimento?...

Grazie!
Cita messaggio
#2
Da gestore Aggiornamenti -Impostazioni-software per ubuntu
controlla che sia impostato- Scaricare da Server Principale

Poi prova da terminale a dare

Codice:
sudo rm -r /var/lib/apt/lists/* -vf

Codice:
sudo apt-get update

Cita messaggio
#3
(16-09-2013, 15:24 )brunik Ha scritto: Da gestore Aggiornamenti -Impostazioni-software per ubuntu
controlla che sia impostato- Scaricare da Server Principale

Poi prova da terminale a dare

Codice:
sudo rm -r /var/lib/apt/lists/* -vf

Codice:
sudo apt-get update

niente brunik. Se lancio il gestore aggiornamenti la finestra resta aperta
per pochi secondi e poi crasha scomparendo senza lasciare messaggi.
Stessa cosa tra l'altro fa il gestore Sorgenti...
Cita messaggio
#4
Il messaggio di errore è scomparso,o ritorna ....
Leggi pure http://www.istitutomajorana.it/forum/Thr...iornamenti sembra lo stesso problema.
Oltre ai comandi indicati che pare siano già stati dati,cerca di avviare con un kernel precedente,vediamo se si ripresenta il problema.

Cita messaggio
#5
(16-09-2013, 16:34 )brunik Ha scritto: Il messaggio di errore è scomparso,o ritorna ....
Leggi pure http://www.istitutomajorana.it/forum/Thr...iornamenti pare lo stesso problema.

il messaggio di errore si ripresenta se lancio Verifica disponibilità aggiornamenti. Se lancio invece il Gestore aggiornamenti invece niente, crasha senza alcun messaggio.

Avevo visto poi la discussione che mi hai indicato, ma la soluzione che ho visto proposta (sudo apt-get update e sudo apt-get upgrade) a me non risolve nulla.
Cita messaggio
#6
(16-09-2013, 16:43 )ghimel Ha scritto: il messaggio di errore si ripresenta se lancio Verifica disponibilità aggiornamenti. Se lancio invece il Gestore aggiornamenti invece niente, crasha senza alcun messaggio.
Huh
Come fai a lanciare la verifica degli aggiornamenti,se il gestore stesso crasha subito senza alcun messaggio ?
Hai aggiunto qualche repository ultimamente,o cambiato qualche opzione nel gestore aggiornamenti.

Cita messaggio
#7
(16-09-2013, 17:43 )brunik Ha scritto:
(16-09-2013, 16:43 )ghimel Ha scritto: il messaggio di errore si ripresenta se lancio Verifica disponibilità aggiornamenti. Se lancio invece il Gestore aggiornamenti invece niente, crasha senza alcun messaggio.
Huh
Come fai a lanciare la verifica degli aggiornamenti,se il gestore stesso crasha subito senza alcun messaggio ?
Hai aggiunto qualche repository ultimamente,o cambiato qualche opzione nel gestore aggiornamenti.

il messaggio lo vedo, come dicevo, se lancio Verifica disponibilità degli aggiornamenti che apre la sola finestrella di aggiornamento della cache. E' qui che vedo il messaggio di errore che esce come finestra nominata backend_helper.py.
Non ho aggiornato nulla tra i repository. Fa conto che il problema si è presentato dopo uno stop del pc di una settimana (ero via per una vacanza).

Invece ti aggiungo un'altra cosa. Se riavvio la macchina in modalità recovery e faccio qualche verifica sui pacchetti danneggiati, trovo un messaggio segmentation fault pacchetti....96% che è esattamente il messaggio su cui si blocca sia l'apt-get update che l'apt-get upgrade
Cita messaggio
#8
Prova da terminale dai

Codice:
sudo rm /var/cache/apt/*.bin

Cita messaggio
#9
(16-09-2013, 18:19 )brunik Ha scritto: Prova da terminale dai

Codice:
sudo rm /var/cache/apt/*.bin

ecco che cosa mi dà impossibile rimuovere "/var/cache/apt/*.bin": File o directory non esistente
Cita messaggio
#10
Da terminale dai
Codice:
sudo gedit /etc/apt/apt.conf.d/70debconf
Nel file aggiungi la riga
Codice:
APT::Cache-Limit "100000000";
Salva,chiudi,riprova ad aggiornare.

Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)