Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 1 voto(i) - 5 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] scheda grafica installata
#1
salve a tutti,
sto facendo una piccola ricerca per vedere quali driver ho installato sulla macchina (proprietari oppure opensource) e per vedere se la configurazione della scheda video è quella ottimale o meno, tenendo presente che ho installato Linux Mint 16 xfce.

Da terminale ho dato i seguenti comandi:
leonida@Satellite-M40 ~ $ lspci | grep -i vga
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]



leonida@Satellite-M40 ~ $ sudo lshw -c display | grep driver 
[sudo] password for leonida:configuration: driver=radeon latency=0 leonida@Satellite-M40 ~ $

 leonida@Satellite-M40 ~ $ glxinfo | grep
render
direct rendering: YesOpenGL renderer string: Gallium 0.4 on ATI RV370GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render,leonida@Satellite-M40 ~ $

leonida@Satellite-M40 ~ $ glxinfo | grep
"OpenGL version"
OpenGL version string: 2.1 Mesa 9.2.1leonida@Satellite-M40 ~ $ 

a questo punto avrei due domande, cortesemente:

1) non sono riuscito a capire se ho installato sul pc i driver proprietari della ATI per la mia scheda grafica oppure i driver open source?

2) dando il comando da terminale glxgears

non appare "l'ingranaggio che si muove"...anzi sul terminale appare:
leonida@Satellite-M40 ~ $ glxgears Running synchronized to the vertical refresh. The framerate should beapproximately the same as the monitor refresh rate.XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"after 37 requests (37 known processed) with 0 events remaining.

Non capisco se ho commesso io qualche errore!!Grazie


 

 

 
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio
#2
questo aiuta:
http://wiki.ubuntu-it.org/Hardware/Video...eFrequenti
Cita messaggio
#3
(10-03-2014, 19:35 )'dxgiusti' Ha scritto: questo aiuta:
http://wiki.ubuntu-it.org/Hardware/Video...eFrequenti

 
grazie dxgiusti per il link segnalatomi,

per quanto riguarda la mia domanda numero 1 mi sembra di aver capito che la macchina abbia driver grafici open source...giusto?
per quanto riguarda la mia domanda nulero 2 non sono proprio riuscito a capire il perchè del mancato funzionamento del comando glxgears!


 
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio
#4
scusate...c'è nessuno che può spiegarmi un possibile motivo per cui, dando da terminale il comando glxgears, non appaiono gli "ingranaggi" in 3D?
Grazie.[img]images/smilies/confused.gif[/img]
 
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio
#5
Codice:
leonida@Satellite-M40 ~ $ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 37 requests (37 known processed) with 0 events remaining.
leonida@Satellite-M40 ~ $

leggendo sul forum e googlando ho letto che digitando sul terminale glxgears dovrebbe apparire una piccola finestra con un ingranaggio in 3D in movimento.
A me invece il terminale, a tale comando, mi da la risposta riportata sopra.
Per cortesia, qualcuno sa spiegarmi il perché?

P.S.: al fine di darvi altre informazioni, allego anche queste videate del terminale:

Codice:
leonida@Satellite-M40 ~ $ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]
leonida@Satellite-M40 ~ $

Codice:
leonida@Satellite-M40 ~ $ sudo lshw -c display | grep driver
[sudo] password for leonida:
       configuration: driver=radeon latency=0
leonida@Satellite-M40 ~ $
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio
#6
prova a dare questo comando
Codice:
glxinfo | grep render
Cita messaggio
#7
Per far funzionare quei comandi devi installare mesa-utils con il comando:
sudo apt-get install mesa-utils
poi col comando glxgears ti appariranno gli ingranaggi colorati che girano, se hai l'accelerazione 3d attiva.
Bilodiego
Cita messaggio
#8
(17-03-2014, 10:57 )bilodiego Ha scritto: Per far funzionare quei comandi devi installare mesa-utils con il comando:
sudo apt-get install mesa-utils
poi col comando glxgears ti appariranno gli ingranaggi colorati che girano, se hai l'accelerazione 3d attiva.
Bilodiego

Codice:
leonida@Satellite-M40 ~ $ sudo apt-get install mesa-utils
[sudo] password for leonida:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
mesa-utils è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
leonida@Satellite-M40 ~ $ glxgears
556 frames in 5.1 seconds = 109.970 FPS
600 frames in 5.1 seconds = 117.481 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 2712 requests (39 known processed) with 0 events remaining.
leonida@Satellite-M40 ~ $

grazie mille bilodiego,

ora funziona, vuol dire che ho l'accelerazione grafica attiva......una domanda, per cortesia, cosa vuol dire la scritta XIO: fatal IO error 11 ecc..?Smile
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio
#9
(17-03-2014, 10:29 )maxbigsi Ha scritto: prova a dare questo comando
Codice:
glxinfo | grep render

ecco la videata del terminale...
Codice:
leonida@Satellite-M40 ~ $ glxinfo | grep render
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
leonida@Satellite-M40 ~ $
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio
#10
una domanda, per cortesia...se apro il gestore driver, mi appare la schermata con la scritta "nessun driver proprietario in uso".

Considerato che il mio Toshiba ha una scheda AMD Radeon X 600SE, che dite...va bene così o sarebbe meglio installare un driver specifico per la scheda ATI leggibile da Linux?Smile
Linux Mint 16 Petra  xfce 
Toshiba  M40-223
Matshita 80Gb
 Advanced Micro Devices, Inc[AMD/ATI] RV380/M24C [Mobility Radeon X600 SE]

 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)