Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 1 voto(i) - 5 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] schermo nero dopo aggiornamento e driver ATI
#1
Nella Remix 9 ho provato con tutti i tasti con F2 con F10 con ESC con shift e via discorrendo ma il grub non v'è modo di farlo apparire, in sintesi ho provato sia prima che appaia la plymount che nel mentre carica... tutti i tentativi sono stati vani! L'unico modo che ho riscontrato per far apparire il grub è da gedit andando a modificare una stringa togliendo lo splash (questo è da fare ovviamente quando si ha il sistema installato cosa che non si riesce da cd-live) quindi appare poi il grub, altri di voi si trovano nello stesso problema?! Come avete risolto?!

Andare in ripristino mi par di aver capito che da cd-live non è possibile quindi o ci si tiene la plymount e non si vede il grub o tramite gedit si elimina lo splash...

Ho provato anche con questo metodo http://www.istitutomajorana.it/index.php...&Itemid=33 ma non ha dato il risultato sperato...
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#2
Che se non appare mai il grub per qualsiasi problema lieve bisognerebbe quando c'è lo schermo nero, mettere nume utente e password e poi da lì rimuovere tramite comando, solo che talune volte non si sa cosa sia il pacchetto da rimuovere, facendo invece il ripristino tramite grub forse egevolerebbe il tutto ed eviterebbe la formattazione, ad esempio, fosse un problema di driver proprietari installati si andrebbe sul ripristino dei driver open ed la macchina tornerebbe ad avviarsi
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#3
Prova QUI: http://www.istitutomajorana.it/index.php...&Itemid=69
Cita messaggio
#4
Da cd-live ho fatto questa operazione:

Codice:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Da cd live ho fatto questa operazione:

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
GRUB_BACKGROUND="/bin"

Forse non sono stato molto chiaro, io non ho lo schermo nero ma con scritte in bianco in cui appare un errore se do l'invio da tastiera mi appare login ed nel mio caso metto davidelex ed in seguito inserire la password da lì poi mi permette di fare operazione da terminale... potrei dunque tentare con i comandi?:

Codice:
sudo apt-get check
sudo apt-get -f install
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#5
(12-07-2012, 18:04 )Bingol Ha scritto: Da cd-live ho fatto questa operazione:

Codice:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Da cd live ho fatto questa operazione:

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
GRUB_BACKGROUND="/bin"

Forse non sono stato molto chiaro, io non ho lo schermo ma con scritte in bianco in cui appare un errore se do l'invio da tastiera mi appare login ed nel mio caso metto davidelex ed in seguito inserire la password da lì poi mi permette di fare operazione da terminale... potrei dunque tentare con i comandi?:

Codice:
sudo apt-get check
sudo apt-get -f install
dai i seguenti comandi:
Codice:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get check
sudo apt-get -f install

Poi prova a rimuovere i driver ATI, se non ci riesci postami qui il messaggio che ti rida' il terminale. poi riavvia con:

Codice:
sudo reboot
Cita messaggio
#6
Ho fatto i comandi consigliati da te matteo, tali comandi li ho dati quando vi è lo schermo nero in cui ho messo login e password, però per la eliminazione dei driver ati non è andato in porto

Mi è uscito:

Codice:
sh: 0: can't open /usr/share/ati/fglrx-unistall.sh

Ho provato anche da cd-live ad entrare nel grub e togliere quiet splash il fatto che quando salva dice che è solo in lettura se salvassi, incontrei problemi?!

Se cerco di cercare la cartella Ati non la trovo...

   
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#7
Digita il comando per vedere quale driver è attivo attualmente. Adesso avevi installato i 12.6 oppure quelli di Driver Aggiuntivi?
Cita messaggio
#8
Se non erro ho messo il proprietario seguendo la tua guida, comunque sia ho dato il comando:

Codice:
sudo lshw -c display | grep driver

il risultato è stato:

Codice:
configuration: driver=fglrx_pci latency=0
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#9
Prova adare i seguenti due comandi:

Codice:
sudo aticonfig --initial -f
sudo reboot

il pc si riavvierà, vediamo se ti funziona. Per la cronaca mi è successa la stessa cosa, a me, te, e altri utenti che mi scrivono sul blog, ognuno sta risolvendo un po' a caso questo problema inerente gli ultimi aggiornamenti di xorg e i driver ati. Un utente pare abbia risolto con i due comandi che ti ho messo.

PS: io ho risolto con:

Codice:
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get install fglrx-updates
sudo reboot
Cita messaggio
#10
Ok, confermo che con uno dei due metodi il problema che c'è stato con i driver ATI dovrebbe andare a posto. Come al solito faccio tesoro di quanto imparo, e QUI ho scritto un piccolo articolo in proposito, dove praticamente spiego quello che ho detto a te Bingol in questa discussione.

PS: modifica il titolo con qualcosa di inerente al problema, che abbiamo scoperto essere definitiva,ente legato ai driver ati, del tipo "schermo nero dopo aggiornamento e driver ati". e se il problema si è risolto, scrivilo sempre nel titolo con un bel RISOLTO =)
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)