Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]ubuntu 13.10 - uso adattatore usb wireless asus usb n13 (realtek rtl8192cu)
#1
Sono nuovo di ubuntu e chiedo l'aiuto della comunità.
Ho acquistato un adattore wireless asus usb n13 per collegarmi su internet attraverso il router netgear dgnb2200 settato in modalità n fino a 300Mbps e protezione wpa2-psk (aes).
L'ho collegato a una porta usb del mio pc e ho stabilito subito il collegamento alla mia rete (tra l'altro, nelle informazioni generali di connessione mi risulta "driver: rtl8192cu" e una velocità stabile di 150 MB/s). Riesco quindi a navigare per un pò; dopo poco tempo, però, il browser (firefox) non apre più nessuna pagina, pur risultando sempre attiva la connessione (le tacche sono sempre le stesse e così l'indicazione della velocità di connessione). Se lo stacco e lo riattacco il pennino riprende a funzionare, ma dopo un pò si blocca di nuovo il browser come prima.
Qualcuno può darmi un aiuto a fare funzionare in modo stabile questo adattatore? (l'ho comprato perchè indicato compatibile con linux)
Cita messaggio
#2
Citazione:Qualcuno può darmi un aiuto a fare funzionare in modo stabile questo adattatore?

devi rivedere le impostazioni internet (ubuntu 13.10) dare un indirizzo "ip" nell'adattatore compreso di dns .

mi sembra ovvio che il router deve essere configurato.
Cita messaggio
#3
Prova ad impostare un ip statico per la connessione,guarda la guida

http://www.gmstyle.org/ubuntu-guide/137-...based.html

Sposto in sezione Reti software vario ed argomenti vari.

Cita messaggio
#4
(19-12-2013, 09:57 )brunik Ha scritto: Prova ad impostare un ip statico per la connessione,guarda la guida

http://www.gmstyle.org/ubuntu-guide/137-...based.html

Sposto in sezione Reti software vario ed argomenti vari.
Cita messaggio
#5
il router è settato per dare un indirizzo ip in automatico. D'altronde la navigazione si avvia regolarmente, però dopo un pò, come ho detto, il browser non apre più nessuna pagina. Il problema a me pare sia un altro e cioè ubuntu è compatibile col wireless settato in modalità fino a 300 Mbps? Perchè ho provato a settare sul router il wireless in modalità fino a 54Mbps e il pennino asus usb n13 adesso funziona a dovere
Cita messaggio
#6
(19-12-2013, 09:57 )brunik Ha scritto: Prova ad impostare un ip statico per la connessione,guarda la guida

http://www.gmstyle.org/ubuntu-guide/137-...based.html

Sposto in sezione Reti software vario ed argomenti vari.

Ho impostato l'ip statico, ma il problema permane se il wireless è settato a 300Mbps. Se viene settato in modalità 54Mbps tutto a posto. Ma allora ubuntu non supporta il wi-fi n300?
Cita messaggio
#7
Il problema pare che sia proprio il driver dell'adattatore usb realtek rtl8192cu in uso su linux che non vada al meglio,in teoria però viene dato per un max di 150Mbps.

Tornando al problema di disconnessione,devi provare a rimpostare come in origine,
provando poi a dare da terminale sudo modprobe rtl8192cu swenc=1 e vedere
se le cose migliorano.Questo perchè potrebbero esserci problemi di crittografia software che rendono problematica la connessione.

In seguito potresti rendere stabili le modifiche aprendo il file seguente con
Codice:
sudo gedit /etc/modprobe.d/rtl8192cu.conf
e aggiungendo la riga
Codice:
options rtl8192cu swenc=1

Cita messaggio
#8
(19-12-2013, 20:18 )brunik Ha scritto: Il problema pare che sia proprio il driver dell'adattatore usb realtek rtl8192cu in uso su linux che non vada al meglio,in teoria però viene dato per un max di 150Mbps.

Tornando al problema di disconnessione,devi provare a rimpostare come in origine,
provando poi a dare da terminale sudo modprobe rtl8192cu swenc=1 e vedere
se le cose migliorano.Questo perchè potrebbero esserci problemi di crittografia software che rendono problematica la connessione.

In seguito potresti rendere stabili le modifiche aprendo il file seguente con
Codice:
sudo gedit /etc/modprobe.d/rtl8192cu.conf
e aggiungendo la riga
Codice:
options rtl8192cu swenc=1

Intanto grazie per la dritta, ma nonc'è nessuna novità! Ho provato quanto da te indicato dando da terminale sudo modprobe rtl8192cu swenc=1. I problemi di navigazione ci sono sempre col wireless settato sia a 300Mbps (in informazioni connessione la velocità risulta stabile 150Mb/s), sia a 145Mbps (la velocità risulta stabile 72Mb/s). Settando la velocita a 54Mbps si torna a navigare senza problemi.
Non ci sono soluzioni?
Cita messaggio
#9
Dovresti riprovare dando stavolta prima sudo modprobe -r rtl8192cu poi ricarichi con sudo modprobe rtl8192cu swenc=1

Altre soluzioni non ne conosco,l'unica se non risolvi e provare ad installare i driver aggiornati (29-10 13) dal sito della Realtek per RTL8192CU

Dopo aver scaricato i driver,apri con gestore archivi ed estrai nella home
Quindi da terminale dai
Codice:
sudo apt-get install build-essential linux-headers-generic
Spostati nella cartella estratta nella home con
Codice:
cd RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911/
Installa poi con
Codice:
sudo bash install.sh

Cita messaggio
#10
Ringrazio brunik per la risposta. Proverò dopo. Poichè sono nuovo di ubuntu, se ho problemi domanderò aiuto per l'installazione dei driver. Confermo comunque che il pennino funziona benissimo con settaggio wireless 54MBps.
A risentirci
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)