Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] uscita digitale SPDIF (farla funzionare con Ubuntu)
#1
La scheda madre del mio Desktop è una GigaByte con chipset nForce3 250Gb (GA-K8NSC-939 serie K8 Triton), di cui uso la scheda audio interna; inoltre questa scheda ha anche un connettore SPDIF_IO che, collegato all'apposito dispositivo mi permette di avere sul retro del PC un'uscita digitale ottica e una RCA.
Ho collegato quindi l'uscita RCA al convertitore digitale/analogico dell'impianto stereo per ascoltare la musica memorizzata sull'HD o trasmessa via Web.
La cosa funziona perfettamente con Windows mentre con Ubuntu (10.04) l'uscita digitale è muta e non sono riuscito a capire come farla funzionare.

C'è qualcuno che avendo lo stesso problema ha trovato una soluzione?

Grazie
Cita messaggio
#2
In alsamixer devi vedere se sono abilitate le uscite, in questo sistema:
- da terminale dai il comando -> alsamixer;
- premi f6;
- scegli la tua scheda grafica (l'uscita s/pdif dipende dalla scheda grafica);
- contollare che le uscite s/pdif, tutte, siano settate "00" e non "MM";
- se sono "MM" vai con il cursore sopra (usando i tasti freccia) e poi premi "M" da tastiera (vedrai cambiarle da "MM" in "00"
esci e prova.
Cita messaggio
#3
               
(10-11-2013, 09:54 )roberto1155 Ha scritto: In alsamixer devi vedere se sono abilitate le uscite, in questo sistema:
- da terminale dai il comando -> alsamixer;
- premi f6;
- scegli la tua scheda grafica (l'uscita s/pdif dipende dalla scheda grafica);
- contollare che le uscite s/pdif, tutte, siano settate "00" e non "MM";
- se sono "MM" vai con il cursore sopra (usando i tasti freccia) e poi premi "M" da tastiera (vedrai cambiarle da "MM" in "00"
esci e prova.

Ho seguito la procedura che mi hai indicato ma non ho trovato nessuna uscita SPDIF con "mm".
Ti ringrazio, comunque, del tuo suggerimento.
PS: allego 3 schermate della situazione che mi ha mostrato Alsamixer per le due schede (nVidia CK8S e SA7134). La quarta (schermata 3) l'ho ottenuta dopo aver lanciato Alsamixergui.
Cita messaggio
#4
Nelle schermate parecchie uscite sono con "MM". Escludendo quelle con la scritta "Mic" sarebbe il caso che siano "00" tutte.
Cita messaggio
#5
Esagerando le ho messe tutte a "00" (anche Mic) ho modificato anche "S/PDIF P" da PCM a IEC958, ma continua a non andare.
Cita messaggio
#6
Hai alzato i livelli audio delle uscite (minimo trattini bianchi)????
Se non sai come si fa, segui:
- potati con i cursori sulle linee;
- premi il tasto freccia alta;
- regola il volume come detto prima.
Cita messaggio
#7
Ho dimenticato una cosa. Dopo le operazioni devi dare il comando:
Codice:
sudo alsactl store
Cita messaggio
#8
Ho controllato e sistemato i volumi di tutte le uscite regolabili e ho dato il comando "sudo alsactl store".
Purtroppo ancora niente.
Grazie comunque della tua disponibiltà.

PS: guardando in altri forum ho visto che non sono l'unico ad avere simili problemi e non ho visto ancora soluzioni.
Cita messaggio
#9
Fai un tentativo da terminale dai

Codice:
sudo gedit /etc/modprobe.d/alsa-base.conf
nel file aggiungi
Codice:
options snd-hda-intel model=auto
Salva, chiudi, riavvia

Ora controlla dalle impostazioni audio,se ti permette di selezionare l'uscita digitale

Cita messaggio
#10
Seguendo le indicazioni di Brunik da terminale ho dato i comandi indicati e poi sono andato in "sistema/preferenze/audio" e da "preferenze dell'audio/hardware" ho scelto "Digital stereo duplex (IEC958)" ed ora l'uscita SPDIF funziona.
Unica cosa:
mi confermate che è normale che l'uscita analogica interna (cuffie) non funzioni più e, quindi, che di volta in volta si debba scegliere l'uscita (digitale o analogica) che si vuole ascoltare e che non è possibile ottenere le due uscite contemporaneamente?

PS: prima dell'intervento consigliatomi da Brunik, andando in "sistema/preferenze/audio" in "preferenze dell'audio/hardware", mi sembra che tra le opzioni ci fosse anche "Digital stereo duplex (IEC958)" ma che, anche scegliendolo non succedeva nulla.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)