Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] wifi non funziona
#1
Salve a tutti!
Mi hanno installato MAJONIX no pae su un portatile Fujitsu Siemens amilo 1405 eliminando definitivamente XP. E' stata una rivelazione e l'aspetto mi piace anche più di Ubuntu. Quindi tutto OK, eccetto che per la scheda wifi; non funziona e mi lega al cavo. Questo mi mostra il terminale al comando sudo lshw -c network:

raffaello@raffaello-AMILO-M1405:~$  lshw -c network
WARNING: you should run this program as super-user.
  *-network:0 DISABLED    
       description: Wireless interface
       product: PRO/Wireless 2200BG [Calexico2] Network Connection
       vendor: Intel Corporation
       physical id: 7
       bus info: pci@0000:01:07.0
       logical name: eth1
       version: 05
       serial: 00:0e:35:de:90:f1
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.5.27 (Dec 12 2007) latency=64 maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
       resources: irq:19 memory:e00fe000-e00fefff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: c
       bus info: pci@0000:01:0c.0
       logical name: eth0
       version: 10
       serial: 00:03:0d:24:cb:69
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.2 latency=64 maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:19 ioport:c800(size=256) memory:e00fd400-e00fd4ff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
raffaello@raffaello-AMILO-M1405:~$

Un grazie anticipato per chi mi aiuta.
Cita messaggio
#2
Salve,prova dando da terminale un comando per volta

Codice:
sudo apt-get install linux-firmware

sudo modprobe -r ipw2200

sudo modprobe ipw2200

Cita messaggio
#3
(05-05-2014, 16:00 )'brunik' Ha scritto: Salve,prova dando da terminale un comando per volta


Codice:
sudo apt-get install linux-firmware

sudo modprobe -r ipw2200

sudo modprobe ipw2200



...ecco cosa appare:

raffaello@raffaello-AMILO-M1405:~$ sudo apt-get install linux-firmware
[sudo] password for raffaello:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
linux-firmware è già alla versione più recente.
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  thunderbird-globalmenu python-pyudev gir1.2-json-1.0 realpath
  gir1.2-timezonemap-1.0 gir1.2-gstreamer-0.10 archdetect-deb libglew1.6
  python-pyicu libdebian-installer4 rdate firefox-globalmenu libtiff-tools
  btrfs-tools localechooser-data apt-clone libtimezonemap1 gir1.2-xkl-1.0
  dpkg-repack libdebconfclient0 libgtkglext1 openjdk-7-jre-lib
Usare "apt-get autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
raffaello@raffaello-AMILO-M1405:~$ sudo modprobe -r ipw2200
raffaello@raffaello-AMILO-M1405:~$ sudo modprobe ipw2200
raffaello@raffaello-AMILO-M1405:~$


 
Cita messaggio
#4
Shy Dai comandi precedenti si legge network:0 DISABLED ,prova ora a dare

rfkill list all
Poi anche
sudo ifconfig wlan0 up

Cita messaggio
#5
eccomi!!!
raffaello@raffaello-AMILO-M1405:~$ rfkill list all
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
raffaello@raffaello-AMILO-M1405:~$ sudo ifconfig wlan0 up
[sudo] password for raffaello:
wlan0: ERRORE leggendo i flag dell'interfaccia: Nessun device corrisponde
raffaello@raffaello-AMILO-M1405:~$


 
Cita messaggio
#6
rimuovi il modulo
sudo modprobe -r ipw2200


e ricalicalo
sudo modprobe -v ipw2200
 
Cita messaggio
#7
raffaello@raffaello-AMILO-M1405:~$ sudo modprobe -r ipw2200
[sudo] password for raffaello:
raffaello@raffaello-AMILO-M1405:~$ sudo modprobe -v ipw2200
insmod /lib/modules/3.2.0-36-generic/kernel/net/wireless/lib80211.ko
insmod /lib/modules/3.2.0-36-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.2.0-36-generic/kernel/drivers/net/wireless/ipw2x00/libipw.ko
insmod /lib/modules/3.2.0-36-generic/kernel/drivers/net/wireless/ipw2x00/ipw2200.ko
raffaello@raffaello-AMILO-M1405:~$

 ancora nulla...
Cita messaggio
#8
La scheda wireless la identifica con logical name: eth1 quindi proviamo ora dando da terminale

Codice:
sudo ifconfig eth1 up && sudo iwlist scan

Ps
Intanto,se via cavo riesci a connetterti,cerca di aggiornare comunque il sistema.

Cita messaggio
#9
...quando ormai non ci speravo più...ho acceso il pc con il cavo di rete scollegato; all'apertura della schermata è apparsa una finestrella in basso a destra che mi diceva che dal menu potevo scegliere una connessione senza fili! Vado nel menu e contemporaneamente stappo lo spumante ma...niente, non trovo una applicazione che mi dia l'elenco di queste benedette reti wireless [Immagine: http://www.istitutomajorana.it/forum/ima...fascio.gif][Immagine: http://www.istitutomajorana.it/forum/ima...fascio.gif][Immagine: http://www.istitutomajorana.it/forum/ima...fascio.gif]
 
Cita messaggio
#10
L'applicazione è il network manager, si trova l'applet nella barra, se non c'è basta digitare nm-applet.
Giuseppe
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)