Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Riconoscimento scheda audio Tascam US-122
#1
Ciao a tutti! 

Ho installato la scheda audio Tascam US-122 seguendo questa guida (dato che con questa non sono mai arrivato da nessuna parte...).
La scheda è riconosciuta (luce verde accesa), dopo avere dato il comando


Codice:
sudo usx2yloader

Infatti


Codice:
cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_usb_usx2y
 2 saa7134_alsa

cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7f10000 irq 50
 1 [USX2Y          ]: USB US-X2Y - TASCAM US-X2Y
                      TASCAM US-X2Y (1604:8007 if 0 at 001/005)
 2 [SAA7134        ]: SAA7134 - SAA7134
                      saa7133[0] at 0xf7e00000 irq 16

La HDA-Intel è la scheda audio integrata, la SAA7134... non lo so: altre schede audio non ne ho installate, quindi non so di preciso cosa sia.
Comunque... il problema è che non sono riuscito a trovare il modo di fare andare effettivamente la scheda. Metto qualche immagine per fare capire:
-Impostazioni di sistema->Audio->Uscita
[Immagine: http://forum.ubuntu-it.org/download/file...&mode=view]
-Impostazioni di sistema->Audio->Ingresso
[Immagine: http://forum.ubuntu-it.org/download/file...&mode=view]
Cioè mentre in ingresso la scheda viene riconosciuta (ed effettivamente funziona riproducendo il segnale audio che gli do (da una tastiera)), in uscita non c'è (e posso usare soltanto la scheda integrata della Intel per ascoltare qualche cosa presente sul computer).

Ho cercato in giro come cambiare le priorità delle schede audio e ho provato a fare come indicato qua nella sezione Gestione di più schede audio, in fondo. Non è cambiato niente.

Utilizzando il comando alsamixer chiedendogli di usare la Tascam US-122 come scheda audio predefinita mi dice che "Questo dispositivo audio non dispone di alcun controllo." (come deve essere) ma non trovo il modo di mantenerla come scheda predefinita.

Ho provato a disattivare tutte le schede audio che non fossero la Tascam aggiungendole al file /etc/modprobe.d/blacklist.conf, ma anche in questo caso la situazione non cambia: tutto ok per l'ingresso, nulla di fatto per l'uscita.

Della guida che ho linkato anche all'inizio ho provato anche a seguire
Citazione:ubuntu-drivers are working with usb 2.0 and the US-122 is with usb1.1. This can be solved by unloading usb2.0 functionality:


Codice:
sudo rmmod ehci_hcd

ma il risultato è sempre


Codice:
rmmod: ERROR: Module ehci_hcd is builtin.
anche se la scheda è disconnessa.

Ovviamente può essere che abbia sbagliato qualche cosa nell'installazione (rispetto alla guida ho usato il firmware aggiornato, quello alla versione 1.0.28) oppure in qualcuna delle procedure seguite... ma non so dove!

Scusate la lungaggine...! Essendo nuovo di Ubuntu mi scuso anche per eventuali castronerie scritte!

Già mille grazie a chi mi potrà dare qualche dritta!

 

 
Cita messaggio
#2
Ciao,
Io uso Ubuntu 14.04 LTS 64 bit ed ho seguito la guida:
https://help.ubuntu.com/community/TASCAM_US-122
(che con Ubuntu 10.04 funzionava benissimo)
ma mi son ritrovato nella tua stessa situazione!!!

premesso che qualche passaggio potrebbe essere superfluo
perchè ho preso le informazioni da diversi forum....

ho risolto così:

da terminale:
[bgcolor=#FFA07A]sudo apt-get install linux-lowlatency[/bgcolor]

da terminale:
[bgcolor=#FFA07A]lsmod | grep "^snd_" | column -t[/bgcolor]

Il risultato nel mio caso è:

snd_seq_dummy          12798   0
snd_usb_usx2y          32686   2
snd_usbmidi_lib        25070   1  snd_usb_usx2y
snd_hda_codec_hdmi     46368   1
snd_hda_codec_realtek  65580   1
snd_hda_intel          52306   3
snd_hda_codec          192906  3  snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              13602   2  snd_usb_usx2y,snd_hda_codec
snd_pcm                102040  4  snd_usb_usx2y,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         18710   3  snd_usb_usx2y,snd_pcm,snd_hda_intel
snd_seq_midi           13324   0
snd_seq_midi_event     14899   1  snd_seq_midi
snd_rawmidi            30095   2  snd_usbmidi_lib,snd_seq_midi
snd_seq                61560   3  snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_seq_device         14497   4  snd_seq,snd_rawmidi,snd_seq_dummy,snd_seq_midi
snd_timer              29433   2  snd_pcm,snd_seq

I moduli effettivi in genere sono quelli che non hanno moduli collegati a destra, e che non hanno "coded" nel nome. Nel mio caso: snd_usb_usx2y e snd_hda_intel.

A questo punto fai un file /etc/modprobe.d/alsa.conf

da terminale:
[bgcolor=#FFA07A]sudo gedit /etc/modprobe.d/alsa.conf[/bgcolor]

copia e incolla

[bgcolor=#AFEEEE]options snd slots=snd_usb_usx2y,snd_hda_intel[/bgcolor]
[bgcolor=#AFEEEE]options snd_usb_usx2y index=0[/bgcolor]
[bgcolor=#AFEEEE]options snd_hda_intel index=1[/bgcolor]

salva e chiudi.

dal gestore pacchetti synaptic installa:
[bgcolor=#AFEEEE]alsa-uitls-1.0.27.2[/bgcolor]
[bgcolor=#AFEEEE]libasound2-1.0.27.2[/bgcolor]

[bgcolor=#ff0000]riavvia il pc[/bgcolor]

[bgcolor=#FFA07A]PROCEDIMENTO PER TUTTE LE VOLTE CHE SI VUOLE USARE LA US-122[/bgcolor]

da terminale:
[bgcolor=#FFA07A]sudo usx2yloader[/bgcolor]

la luce diventa verde ma nelle impostazioni audio potrebbe
ancora non vedersi....

a questo punto stacca il cavo USB della scheda dal PC e riconnettilo,
(la luce verde si attiva in automatico)

nelle impostazioni audio dovrebbe essere vista e selezionandola
dovrebbe funzionare correttamente sia in ingresso che in uscita,
in caso contrario prova a riavviare il pc con il cavo USB collegato
e ripeti l'ultimo PROCEDIMENTO.


fammi sapere se hai risolto....
saluti
jaeck

 

 

 

 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)