Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Risolto] Gestore aggiornamenti Kubuntu. Problema con libcoin60
#1
Ciao a tutti.
Ho il seguente problema o anomalia.
Il gestore aggiornamenti fallisce a causa del "libcoin60".
Vedi schermata1.png.

Ho provato a rimuovere libcoin60 tramite il "gestore pacchetti Muon" ma non vi sono riuscito (vedi schermata2.png).

Avete qualche consiglio da darmi ?
Grazie.


Allegati Anteprime
       
Cita messaggio
#2
Huh
Hai provato invece che rimuoverlo a rinstallarlo ?

Cita messaggio
#3
Il gestore di pacchetti MUON (cliccando tasto destro sul file libcoin60) mi da come attive solo le soluzioni:
- seleziona per rimozione
- seleziona per la pulizia
- blocca alla versione attuale.
l'opzione - "seleziona per la re-installazione" non è attiva.

Ovviamente ho provato a rimuoverlo ed è apparso il messaggio:

Si è verificato un errore durante l'applicazione delle modifiche:

Dettagli:
libcoin60
Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.

Vi è un altro modo per reinstallarlo ?
Cita messaggio
#4
(22-06-2013, 11:43 )Hal9 Ha scritto: Il gestore di pacchetti MUON (cliccando tasto destro sul file libcoin60) mi da come attive solo le soluzioni:
- seleziona per rimozione
- seleziona per la pulizia
- blocca alla versione attuale.
l'opzione - "seleziona per la re-installazione" non è attiva.

Ovviamente ho provato a rimuoverlo ed è apparso il messaggio:

Si è verificato un errore durante l'applicazione delle modifiche:

Dettagli:
libcoin60
Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.

Vi è un altro modo per reinstallarlo ?


da console utente

sudo dpkg --force-all --configure -a
sudo apt-get -f clean
sudo apt-get update
sudo apt-get -f dist-upgrade

Senza fare prima l' update , è nella norma che l' upgrade possa restituire errori
Cita messaggio
#5
Alla fine del 4 comando ho il seguente messaggio:

È necessario scaricare 3064 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare [S/n]? s
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu/ raring/universe libcoin60 i386 3.1.3-2.2 [3064 kB]
Recuperati 3064 kB in 25s (118 kB/s)
dpkg: errore nell'elaborare libcoin60 (--configure):
Il pacchetto si trova in uno stato di inconsistenza critico - è consigliato
reinstallarlo prima di tentare la configurazione.
Si sono verificati degli errori nell'elaborazione:
libcoin60
E: Sub-process /usr/bin/dpkg returned an error code (1)

Non mi sembra normale..???
Cita messaggio
#6
Forse per reinstallarlo è sufficiente forzarne l'installazione

Codice:
sudo apt-get install --force libcoi60

Bada bene che la mia è una domanda ... se vuoi provare non credo che possa far danni ... al massimo non va a buon fine!
Cita messaggio
#7
Il comando
sudo apt-get install --force libcoi60
non funziona. In questo contesto --force è:

E: Opzione a riga di comando --force non comprensibile

Ho provato il comando
sudo apt-get install libcoi60
con il seguente risultato:

Lettura elenco dei pacchetti... Fatto
Generazione hal9 delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto libcoi60

L'anomalia rimane.
Ad ogni aggiornamento compare la scritta:
__________________________________________________
Si è verificato un errore durante l'applicazione delle modifiche:
libcoin60
Package is in a very bad inconsistent state - you should reinstall it before attempting configuration.
__________________________________________________
Faccio una ulteriore domanda.
Ho letto che libcoin60 è una libreria per OpenGL, non è che per caso non riesco a reinstallarla perchè in uso dal sistema ?

Ciao
Cita messaggio
#8
Prova a cancellarlo con
sudo dpkg --remove --force-remove-reinstreq libcoin60
Poi rinstalli
sudo apt-get install libcoin60

Cita messaggio
#9
Eseguo comando
$ sudo dpkg --remove --force-remove-reinstreq libcoin60
[sudo] password for hal9:

Il sistema risponde con:

dpkg: attenzione: viene ignorato il problema poiché è usata l'opzione --force:
Il pacchetto si trova in uno stato di inconsistenza grave - è
necessario reinstallarlo prima di rimuoverlo.
(Lettura del database... 262326 file e directory attualmente installati.)
Rimozione di libcoin60...
Elaborazione dei trigger per libc-bin...
ldconfig deferred processing now taking place

Lancio il comando
sudo apt-get install libcoin60

Il sistema risponde con:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
linux-headers-3.8.0-19 linux-headers-3.8.0-19-generic linux-image-3.8.0-19-generic
linux-image-extra-3.8.0-19-generic
Usare "apt-get autoremove" per rimuoverli.
Pacchetti suggeriti:
libsimage-dev libopenal0a
I seguenti pacchetti NUOVI saranno installati:
libcoin60
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 0 B/3064 kB di archivi.
Dopo quest'operazione, verranno occupati 9062 kB di spazio su disco.
Selezionato il pacchetto libcoin60 non precedentemente selezionato.
(Lettura del database... 262321 file e directory attualmente installati.)
Estrazione di libcoin60 (da .../libcoin60_3.1.3-2.2_i386.deb)...
Configurazione di libcoin60 (3.1.3-2.2)...
Elaborazione dei trigger per libc-bin...
ldconfig deferred processing now taking place

Al prossimo aggiornamento software vi so dire se l'operazione è riuscita.
Grazie
Ciao
Cita messaggio
#10
La soluzione sopra descitta risolve il problema.
Per maggiori informazioni (future) ho anche scoperto che il problema è nato dopo l'instalazione del programma FreeCAD e della sua successiva disinstallazione.
Grazie
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)