Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
TP-Link TL-WDN3200
#1
Buona sera
Ho acquistato una pennina usb per il collegamento wireless per un lapttop.
Purtroppo il CD di installazione driver,funziona solo con sistemi operativi Windows.
Dove trovo i driver e modalità di istallazione per Linux e derivate??
Ho visitato il sito della casa costruttrice,ma non ho trovato,o meglio,non ho capito quali pacchetti scaricare e come installarli per Linux
Come si risolve?
Grazie a chi mi aiuta
Cita messaggio
#2
I driver da scaricare dovrebbero essere questi gia editati
DPO_RT5572_LinuxSTA_2.6.0.1_20120629_EDITED.tar.bz2.bz2
Ora spostati nella cartella Scaricati
Codice:
cd Scaricati
Decomprimi con
Codice:
tar xvf DPO_RT5572_LinuxSTA_2.6.0.1_20120629_EDITED.tar.bz2.bz2
Quindi dai
Codice:
cd DPO_RT5572_LinuxSTA_2.6.0.1_20120629
Poi
Codice:
sudo make
Infine installa i driver con
Codice:
sudo make install

Cita messaggio
#3
(15-11-2013, 23:56 )brunik Ha scritto: I driver da scaricare dovrebbero essere questi gia editati
DPO_RT5572_LinuxSTA_2.6.0.1_20120629_EDITED.tar.bz2.bz2
Ora spostati nella cartella Scaricati
Codice:
cd Scaricati
Decomprimi con
Codice:
tar xvf DPO_RT5572_LinuxSTA_2.6.0.1_20120629_EDITED.tar.bz2.bz2
Quindi dai
Codice:
cd DPO_RT5572_LinuxSTA_2.6.0.1_20120629
Poi
Codice:
sudo make
Infine installa i driver con
Codice:
sudo make install
Buon giorno.
Fatte le operazioni indicate,ma il laptop,ancora non vede il collegamento wireless
Nel settaggio ho dato:
SSID il nome della pennnina TP-Link TL-WDN3200
per il resto ho rimasto tutto come di default
Ho spuntato solo,connessione sutomatica e connessione avviabile da tutti gli utenti.
Ho riavviato il laptop,ma niente,non si collega al router che ho in funzione
Cita messaggio
#4
Riprova dando sudo modprobe rt5572sta

(Fai sapere che versione di ubuntu stai usando)

Cita messaggio
#5
(16-11-2013, 12:25 )brunik Ha scritto: Riprova dando sudo modprobe rt5572sta

(Fai sapere che versione di ubuntu stai usando)
Dopo sudo make?? oppure prima??Huh
Cita messaggio
#6
I driver dovrebbero essere gia installati,quindi la fase (make-sudo make install)è superata.
Ora prova a dare solo sudo modprobe rt5572sta.
Se non si risolve,il problema potrebbere aver due cause
1) i driver non sono esatti o non vanno bene per la versione in uso (fai sapere quale )
2) occorrono ulteriori configurazioni.

Prima di cambiare driver ,prova ad aprire il file da terminale
Codice:
gedit os/linux/config.mk
Controlla se presenti le linee

#Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y

# Support Native WpaSupplicant for Network Manager
Has_native_WPA_SUPPLICANT_SUPPort=y

In pratica vedi che devono essere impostate su y
Salva chiudi gedit,riavvia

Cita messaggio
#7
(16-11-2013, 15:02 )brunik Ha scritto: I driver dovrebbero essere gia installati,quindi la fase (make-sudo make install)è superata.
Ora prova a dare solo sudo modprobe rt5572sta.
Se non si risolve,il problema potrebbere aver due cause
1) i driver non sono esatti o non vanno bene per la versione in uso (fai sapere quale )
2) occorrono ulteriori configurazioni.

Prima di cambiare driver ,prova ad aprire il file da terminale
Codice:
gedit os/linux/config.mk
Controlla se presenti le linee

#Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y

# Support Native WpaSupplicant for Network Manager
Has_native_WPA_SUPPLICANT_SUPPort=y

In pratica vedi che devono essere impostate su y
Salva chiudi gedit,riavvia
Domani mattina provo e vedo se riesco a risolvere.
(Su windows,mi riconosce il collegamento direttamente.Ho contattato la casa costruttrice e,mi dice che la pennina che ho acquistato non è compatibile con Linux,ma io non ci credo.Ci deve essere un modo per farla andare!!)
Cita messaggio
#8
(16-11-2013, 18:05 )marinaiomec Ha scritto:
(16-11-2013, 15:02 )brunik Ha scritto: I driver dovrebbero essere gia installati,quindi la fase (make-sudo make install)è superata.
Ora prova a dare solo sudo modprobe rt5572sta.
Se non si risolve,il problema potrebbere aver due cause
1) i driver non sono esatti o non vanno bene per la versione in uso (fai sapere quale )
2) occorrono ulteriori configurazioni.

Prima di cambiare driver ,prova ad aprire il file da terminale
Codice:
gedit os/linux/config.mk
Controlla se presenti le linee

#Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y
# Support Native WpaSupplicant for Network Manager
Has_native_WPA_SUPPLICANT_SUPPort=y

In pratica vedi che devono essere impostate su y
Salva chiudi gedit,riavvia
Domani mattina provo e vedo se riesco a risolvere.
(Su windows,mi riconosce il collegamento direttamente.Ho contattato la casa costruttrice e,mi dice che la pennina che ho acquistato non è compatibile con Linux,ma io non ci credo.Ci deve essere un modo per farla andare!!)
Allora :
I due supporti che indichi,sono impostati sulla=y
Il comando mdprobe rt5572sta
mi dice FATAL: module rt5572 not found
Cita messaggio
#9
Allora (se fai sapere che versione di ubuntu è installata è meglio )
Poi possiamo provare a risolvere installando i driver-backports
Da terminale dai
Codice:
sudo apt-get install build-essential
Scarica
http://www.kernel.org/pub/linux/kernel/p...-1.tar.bz2
Click destro apri con gestore archivi,estrai e lascia selezionata cartella scaricati
Spostati col terminale nella nuova cartella backports-3.11-rc3-1 dando
Codice:
cd Scaricati/backports-3.11-rc3-1/
Quindi un comando per volta continua con

make defconfig-wifi
make
sudo make install
sudo modprobe -r rt5572sta
sudo modprobe rt2800usb

Cita messaggio
#10
(18-11-2013, 17:51 )brunik Ha scritto: Allora (se fai sapere che versione di ubuntu è installata è meglio )
Poi possiamo provare a risolvere installando i driver-backports
Da terminale dai
Codice:
sudo apt-get install build-essential
Scarica
http://www.kernel.org/pub/linux/kernel/p...-1.tar.bz2
Click destro apri con gestore archivi,estrai e lascia selezionata cartella scaricati
Spostati col terminale nella nuova cartella backports-3.11-rc3-1 dando
Codice:
cd Scaricati/backports-3.11-rc3-1/
Quindi un comando per volta continua con

make defconfig-wifi
make
sudo make install
sudo modprobe -r rt5572sta
sudo modprobe rt2800usb
La versione Ubuntu installata è la 10.04 della Canonical.
Procedo con le indicazioni che mi hai dato??
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)