Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 2 voto(i) - 4 media
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu, montare automaticamente una partizione all'avvio
#1
Ecco come: http://www.lffl.org/2012/02/ubuntu-monta....html#more
Cita messaggio
#2
Un saluto a tutti Smile,
ho sostituito la 11.10 Plus 8 Remix con la 12.04 Plus 9 Remix.
Tutti i miei dati sono su una partizione ntfs montata in /media/Dati e dato che ho sempre avuto la necessita' di montarla come prima operazione, ho ceduto alla tentazione di rendere automatico il montaggio tramite ntfs-config, ma mi sono trovato un problemino per il quale chiedo istruzioni per non andare a peggiorare la cosa. Per l'nstallazione di ntfs-config ho usato il terminale, seguendo le informazioni trovate in un sito Web. All'apertura del programma, in una finestra mi ha evidenziato tutte le partizioni non montate, trovate nei due HD presenti nel computer. Ho messo la spunta su /media/Dati e ho dato l'invio, ma a questo punto il programma mi ha segnalato un errore. Sono quindi andato a vedere il file fstab contenuto in etc/ ed ho visto che l'originale e' stato rinominato fstab-ntfs-config-save e ne e' stato generato uno nuovo con all'interno i riferimenti alle varie partizioni e HD.
Ho provato a spegnere il computer ma alla riaccensione, mentre carica il Sistema Operativo, nella parte inferiore del monitor, sotto la barra di riempimento, mi appare la seguente scritta:

Keys: Attendere oppure premere S per omettere il mount o M per il ripristino manuale.

Se non faccio nulla non si muove dalla pagina, premendo S mi presenta la schermata per l'inserimento della password. Digitandola, mi entra nella scrivania, tutte le partizioni sono montate (non solo quella richiesta) ma dopo pochi secondi mi appare una finestrella d'avviso che ntfs-config si e' chiuso inaspettatamente... dopo di che tutto sembra funzionare correttamente, salvo ripetere le stesse cose ad ogni accensione.

Inizialmente avevo pensato di disinstallare ntfs-config e ripristinare il file fstab originale, con l'intento di riportare il sistema alle condizioni iniziali (ma dato che non so nulla di Ubuntu, potrebbero essere stati modificati altri files), ed eventualmente riprovare il montaggio automatico con il programma Disk Manager che, da ricerche fatte in seguito sembrerebbe migliore.

Poi ho pensato che sarebbe stato meglio rivolgermi al forum senza rischiare oltre. Quindi, allego il file fstab originale-rinominato, e quello creato da ntfs-config nella speranza che qualcuno possa darmi qualche consiglio.

-------------- inizio file fstab originale ---------------

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda9 during installation
UUID=24e1658e-2e02-421e-964b-497c2f1e5213 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda6 during installation
UUID=42fc2cc9-a0dc-45ce-8639-e5b29128ade0 none swap sw 0 0


-------------- fine file fstab originale ---------------

-------------- inizio file fstab modificato ---------------


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sda9 :
UUID=24e1658e-2e02-421e-964b-497c2f1e5213 / ext4 errors=remount-ro 0 1
#Entry for /dev/sda5 :
UUID=542C3F6E2D5777AD /media/Dati ntfs defaults,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177 0 0
#Entry for /dev/sdb1 :
UUID=ECC090D0C090A1FE /media/HD_2 ntfs defaults,nls=utf8,umask=0222 0 0
#Entry for /dev/sda1 :
UUID=5860899460897990 /media/Win\040XP ntfs defaults,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177 0 0
UUID=C68C48DF8C48CC1D /media/HD\040600\040GB\040Film ntfs defaults,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177 0 0
#Entry for /dev/sda6 :
UUID=42fc2cc9-a0dc-45ce-8639-e5b29128ade0 none swap sw 0 0


-------------- fine file fstab modificato ---------------



Un ringaziamento a tutti, Roberto
Cita messaggio
#3
grazie, doc! Eseguito ieri con successo
Un saluto a tutto il forum!
Cita messaggio
#4
RobertoPhuket ciao, da terminale scrivi sudo ntfs-config poi togli la spunta alle partizioni che non vuoi siano montate all'avvio del pc e riavvia.

Cita messaggio
#5
(10-05-2012, 12:20 )sg-1 Ha scritto: RobertoPhuket ciao, da terminale scrivi sudo ntfs-config poi togli la spunta alle partizioni che non vuoi siano montate all'avvio del pc e riavvia.

Ciao sg-1,
ti ringrazio della rapida risposta. Ho aperto ntfs-config con il comando da terminale che mi hai indicato, ho tolto la spunta alle partizioni che mi interessano poco, ma il programma, automaticamente, mi toglie la spunta anche a: Attiva il supporto in scrittura per dispositivi interni. Cliccando poi sul pulsante chiudi mi appare, come sempre, la finestra d'allarme che il programma si e' chiuso inaspettatamente.
Quindi ho lasciato com'e'.
Inoltre anche nel terminale, dopo le righe dell'esecuzione del comando, alla fine appare il seguente messaggio di errore:

Attribute Error: 'float' object has no attributes 'lower'

Ad ogni modo, se vengono caricate anche partizioni che uso molto saltuariamente non mi crea problemi, quello che mi preoccupa e' l'apparire della scritta:

Keys: Attendere oppure premere S per omettere il mount o M per il ripristino manuale.

... e dover premere S per poter proseguire con il caricamento di Ubuntu e arrivare alla schermata della password.

Quindi, per risolvere, posso ripristinare il file fstab originale e disinstallare ntfs-config?

Oppure la cosa e' un po' piu' complessa?

Un saluto a tutti, Roberto
Cita messaggio
#6
(10-05-2012, 13:26 )RobertoPhuket Ha scritto:
(10-05-2012, 12:20 )sg-1 Ha scritto: RobertoPhuket ciao, da terminale scrivi sudo ntfs-config poi togli la spunta alle partizioni che non vuoi siano montate all'avvio del pc e riavvia.

Ciao sg-1,
ti ringrazio della rapida risposta. Ho aperto ntfs-config con il comando da terminale che mi hai indicato, ho tolto la spunta alle partizioni che mi interessano poco, ma il programma, automaticamente, mi toglie la spunta anche a: Attiva il supporto in scrittura per dispositivi interni. Cliccando poi sul pulsante chiudi mi appare, come sempre, la finestra d'allarme che il programma si e' chiuso inaspettatamente.
Quindi ho lasciato com'e'.
Inoltre anche nel terminale, dopo le righe dell'esecuzione del comando, alla fine appare il seguente messaggio di errore:

Attribute Error: 'float' object has no attributes 'lower'

Ad ogni modo, se vengono caricate anche partizioni che uso molto saltuariamente non mi crea problemi, quello che mi preoccupa e' l'apparire della scritta:

Keys: Attendere oppure premere S per omettere il mount o M per il ripristino manuale.

... e dover premere S per poter proseguire con il caricamento di Ubuntu e arrivare alla schermata della password.

Quindi, per risolvere, posso ripristinare il file fstab originale e disinstallare ntfs-config?

Oppure la cosa e' un po' piu' complessa?

Un saluto a tutti, Roberto
Ciao, in fstab modificato metti il # davanti all uuid delle partizioni non tutte solo quelle che ti posto, le altre lasciale come sono, cosi la stringa risulta solo commentata e non attiva, prova e vediamo come si comporta, salva prima di uscire.

#Entry for /dev/sdb1 :
#UUID=ECC090D0C090A1FE /media/HD_2 ntfs defaults,nls=utf8,umask=0222 0 0
#Entry for /dev/sda1 :
#UUID=5860899460897990 /media/Win\040XP ntfs defaults,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177 0 0
#UUID=C68C48DF8C48CC1D /media/HD\040600\040GB\040Film ntfs defaults,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177 0 0
Cita messaggio
#7
Ciao sg-1, Exclamation
ho seguito le tue ultime indicazioni e tutto e' tornato perfetto: non mi chiede piu' di intervenire mentre carica Ubuntu, e' montata solo la partizione richiesta e non appare la finestra che mi dice ntfs-config si e' chiuso inavvertitamente.

Ora faccio un po' di pulizia seguendo le indicazioni del prof. e poi mi masterizzo una immagine su DVD con Remastersys... tanto per mettermi al sicuro Exclamation

Grazie mille dell'aiuto, metto [Risolto] sul titolo.

Ancora un saluto a tutti, Roberto
Cita messaggio
#8
Shy oops... la discussione non l'ho aperta io, quindi credo che non debbo mettere RISOLTO

O no?
Cita messaggio
#9
(10-05-2012, 15:43 )RobertoPhuket Ha scritto: Shy oops... la discussione non l'ho aperta io, quindi credo che non debbo mettere RISOLTO

O no?
È vero, togli risolto. Ciao.
Cita messaggio
#10
salve a tutti
io ho lo stesso problema ... però la situazione è diversa. Ho installato linux Mint 15 Mate per prova e devo dire che mi ci trovo benone.
Praticamente un paio di giorni fa ho provato ad installare grub 2 tramite il gestore applicazioni (sotto tale applicazione c'è scritto che si poteva rimuovere senza problemi) ma dal riavvio successivo, alla prima schermata con il logo di linux Mint, mi compare in alto la stessa dicitura : "Keys: attendere oppure premere S per omettere il mount o M per il ripristino manuale" .
Se attendo ... non va più avanti con il caricamento ... se clicco su M mi compare il terminale ma non so più come procedere ... se clicco S prosegue con il normale caricamento ... ho provato a disinstallare grub2 ... ma ormai il problema persiste ... qualcuno sa da che cosa possa essere causato ?
Grazie mille a chi mi può aiutare ...
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)