Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
crontab -e da terminale
#1
Question 
Buona sera. Come da oggetto lancio da terminale, su un pc desktop, il comando crontab -e per inserire i parametri di backup con "backintime" ma il terminale mi restituisce un numero tipo 1805 e il cursore lampeggiante invece di aprirmi l'editor e settare i parametri.
Aggiungo che lo stesso comando sul notebook mi restituisce l'editor dove setto i parametri e tutto va per il verso giusto.
S.O. ubuntu 10.10 del prof su entrambi i pc.
Spero di essere stato chiaro.
Grazie per le risposte.
Cita messaggio
#2
Meglio sarebbe avere conoscenza esatta del codice di errore (dato dal numero o dai due numeri [più spesso] che hai visto). Comunque sia, guarda se in questa discussione (in lingua inglese) trovi un'idea che ti può consentire di risolvere.
[Immagine: http://www.pic4ever.com/images/2mpe5id.gif]Un poeta può sopravvivere a tutto tranne che ad un errore di stampa.(Andy Wahrol)
Cita messaggio
#3
Nel link da te proposto non trovo la soluzione.
Inserisco du immagini del terminale recanti l'errore ed il list del cron; dove si vede che utilizzo sia il programma "luckybackup" che "backintime".
Nella home ho spulciato nella cartella .luckybackup e nella sottocartella schedule ho trovato il file luckycron.txt; magari provo ad editare questo file per variare i parametri che m'interessano e vedre se risolvo.
Ti farò sapere.


Allegati Anteprime
       
Cita messaggio
#4
A guardare la seconda immagine postata, sembra potrebbe entrarci un problema di "permessi"...
[Immagine: http://www.pic4ever.com/images/2mpe5id.gif]Un poeta può sopravvivere a tutto tranne che ad un errore di stampa.(Andy Wahrol)
Cita messaggio
#5
Come anticipato ecco l'aggiornamento dello smanettamento.
Ho editato il file presente nella cartella .luckybackup ma niente da fare; il programma,backintime, non rispondeva come richiesto.
Allora ho aperto nautilus da root è ho modificato il file che si trova in /var/spool/cron/crontabs/nomeutente e ho riavviato. Il programma ha eseguito le indicazioni immesse. In ogni caso ho riaperto il terminale ridigitato per l'ennesima volta: crontab -e e stavolta l'errore dava 1807 anzichè 1805.
Quindi ho risolto in parte nel senso che il terminale si rifiuta di eseguire il comando per editare.
Cosa mi consigli di scrivere: [risolto parzialmente] o non scrivo niente?

Cita messaggio
#6
Non essendo "risolto" (lo sarebbe stato se fossimo riusciti a fornirti una indicazione tale da consentirti di fare quel che intendevi), direi che non ha senso scrivere "risolto".
Però, ci abbiam provato: sappilo. Non tutte le "ciambelle", purtroppo, riescono "col buco"... Big Grin
[Immagine: http://www.pic4ever.com/images/2mpe5id.gif]Un poeta può sopravvivere a tutto tranne che ad un errore di stampa.(Andy Wahrol)
Cita messaggio
#7
Vedi QUI se puoi configurare qualche opzione
o conferma solo gli errori Huh
Cita messaggio
#8
(01-09-2011, 22:46 )devil Ha scritto: Buona sera. Come da oggetto lancio da terminale, su un pc desktop, il comando crontab -e per inserire i parametri di backup con "backintime" ma il terminale mi restituisce un numero tipo 1805 e il cursore lampeggiante invece di aprirmi l'editor e settare i parametri.
Aggiungo che lo stesso comando sul notebook mi restituisce l'editor dove setto i parametri e tutto va per il verso giusto.
S.O. ubuntu 10.10 del prof su entrambi i pc.
Spero di essere stato chiaro.
Grazie per le risposte.

Prova a dare da terminale
Codice:
select-editor
per riassettare l'editor di crontab.

Bye
Token
Cita messaggio
#9
Scusate se riprendo adesso questa discussione ma, come scritto prima, avevo risolto in altro modo e quindi non ero più tornato a controllare altri suggerimenti.
Desidero ringraziare, oltre Monsee, sia Brunick che Token per i loro suggerimenti che non ho potuto testare in quanto successivamente ho reinstallato (per altri smanettamenti) l'immagine di sistema fatta tempo prima con clonezilla e il comando "crontab -e" è tornato a funzionare regolarmente.
Saluti.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)