Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
dpkg - configure -a
#1
Thumbs Down 
Buon giorno a tutti.
Il mio computer stava facendo gli aggiornamenti di upgrade quando si è bloccato a metà.
Ora non mi permette più di lanciare di nuovo il comando di "sudo apt-get upgrade" per completare il lavoro che stava facendo; mi dice di lanciare prima il comando "dpkg - configure -a"-
Scrivo nel terminale "$ dpkg - configure -a" mi da errore.
Scrivo "apt-get dpkg - configure -a" di nuovo errore.
Non so come fare, non so che comandi dargli per risolvere il blocco.

----
Un'altra cosa.
Quando dico di aggiornare "update" alla fine mi dà errore perchè non ha trovato le chiavi che ho aggiunto per fare funzionare il programma "freepops", come ha scritto sul loro sito un tale Marco.
Il programma freepops mi serve.

Grazie per le vostre preziose indicazioni.
Giovanna
Giovanni
----
Ubuntu 14.04 a 32 bit.
Cita messaggio
#2
ciao, dal terminale:
sudo apt-get -f install
al termine:
sudo apt-get-update
copia/incolla eventuali segnalazioni di errore.
Cita messaggio
#3
freepops lo trovi nei pacchetti di ubu, senza bisogno di ppa esterni
   
Cita messaggio
#4
Smile 
Buona sera Dxgiusti.
Quasi ci sono...
Ho seguito passo passo le tue indicazioni e ho installato tutti i freepops dal gestore pacchetti.
Alla fine ho dato di nuovo "update" e mi dice ancora:

W: Impossibile recuperare http://ppa.launchpad.net/marco/freepops/...6/Packages 404 Not Found

W: Impossibile recuperare http://ppa.launchpad.net/marco/freepops/...6/Packages 404 Not Found

W: Impossibile recuperare http://ppa.launchpad.net/screenlets/ppa/...6/Packages 404 Not Found

E: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.
----------------

Sto cercando di aggiornare il computer perchè non mi funzionano i programmi per leggere i video .avi.
A ottobre sono passata da winXp a Ubuntu 13.10.
Prima con un programma o l'altro (in genere usavo Zoom Player) potevo vedere vari formati di cartoni animati o video scaricati da youtobe .avi, .mkw, .flv senza problemi.
Ora ho scaricato vari player video VLC, SMPlayer, Xine, Video, MPlayer. I flv sono senza audio, gli avi si bloccano dopo qualche minuto. Zoom Player mediante wine proprio non funziona (ma con wine funziona solo il blok notes e tutti gli altri programmi no).

Ieri ho provato anche ad installare tutti i codec seguendo una guida presente su questo sito ma i video non funzionano ugualmente.
Qualche consiglio in proposito?

Grazie a tutti per le indicazioni (terra terra) che mi vorrete dare. Arrendersi
Giovanni
----
Ubuntu 14.04 a 32 bit.
Cita messaggio
#5
Facevi due errori con dpkg:
1. Va dato da root
2. doppia lineetta per configure
# dpkg -- configure -a
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#6
ciao, una cosa alla volta. apri sorgenti software e nella finestra dei ppa elimina quelli relativi a freepops e quelli di screenlets.
ora dal terminale:
sudo nautilus /etc/apt/sources.list.d/
cerca sempre quelli relativi a freepops e screenlets, evidenziali, maiuscolo+canc, cancella.
ora ritorna al tuo terminale e riaggiorna:
sudo apt-get-update
se tutto ok, prosegui:
sudo apt-get dist-upgrade
per eventuali errori ( speriamo di no ) postali.
Cita messaggio
#7
(04-12-2013, 12:43 )'dxgiusti' Ha scritto: ciao, dal terminale:
sudo apt-get -f install
al termine:
sudo apt-get-update
copia/incolla eventuali segnalazioni di errore.

 
Anche oggi mi si è bloccato l'aggiornamento di oracle
Ho dato i comandi suggeriti da dxgiusti

Dopo il comando
sudo apt-get -f install

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Risorsa temporaneamente non disponibile
Configurazione di oracle-java8-installer (8b121-0~webupd8~0)...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Risorsa temporaneamente non disponibile
dpkg: errore nell'elaborare oracle-java8-installer (--configure):
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
 oracle-java8-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
-------------------
allora ho dato
sudo apt-get update
mi risponde

E: Impossibile impostare il blocco /var/lib/apt/lists/lock - open (11: Risorsa temporaneamente non disponibile)
E: Impossibile bloccare la directory /var/lib/apt/lists/

Come lo sblocco?
Grazie a tutti





 
Giovanni
----
Ubuntu 14.04 a 32 bit.
Cita messaggio
#8
(04-12-2013, 16:20 )'zafran' Ha scritto: Facevi due errori con dpkg:
1. Va dato da root
2. doppia lineetta per configure
# dpkg -- configure -a

 
Il comando intero è
sudo dpkg --configure -a
vero?


 
Giovanni
----
Ubuntu 14.04 a 32 bit.
Cita messaggio
#9
(06-01-2014, 20:04 )'Gian Maria' Ha scritto: Il comando intero è
sudo dpkg --configure -a
vero?
 
si

per il post precedente, il blocco te lo da perché hai aperto un altro programma che "gioca" con i pacchetti (ubuntu software center, synaptic, aggioramento software)


 

 
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)