Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
driver ati scheda video radeon hd 2400 pro
#1
Chiedo scusa se il mio primo post sarà  lungo ma voglio fornirvi quanti più elementi possibili per la soluzione della problematica, che come ho potuto appurare non riguarda solo me . Utilizzo da tempo e con grande soddisfazione le distro plus remix, in questo momento uno dei pc che uso per lavorare e sul quale è installata  una distro ubuntu plus 9 remix 32 bit 12.04.01 ha avuto dei problemi con i driver ATI restituendomi questo errore dopo gli aggiormamenti di Gennaio :

Si è verificato un problema durante l'inizializzazione del Catalyst Control Center nell'edizione Linux. Le cause potrebbero essere le seguenti.
Non è installato alcun driver grafico AMD oppure il driver AMD non funziona correttamente.
Si prega di installare il driver AMD adatto al vostro hardware AMD o di configurarlo usando anticonfig.

Aggiungo alcune info  per completezza:

Aggiornamenti del kernel : solo quelli proposti
 
Kernel in uso : 3.2.0-58-generic-pae

Versione di xOrg: X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-37-generic i686 Ubuntu
Current Operating System: Linux ubumabel 3.2.0-58-generic-pae #88-Ubuntu SMP Tue Dec 3 18:00:02 UTC 2013 i686


Scheda grafica : Radeon HD 2400 PRO

Proprio i driver Ati attivati con jockey dopo la prima installazione della iso e dei quali non sono riuscito a determinare la versione funzionante, dopo l'ultimo aggiornamento  hanno smesso di funzionare.
Nel tentativo di ripristinare ho dapprima disinstallato i driver propietari con i seguenti comandi:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

e poi provato a reinstallare gli updates con:

sudo apt-get install fglrx-updates

ma non ha funzionato per cui ho nuovamente disinstallato e attualmente stò usando questi senza grossi problemi:

sudo lshw -c display | grep driver

[sudo] password for xxxxxx:
       configuration: driver=radeon latency=0

glxinfo | grep render

direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD RV610
    GL_EXT_vertex_array_bgra, GL_NV_conditional_render,

Tuttavia vorrei capire per quale motivo non è più possibile installare i driver ATI attraverso jockey il quale non presenta piú alcun avviso di attivazione.
Azzardo una ipotesi poichè usando il pc per lavoro non posso permettermi di procedere per tentativi.
Forse gli aggiornamenti di Gennaio del driver Ati  non permettono più l'installazzione automatica del driver tramite jockey stesso, il motivo potrebbe essere che la versione del kernel presente nella distro di ubuntu 12.04.01 è inferiore alla vers 3.4 ??? infatti controllando sul sito della ATI si legge (AMD Catalyst propietary Linux x86 Display Driver Vers.13.1 Data rilascio 21/01/2013  Description: Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4).

Trovandomi quindi nella condizione di dover installare manualmente chiedo quale sia la procedura corretta per attivare i propietari ATI e quali siano a questo punto i driver funzionanti per la mia scheda video.
 
 Ringrazio tutti anticipatamente
 

 

 
Cita messaggio
#2
SE ti può consolare cmq i driver open che hai installato funzionano perfettamente compreso l'accelerazione grafica infatti è confermato dal risultato che hai postato e non ti daranno nessun problema

direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD RV610
GL_EXT_vertex_array_bgra, GL_NV_conditional_render

Vedi se questo link ti può essere utile
http://askubuntu.com/questions/204129/wh...on-2400-hd

Bilodiego
Cita messaggio
#3
[img]images/smilies/exclamation.gif[/img] Ti ringrazio  e volevo anche rincuorare i molti che hanno lo stesso problema confermando che comunque gli open funzionano bene almeno su questa scheda.
Speriamo comunque che in futuro gli aggiornamenti tengano conto di questi problemi.
Oppure bisognerebbe consigliare di mettere BLOCCA VERSIONE da synaptic una volta verificato il funzionamento dei driver.
Non metto risolto perchè voglio raccogliere materiale per una eventuale soluzione
Cita messaggio
#4
ma..Huh forse è il kernel e l'xserver che non andrebbe cambiato, che di conseguenza non essendo compatibile col relativo driver proprietario installa gli open.

Cmq qui ho trovato del materiale:

QUI tratta la tematica, nel medesimo ti rimanda
http://wiki.cchtml.com/index.php/Hardware
dove include anche che la tua scheda hd 2400 radeon in cui dice:
"ATI / AMD Catalyst inizialmente ha abbandonato il supporto per queste schede nel regolare Catalyst 12-6. Queste schede sono ora supportate con il successivo Catalyst rilasciato 13-1 legacy, ma è necessario utilizzare un kernel <= 3.4 e Xserver <= 1,12. Ad esempio, è possibile utilizzare Catalyst 13.1 legacy se si sta eseguendo Ubuntu 12.04 o Debian Squeeze/6.0. Il supporto open source è buono e 3D sta ancora migliorando."

Non so se vale la pena tutto ciò visto che appunto gli open sono soddisfacenti.

Bilodiego
Cita messaggio
#5
se interessa:
http://wiki.ubuntu-it.org/NewsletterItaliana/2014.006
io pero non sono riuscito a capire come scaricare il kernel
Cita messaggio
#6
Non ho mai avuti necessità di scaricare e cambiare il kernel in uso, salvo che leggere qualche guida in proposito, proprio adesso mi si è aggiornato firefox alla versione 27.
Bilodiego
Cita messaggio
#7
si anche a me, ho corretto il mio precedente.
Cita messaggio
#8
Credo proprio che volendo installare i driver Ati su questa versione di ubuntu senza passare ad un kernel 3.4 o superiori si dovrebbe per forza installare manualmente il driver 12.4 o 12.6 e bloccare la versione altrimenti ai prossimi aggiornamenti ci si troverebbe di nuovo daccapo.......ma io per ora non voglio . Comunque si accettano volentieri suggermenti

 
Cita messaggio
#9
Opps chiedo scusa per il doppio post ma sono con lo smartphone può succedere.
Cita messaggio
#10
ops, come mai un post doppio a distanza di dieci minuti, è un errore ?
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)