Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
fglrx-updates problemi con plymount e sistema
#1
Io è da parecchio che uso gli open sempre aggiornati, ( driver sempre aggiornati ) ed ho verificato che non ho problemi con i driver 3.11.xxx e nemmeno con l'ufficiale 3.2.xxx invece se metto gli updates se entro con il Kernel 3.11.xxx entra tranquillamente con il 3.2.xxx sfasa la immagine e non mi fa arrivare in fase di login, comunque anche se entro con la 3.11.xxx la plymount non appare perchè questo problema, perchè con il 3.2.xxx non entra, sicuri che i proprietari ultimamente siano meglio che gli open? Io vedo che gli Open non mi stanno dando alcun problema..
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#2
tutta varia da scheda a scheda. ti posso dire solo che, con la mia scheda (Radeon HD 6xxxM ) e con il kernel 3.2 (sia su Debian che su Ubuntu) i driver fglrx proprietari non sono il massimo e non sono esenti da bug o carenze grafiche, tuttavia sono molto meglio degli open. anche solo per il semplice fatto che con gli open ho temperature inaccettabili che mi avrebbero rovinato il portatile.

con lo sviluppo del kernel il supporto hardware va sempre migliorando, quindi ovviamente nel kernel 3.11 i driver open sono molto migliori che non nel "vecchio" 3.2, tuttavia non mi risulta che il "sorpasso" ai danni dei proprietari sia avvenuto o avverrà nel futuro. comunque, se usi gli open, si dicono meraviglie a proposito del kernel 3.12 attualmente in fase di sviluppo. penso che quando verrà rilasciato troverò il modo di provarlo su Debian.

riguardo ai problemi di visualizzazione di plymouth, è un bug noto, e ahimè il più delle volte bisogna tenerselo così com'è.
Il mio blog su Ubuntu: trucchi, consigli e guide

Notebook HP G62 con Debian Jessie (testing) Xfce
Samsung Galaxy Tab 2 con CyanogenMod 11
Samsung Galaxy W con CyanogenMod 9 
Cita messaggio
#3
A me gli open al massimo arrivano a 63 quando gioco con flash player, tempi fa l'errore mi era apparso, le scritte ad avvio, avevo gli open sempre aggiornati ho provato a mettere gli fglrx i quali mi davano errore ed ho rimesso gli open al riavvio le scritte che ho messo il link sopra per vederle, ho risolto reinstallando il kernel, questa volta invece nulla ho reinstallato ma gli errori permangono, chissà perché questa volta avendo fatto allo stesso modo dell'altra volta non ha risolto...
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#4
(17-10-2013, 15:13 )Bingol Ha scritto: A me gli open al massimo arrivano a 63 quando gioco con flash player, tempi fa l'errore mi era apparso mi riferisco alle scritte ad avvio, avevo gli open sempre aggiornati ho provato a mettere gli fglrx i quali mi davano errore ed ho rimesso gli open al riavvio le scritte che ho messo il link sopra per vederle, ho risolto reinstallando il kernel, questa volta invece nulla ho reinstallato ma gli errori permangono, chissà perché questa volta avendo fatto allo stesso modo dell'altra volta non ha risolto...

non so, io fossi in te utilizzerei sempre i driver presenti nei repo ufficiali della distribuzione (Ubuntu è testato per funzionare con essi, non con altri driver esterni o posteri), se proprio volessi tenerli sempre aggiornati allora installerei sempre l'ultima versione di Ubuntu disponibile oppure passerei a una distribuzione rolling così ti levi di dosso il problema degli aggiornamenti (ti vengono proposti in automatico senza bisogno di andare a cercare guide online).

forse adesso potresti provare a fare a ritroso i passi di quella guida, vale a dire reinstalli i vecchi driver open di default in ubuntu, fai pulizia di quelli nuovi, riavvii il kernel 3.2 e incrocia le dita.
Il mio blog su Ubuntu: trucchi, consigli e guide

Notebook HP G62 con Debian Jessie (testing) Xfce
Samsung Galaxy Tab 2 con CyanogenMod 11
Samsung Galaxy W con CyanogenMod 9 
Cita messaggio
#5
Il problema che vorrei togliere è questo http://www.istitutomajorana.it/forum/att...?aid=11305 non capisco cosa centrino gli open o kernel con questo problema sai per caso indicarmelo come indicavo prima l'altra volta ho reinstallato il driver e gli open e si è sistemato questa volta permane tal problema
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#6
(17-10-2013, 18:01 )Bingol Ha scritto: Il problema che vorrei togliere è questo http://www.istitutomajorana.it/forum/att...?aid=11305 non capisco cosa centrino gli open o kernel con questo problema sai per caso indicarmelo come indicavo prima l'altra volta ho reinstallato il driver e gli open e si è sistemato questa volta permane tal problema

come puoi leggere dalla tua foto, dallo svariato numero di volte in cui compare la scritta RADEON (è il nome dei driver open della tua scheda ati), si può dedurre che il problema risalga proprio a quei driver. Fossi in te toglierei il ppa che li aggiorna e riaggiornerei l'elenco pacchetti e il sistema stesso. Poi incrocerei le dita e riavvierei il pc, magari torna a funzionare Confused
Il mio blog su Ubuntu: trucchi, consigli e guide

Notebook HP G62 con Debian Jessie (testing) Xfce
Samsung Galaxy Tab 2 con CyanogenMod 11
Samsung Galaxy W con CyanogenMod 9 
Cita messaggio
#7
ma prima che non rimettessi gli fglrx-updates andava... Huh Ergo consigli di lasciare gli open aggiornati come ora ho e togliere la spunta sul PPA giusto poi fare aggiornamento sistema e riavviare?
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#8
Ho tolto il PPA e dava sempre quel errore ora ho provato a rimettere i driver sempre aggiornati ma esce un problema:

Codice:
sudo add-apt-repository ppa:oibaf/graphics-drivers
[sudo] password:
You are about to add the following PPA to your system:
PLEASE READ: don't email me to report bugs, unless you are sure it's a packaging bug. Not only is email not a good tool for tracking bugs, it also excludes anybody else from tracking or working on the issue. Please read the section "Debugging and reporting problems" below.

=============

Supported Ubuntu versions:
- 12.04 (precise)
- 12.10 (quantal)
- 13.04 (raring) - note: KDE 4.11 (from https://launchpad.net/~kubuntu-ppa/+archive/backports PPA) needs rebuilt kde-workspace packages available at https://launchpad.net/~oibaf/+archive/kde-wayland to properly work.

For forum support see: http://phoronix.com/forums/showthread.php?50038-Updated-and-Optimized-Ubuntu-Free-Graphics-Drivers

To support this PPA with a Paypal donation: https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=fmrummey%40gmail%2ecom&lc=US&item_name=Ubuntu%20Graphics%20Drivers%20PPA&item_number=PPA&currency_code=EUR&bn=PP%2dDonationsBF%3apaypal%2epng%3aNonHosted

=== Introduction ===
This PPA provides updated X (2D) and mesa (3D) free graphics drivers for radeon, intel and nvidia hardware. Updates packages provide:
 * OpenGL 3.2+ support (only some drivers) and new OpenGL extensions: http://cgit.freedesktop.org/mesa/mesa/plain/docs/GL3.txt
 * new 3D radeonsi driver with 2D GLAMOR acceleration (including Xv) working out-of-the-box (13.04 only)
 * optional GLAMOR acceleration on intel and radeon (>= r600) drivers (13.04 only)
 * r600 shader backend enabled by default (mesa 9.3)
 * improvements to performance and games support
 * XvMC and VDPAU Gallium3D accelerated video drivers (install the libg3dvl-mesa package) - including out-of-tree NV_vdpau_interop extension
 * PostProcessing, including MLAA: http://mesa3d.org/postprocess.html
 * gallium llvmpipe as the default software renderer rather than classic swrast
 * nouveau gallium (for newer GPU) and classic (for older GPU) drivers
 * i915 gallium drivers in the experimental package
 * custom OpenGL version string to make sure you are running drivers from this PPA

For more details check the changelogs.

=== Basic usage ===
See "Adding this PPA to your system" later on and update your Ubuntu with the package herein.

=== Using VDPAU/XvMC accelerated video ===
Supported XvMC drivers: softpipe, r300, r600, radeonsi, nouveau
Supported VDPAU drivers: softpipe, r300, r600, radeonsi, nouveau

* First you need to install the libg3dvl-mesa package:
sudo apt-get install libg3dvl-mesa

* Then to test the VDPAU driver with mplayer use:
for basic accelerated video output:
$ mplayer -vo vdpau yourvideofile
for accelerated video decoding (only some formats (i.e. mpeg2) are currently supported):
$ mplayer -vo vdpau -vc ffmpeg12vdpau yourvideofile

* To test the XvMC (e.g.) r600 driver edit the file /etc/X11/XvMCConfig and insert:
/usr/lib/dri/libXvMCr600.so

and restart the X server. Then to test it with mplayer:
mplayer -vo xvmc yourvideofile

=== Using alternative drivers ===
Example on how to run your OpenGL program (in this case glxgears -info) with non default drivers.

To use experimental i915 gallium driver, or classic swrast driver you need to install the experimental package:
$ sudo apt-get install libgl1-mesa-dri-experimental

To force the use of gallium llvmpipe software render:
$ LIBGL_ALWAYS_SOFTWARE=1 glxgears -info
To force the use of old non-gallium software render:
$ LIBGL_ALWAYS_SOFTWARE=1 LIBGL_DRIVERS_PATH=/usr/lib/dri-alternates glxgears -info
To force the use of gallium i915 driver:
$ LIBGL_DRIVERS_PATH=/usr/lib/dri-alternates glxgears -info

=== Debugging and reporting problems ===
If you have some problem with the drivers try running the application from the command line and see if there are graphics related warnings (note that mesa is already built with --enable-debug which can provide useful debug informations). Also type dmesg to see if there are other related informations here.

If you get crashes install the relevant -dbg pacakges (libgl1-mesa-dri-dbg or libgl1-mesa-dri-experimental-dbg for 3D drivers and xserver-xorg-video-intel-dbg , xserver-xorg-video-nouveau-dbg or xserver-xorg-video-radeon-dbg for X drivers) and reproduce the crash with gdb. Example:
$ gdb glxgears
[...make your application crash and then get a backtrace with:]
(gdb) bt

If X.org crashes look at /var/log/Xorg.0.log (or /var/log/Xorg.0.log.old when a new X session is started after the crash).

With the gathered informations try searching at https://bugs.freedesktop.org/query.cgi (also try with google) if someone already reported a similar bug. If not you may want to report a new bug:
for 3D drivers bugs: https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa
for X / 2D driver bugs: https://bugs.freedesktop.org/enter_bug.cgi?product=xorg

=== Revert to original drivers ===
To revert to standard Ubuntu drivers type the following in a prompt shell:
$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:oibaf/graphics-drivers
More info: https://launchpad.net/~oibaf/+archive/graphics-drivers
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: portachiavi "/tmp/tmpBOYtOI/secring.gpg" creato
gpg: portachiavi "/tmp/tmpBOYtOI/pubring.gpg" creato
gpg: richiesta della chiave A03A4626 dal server hkp keyserver.ubuntu.com
gpg: /tmp/tmpBOYtOI/trustdb.gpg: creato il trustdb
gpg: chiave A03A4626: chiave pubblica «Launchpad PPA for Fabio Pedretti» importata
gpg: Numero totale esaminato: 1
gpg:               importate: 1  (RSA: 1)
OK
:~$ sudo apt-get update
E: Tipo "eb" non riconosciuto alla riga 2 nel file /etc/apt/sources.list.d/oibaf-graphics-drivers-precise.list
E: Impossibile leggere l'elenco dei sorgenti.


Come si vede alla fine si legge questo:

sudo apt-get update
E: Tipo "eb" non riconosciuto alla riga 2 nel file /etc/apt/sources.list.d/oibaf-graphics-drivers-precise.list
E: Impossibile leggere l'elenco dei sorgenti.

Che fare?

   
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#9
Con questo errore non riesco nemmeno ad entrare e togliere il PPA che si chiude la pagina idem se vado dal gestore pacchetti...
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#10
Come posso fare ad eliminare tutti i driver e mettere in default o comunque che fare per togliere il PPA e quindi darmi modo di andare avanti?
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)