Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
impossibile aggiornare kubuntu 12.04
#1
Innanzitutto buon giorno a tutto il forum,
come da titolo ho un problema con la versione "beta 1" di kubuntu 12.04 :
come da titolo non mi è possibile aggiornare il a causa di un problea con dei pacchetti più precisamente : con glib networking
vi posto l'out put del terminale sperando in un vostro aiuto



caffe@arseniko:~$ sudo apt-get upgrade
[sudo] password for caffe:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
glib-networking : Dipende: glib-networking-services (< 2.31.22-1.1~)
Dipende: glib-networking-common (= 2.31.22-1) ma la versione 2.32.0-1 è installata
Rompe: glib-networking:i386 (!= 2.31.22-1) ma la versione 2.31.20-0ubuntu1 è installata
glib-networking:i386 : Dipende: glib-networking-services:i386 (< 2.31.20-0ubuntu1.1~)
Dipende: glib-networking-common:i386 (= 2.31.20-0ubuntu1)
Rompe: glib-networking (!= 2.31.20-0ubuntu1) ma la versione 2.31.22-1 è installata
gvfs : Dipende: gvfs-libs (= 1.11.4-0ubuntu2) ma la versione 1.11.5-1ubuntu1 è installata
Dipende: gvfs-common (= 1.11.4-0ubuntu2) ma la versione 1.11.5-1ubuntu1 è installata
gvfs:i386 : Dipende: gvfs-libs:i386 (= 1.11.4-0ubuntu2) ma la versione 1.11.5-1ubuntu1 è installata
Dipende: gvfs-common:i386 (= 1.11.4-0ubuntu2)
gvfs-daemons : Dipende: gvfs-libs (= 1.11.4-0ubuntu2) ma la versione 1.11.5-1ubuntu1 è installata
Dipende: gvfs-common (= 1.11.4-0ubuntu2) ma la versione 1.11.5-1ubuntu1 è installata
libsoup-gnome2.4-1 : Rompe: libsoup-gnome2.4-1:i386 (!= 2.37.92-1) ma la versione 2.37.91-1 è installata
libsoup-gnome2.4-1:i386 : Rompe: libsoup-gnome2.4-1 (!= 2.37.91-1) ma la versione 2.37.92-1 è installata
libsoup2.4-1 : Rompe: libsoup2.4-1:i386 (!= 2.37.92-1) ma la versione 2.37.91-1 è installata
libsoup2.4-1:i386 : Rompe: libsoup2.4-1 (!= 2.37.91-1) ma la versione 2.37.92-1 è installata
E: Dipendenze non trovate. Riprovare usando -f.
caffe@arseniko:~$ apt-get -f install
E: Impossibile aprire il file di blocco /var/lib/dpkg/lock - open (13: Permesso negato)
E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). È necessario essere root.
caffe@arseniko:~$
grazie per l'attenzione Arsenio
Cita messaggio
#2
Il comando che devi dare è:

sudo apt-get install -f

Dovrebbe forzare il processo in sospeso.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#3
(07-04-2012, 07:25 )francater Ha scritto: Il comando che devi dare è:

sudo apt-get install -f

Dovrebbe forzare il processo in sospeso.
gentile francater haimè non funziona neanche così:
ti posto il risultato

caffe@arseniko:~$ sudo apt-get install -f
[sudo] password for caffe:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
libopenal1:i386 libsdl-ttf2.0-0:i386 libkrb5-3:i386 libgconf-2-4:i386
libk5crypto3:i386 libstdc++5:i386 libxcomposite1:i386 libldap-2.4-2:i386
liblcms1:i386 libroken18-heimdal:i386 libunistring0:i386 libcupsimage2:i386
libgphoto2-port0:i386 libidn11:i386 libnss3:i386 libaio1:i386 libsane:i386
odbcinst1debian2:i386 libsdl-mixer1.2:i386 libcap2:i386
libdbus-glib-1-2:i386 libtdb1:i386 libasn1-8-heimdal:i386 libxslt1.1:i386
libgomp1:i386 libcapi20-3:i386 libibus-1.0-0:i386 libgssapi3-heimdal:i386
libcanberra0:i386 libmysqlclient18:i386 libavahi-common-data:i386
libsdl-image1.2:i386 libwind0-heimdal:i386 libsdl1.2debian:i386 libxaw7:i386
libgdbm3:i386 libcups2:i386 libcurl3:i386 libxinerama1:i386 libesd0:i386
libmikmod2:i386 libkrb5support0:i386 libcroco3:i386
libpulse-mainloop-glib0:i386 libice6:i386 libieee1284-3:i386 libao4:i386
libkeyutils1:i386 libxmu6:i386 libvorbisfile3:i386 libxpm4:i386
libusb-0.1-4:i386 libhcrypto4-heimdal:i386 libnspr4:i386
libhx509-5-heimdal:i386 libgettextpo0:i386 libxss1:i386 libgd2-xpm:i386
libheimbase1-heimdal:i386 libsdl-net1.2:i386 libxtst6:i386 librsvg2-2:i386
libavahi-client3:i386 libssl0.9.8:i386 libmpg123-0:i386 libmad0:i386
libsasl2-2:i386 xaw3dg:i386 libsm6:i386 libheimntlm0-heimdal:i386
libpulsedsp:i386 libqoauth1 libodbc1:i386 libexif12:i386 librtmp0:i386
libgssapi-krb5-2:i386 libxi6:i386 libxp6:i386 libaudio2:i386
libxcursor1:i386 libxt6:i386 libsasl2-modules:i386 libavahi-common3:i386
libxrandr2:i386 libmng1:i386 libltdl7:i386 libkrb5-26-heimdal:i386
libssl1.0.0:i386 libgphoto2-2:i386 libaudiofile1:i386
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
glib-networking glib-networking:i386 gvfs gvfs:i386 gvfs-common gvfs-daemons
gvfs-libs gvfs-libs:i386 libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386
libsoup2.4-1 libsoup2.4-1:i386
Pacchetti suggeriti:
gvfs-backends gvfs-backends:i386
I seguenti pacchetti saranno aggiornati:
glib-networking glib-networking:i386 gvfs gvfs:i386 gvfs-common gvfs-daemons
gvfs-libs gvfs-libs:i386 libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386
libsoup2.4-1 libsoup2.4-1:i386
12 aggiornati, 0 installati, 0 da rimuovere e 665 non aggiornati.
13 non completamente installati o rimossi.
È necessario scaricare 0 B/1214 kB di archivi.
Dopo quest'operazione, verranno occupati 303 kB di spazio su disco.
Continuare [S/n]? s
dpkg: errore nell'elaborare glib-networking:i386 (--configure):
glib-networking:i386 2.31.20-0ubuntu1 cannot be configured because glib-networking:amd64 is in a different version (2.31.22-1)
dpkg: errore nell'elaborare glib-networking (--configure):
glib-networking:amd64 2.31.22-1 cannot be configured because glib-networking:i386 is in a different version (2.31.20-0ubuntu1)
dpkg: errore nell'elaborare libsoup2.4-1 (--configure):
libsoup2.4-1:amd64 2.37.92-1 cannot be configured because libsoup2.4-1:i386 is in a different version (2.37.91-1)
dpkg: errore nell'elaborare libsoup2.4-1:i386 (--configure):
libsoup2.4-1:i386 2.37.91-1 cannot be configured because libsoup2.4-1:amd64 is in a different version (2.37.92-1)
dpkg: errore nell'elaborare libsoup-gnome2.4-1:i386 (--configure):
libsoup-gnome2.4-1:i386 2.37.91-1 cannot be configured because libsoup-gnome2.4-1:amd64 is in a different version (2.37.92-1)
dpkg: errore nell'elaborare libsoup-gnome2.4-1 (--configure):
libsoup-gnome2.4-1:amd64 2.37.92-1 cannot be configured because libsoup-gnome2.4-1:i386 is in a different version (2.37.91-1)
Si sono verificati degli errori nell'elaborazione:
glib-networking:i386
glib-networking
libsoup2.4-1
libsoup2.4-1:i386
libsoup-gnome2.4-1:i386
libsoup-gnome2.4-1
E: Sub-process /usr/bin/dpkg returned an error code (1)
caffe@arseniko:~$

sperando in un tuo/vostro aiuto
arsenio
Cita messaggio
#4
La 12.04 che hai installato è una Alpha, una Beta o una Beta2?
Hai aggiunto software diversi da quelli presenti nei repository ufficiali, o hai aggiunto ppa o repository differenti?
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#5
gentile francater
mi devo scusare ancora con te-voi per il ritado con il quale ti-vi rispondo
diciamo che ho optato per la soluzione + sbrigativa e drastica formattando il tutto
per completezza di informazioni alla tua ultima richiesta si trattava di una beta 1 a cui avevo "forzato "
il kernel con una versione ancora instabile e quindi molto falcilmente ho "rotto"gli aggiornamenti
nel frattempo ho recuperato degli hd (orasiamo a tre) e li ho installati sul mio pc quindi ,mentre uno sarà dedicato
alla versione stabile del mio K-X-G3-U.. buntu, non ho ancora deciso qual'è il mio desktop perferito,
gli altri 2 potranno essere dedicati ad esprimenti e contaminazioni varie .........
ora però devo aprire un'altro post per capire qual'è il sistema ,se esite, dove è installato il settore di boot
Cita messaggio
#6
Credo che non sia possibile per una beta ricevere gli aggiornamenti, è una versione messa in piedi affinchè l'utente possa valutare un prodotto, quindi manca il supporto che sarà disponibile per la versione stabile.
Cita messaggio
#7
(21-04-2012, 15:43 )tivellino Ha scritto: gentile francater
mi devo scusare ancora con te-voi per il ritado con il quale ti-vi rispondo
diciamo che ho optato per la soluzione + sbrigativa e drastica formattando il tutto
per completezza di informazioni alla tua ultima richiesta si trattava di una beta 1 a cui avevo "forzato "
il kernel con una versione ancora instabile e quindi molto falcilmente ho "rotto"gli aggiornamenti
nel frattempo ho recuperato degli hd (orasiamo a tre) e li ho installati sul mio pc quindi ,mentre uno sarà dedicato
alla versione stabile del mio K-X-G3-U.. buntu, non ho ancora deciso qual'è il mio desktop perferito,
gli altri 2 potranno essere dedicati ad esprimenti e contaminazioni varie .........
ora però devo aprire un'altro post per capire qual'è il sistema ,se esite, dove è installato il settore di boot
hai già provato con il comando

Codice:
sudo apt-get dist-upgrade

la beta2 di Lubuntu all'inizio soffriva del bug di non potere aggiornare in altro modo se non così. Poi è andata a posto. Comunque sia il 26 aprile la potrai benissimo aggiornare alla versione stabile eseguendo tutti gli aggiornamenti proposti dal Gestore, se tutto funziona a dovere.
Cita messaggio
#8
gentile procton 771
permettimi di non essere d'accordo con te in quanto fino alla forzatura del kernel tutto viaggiava regolarmente
quindi aggiornamenti anche corposi (qualche centinaio di Mb alla volta o quando mi venivano segnalati oppureuna volta a settimana
da terminale con sudo apt-get update && sudo apt-get upgrade e con questo ho finito la conoscenza dei comandi da shell per Ubuntu [sob]
.:Matteo :.
ho tentato anche un
sudo apt-get install -f come consigliatomi da francater
ed un improbabile sudo apt-get upgrade -f
ma con nessun risultato tanto da costringermi ad un "formatta tutto e riparti da li
Cita messaggio
#9
(21-04-2012, 17:44 )tivellino Ha scritto: gentile procton 771
permettimi di non essere d'accordo con te in quanto fino alla forzatura del kernel tutto viaggiava regolarmente
quindi aggiornamenti anche corposi (qualche centinaio di Mb alla volta o quando mi venivano segnalati oppureuna volta a settimana
da terminale con sudo apt-get update && sudo apt-get upgrade e con questo ho finito la conoscenza dei comandi da shell per Ubuntu [sob]
.:
Permesso accordato tivellino Smile avevo solo azzardato una mia ipotesi, visto che di solito sono restio ad usare le versioni beta e quindi non ho nessun tipo di riscontro da poter affermare il contrario Sleepy
Cita messaggio
#10
Come dico sempre, sperimentare ci aiuta a crescere Exclamation
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)