Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
mint 17 e installazione drivers
#1
             Buon giorno.
Sono nuovo di linux e ho difficolta ad installare i dirivers della scheda wifi.
La macchina è un vecchio IBM T30 con scheda wifi intersil prism. Non riesco a configurare la scheda.
In allegato alcune informazioni.
grazie in anticipo per la risposta.
Giuseppe
Cita messaggio
#2
ciao, apri synaptic e metti come chiave di ricerca hostap, dovrebbero spuntarti due voci, hostap-utils e hostapd, e almeno hostap-utils dovrebbe essere installato; se non lo è, installalo e riavvia.

sarebbe opportuno poi vedere anche la schermata del comando rfkill list, se dovesse restituire dei blocchi prova a sbloccare con: sudo rfkill unblock all

ricordati che se sei in dual boot con win e che se da win hai spento il wifi, molto probabilmente dovrai rientrare in win per accenderlo e chiudere win lasciando acceso il wifi.

ciao

edit: in rete ho trovato questo https://wiki.debian.org/hostap#Installation
ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#3
grazie mille per la puntuale risposta.
avevo già installato iieri hostap-utils e poco fa ho verificato che risulta installato anche wireless-tools. Il comando rfkill list non da alcuna risposta e comunque ho provato anche a dare sudo rfkill unblock all senza alcun risoltato. Non ho il dual boot ma solo linux. Ho anche provato a impartire i comandi del link che mi hai inviato senza alcun risultato.
AIUTOO!!
Ho esaurito tutte le idee....


Allegati Anteprime
           
Cita messaggio
#4
ma prima c'era installato win? e quand'era installato tenevate spento il wifi se non serviva o prima di spegnere il pc?

e con
sudo rfkill list
sudo ifconfig wlan0 up
l'esito è lo stesso?

hai provato ad accendere l'antenna wifi dal tasto fisico (o combinazione di tasti) del notebook?

il pacchetto hostapd è installato? se non lo è, prova ad installarlo e vediamo se riesce a sbloccare la situazione.

edit: purtroppo googolando un po' (chiave di ricerca: ubuntu 14.04 problemi wireless ibm t30) non sei il solo ad avere di questi problemi.
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#5
Prova ad installare il pacchetto hostap-utils, il quale dovrebbe provvede a blacklistare dei moduli che interferiscono con quello utilizzato dalla tua scheda wifi.

Bye,
Token

 

 
Cita messaggio
#6
    Buon giorno Gius.
Ho installato anche hostapd  e ho ridato i comandi ma niente. su questo hard disk prima avevo installato mint 13 e il wifi non funzionava ugualmente. inserendo il secondo hard disk con seven il wifi funziona regolarmente. Il T30 non ha tasti di accenzione o di attivazione del wifi. la scheda wifi è interna e simile a questa:  http://www.ebay.com/itm/IBM-T30-802-11b-...0219335520 . Tra l'altro possiedo anche un altra scheda wifi cinese del tipo pcmcia e anche questa non viene riconosciuta.
Per Token: se hai notato nelle foto allegate un paio di giorni fa, hostap-utils è già stato installato senza risultati.
Giuseppe

 

 
Cita messaggio
#7
e naturalmente quando chiudi win, lasci accesa l'antenna wifi, giusto?

prova anche a vedere se il comando
sudo rfkill list wlan
ti da un risultato (eventualmente postalo)

allega anche il file
/etc/modprobe.d/blacklist.conf
come giustamente osservato da token hostap-utils dovrebbe mettere in blacklist dei driver (orinoco) che vanno in conflitto, vediamo se sono inseriti.
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#8
            Gius,
come dicevo, la macchina non ha un tasto di accensione per il wifi, può darsi che sotto win faccia tutto da solo ma, non ho mai acceso o spento nulla.

anche "sudo rfkill list wlan" non da risultato (vedi allegato).
Ho allegato anche il file blacklist.conf  (2 allegati).
Grazie ancora.
Giuseppe

 

 

 
Cita messaggio
#9
sembra che non ci siano, proviamo a metterli noi, apri il terminale e digita:
sudo gedit /etc/modprobe.d/blacklist.conf
dopo l'ultima riga (blacklist amd76x_edac) aggiungi una riga vuota e poi aggiungi (copia incolla) il seguente gruppo:
# blacklist dei driver orinoco che confliggono con i driver hostap
blacklist orinoco_pci
blacklist orinoco_cs

salva e chiudi e poi riavvia... [img]images/smilies/cool.gif[/img]
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#10
    fatto. in allegato il file modificato.
Ho salvato e riavviato ma non è cambiato nulla.

 

 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)