Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
ubuntu 13.04 non si avvia correttamente. schermate nere
#1
Salve a tutti! E' da quando ho installato Ubuntu 13.04 (poco meno di una settimana) che ho problemi nell'avviarlo correttamente.
Avvio il pc, mi appare la schermata del GRUB (ho windows8 e ubuntu 13.04 in dual boot), premo invio su Ubuntu 13.04 ed il più delle volte rimango bloccato su alcune schermate di questo tipo:
http://imgur.com/nSNl9ng
http://imgur.com/Xj7lxru

Ho scattato le due foto ieri sera dal mio smartphone. Come potete vedere dalla prima immagine l'ultima riga la ho scritta io. Il più delle volte Ubuntu mi si blocca all'avvio in queste situazioni. Per uscirne fino ad adesso ho spento e riacceso il pc. Windows 8 si avvia regolarmente, Ubuntu 13.04 mi dà questi problemi, ma a volte mi si avvia correttamente.

Al primo avvio (Ubuntu appena installato) ho avuto una schermata che diceva:
"The system is running in low-graphics mode
Your screen, graphics card and imput device settings could not be detected correctely. You will need to configure there yourself".

What would you like to do?
-Exit console login
-reconfigure graphics
-run in low-graphics mode for just one session
-troubleshoot error"

Optai per la terza e riavviai il sistema. Purtroppo i problemi all'avvio continuavano. Ho pensato fosse un problema di drivers nvidia, che in qualche modo Ubuntu avesse dei problemi con la mia GTX 570, quindi ho reinstallato i drivers nvidia, prima ho provato con "nvidia-current", poi con drivers più recenti, però i problemi non si sono risolti.

Quando si avvia correttamente Ubuntu 13.04 è velocissimo (lo ho installato su ssd). L'unica cosa che riesco a intravedere è schermata nera, in alto a sinistra leggo per un instante:"ubuntu ringtail ttl1". Sotto è troppo veloce ma credo che vada ad inserire la mia password (ho impostato che quando entro in ubuntu 13.04 non mi chiede la psw).

Il discorso è che per entrare in Ubuntu 13.04 spesso è complicato. Ho cercato su internet per possibili soluzioni ed ho trovato questo:
http://www.webupd8.org/2013/01/ubuntu-li...using.html
Cosa ne pensate? Potrebbe essere la soluzione?
Se ho ben capito il problema sarebbe legato alla mia configurazione, in particolare al mio ssd che sarebbe troppo veloce, e il LightDM non caricherebbe correttamente? Secondo voi è plausibile? Aggiungo la mia configurazione in firma per maggiore chiarezza. Ad ogni modo ubuntu lo ho installato sull'ssd isieme a windows8, la home la ho messa sul disco meccanico insieme alla partizione di swap).

Scusate se la seguente discussione è un pò lunga Smile sorriso originale Come procedereste per risolvere l'errore di avvio?
Grazie in anticipo Smile
Cooler Master Centurion 590 - Enermax 525W modu 82+ - Crucial m4 128GB - Barracuda Green SATA 6Gb/s 2TB - Intel Core i5-3570k - CPU Cooler Master Hyper 412 - MSI MPower Z77 - DDR3 Crucial Ballistix Smart Tracer - GTX 570 glh - Samsung P2450H - Logitech X-230
Cita messaggio
#2
Salve
Se non vi erano altri problemi,avrei installato anche la home e swap su sdd
Detto questo, per quanto riguarda la soluzione da te postata,proverei direttamente
con Use GDM instead of LightDM fai prima a vedere se il problema è dato da LightDM, quindi a ritornare con le impostazioni di default,se non si risolve.

Cita messaggio
#3
(07-05-2013, 10:07 )brunik Ha scritto: Salve
Se non vi erano altri problemi,avrei installato anche la home e swap su sdd
Detto questo, per quanto riguarda la soluzione da te postata,proverei direttamente
con Use GDM instead of LightDM fai prima a vedere se il problema è dato da LightDM, quindi a ritornare con le impostazioni di default,se non si risolve.

Per rispondere alla prima parte ho installato home e swap su disco meccanico per un discorso di spazio. Il mio ssd ha una capienza di 120GB. Considerando che solo la mia cartella windows occupa 21GB, più alcuni programmi su windows, più lo spazio per Ubuntu... inoltre per preservare la durata dell'ssd lascio sempre un pò di spazio libero su di esso. Poichè avevo intenzione di usare la home per foto, video, e steam con qualche gioco, ho fatto un rapido calcolo e mi sono accorto che 120GB non mi sarebbero bastati assolutamente per tutte queste cose. Poi mi sembrava uno spreco usare qualche GB di ssd per la partizione di swap quando ho 8GB di ram.

Riguardo la seconda parte ho installato e selezionato gdm come display manager, seguendo le istruzioni del link da me postato nel mio intervento precendente. Qualche cosa è cambiato, infatti riesco ad entrare in ubuntu 13.04 adesso ma sono afflitto da tutta una serie di problemi.
Giusto un paio di foto fatte con il mio smartphone per rendere l'idea:
Entro in Ubuntu 13.04 e questa è la situazione:
http://i.imgur.com/XmrEnQ6.jpg

Come potete vedere adesso non compare proprio la barra a sinistra tipica di unity. In compenso dopo qualche secondo mi compare un messaggio "System program problem detected". Effettivamente me ne ero accorto che c'era qualche cosa che non quadrava....
fortunatamente almeno il terninal riesco a lanciarlo.

Qui invece non mi ricordo se stavo provando a riavviare o a spegnere proprio il pc, ma si è bloccato:

http://imgur.com/TnSOFrc


Comunque con il GDM riesce ad entrare in ubuntu, ma ci entro con tutta una serie di problemi correlati:/ Non so più che fare. Davvero problemi a non finire Undecided In tutta onestà se non avessi tramite grub il dual boot con windows8 (partizione che vorrei tutelare) avrei già formattato tutto e provato con un'altra distribuzione.
Cooler Master Centurion 590 - Enermax 525W modu 82+ - Crucial m4 128GB - Barracuda Green SATA 6Gb/s 2TB - Intel Core i5-3570k - CPU Cooler Master Hyper 412 - MSI MPower Z77 - DDR3 Crucial Ballistix Smart Tracer - GTX 570 glh - Samsung P2450H - Logitech X-230
Cita messaggio
#4
Il problema che segnala,non è detto che riguardi le modifiche apportate,è generico,
comunque pare che almeno così con gdm il problema dello schermo nero sia superato.
Vedi ora di riempostare LightDM come display manager e seguire stavolta la prima
parte della guida Start LightDM with a delay.Vediamo se così anche LightDM
si avvia,e si supera lo schermo nero.Potresti anche cambiare versione di ubuntu e installare una 12.04 lts.

Cita messaggio
#5
(07-05-2013, 14:51 )brunik Ha scritto: Il problema che segnala,non è detto che riguardi le modifiche apportate,è generico,
comunque pare che almeno così con gdm il problema dello schermo nero sia superato.
Vedi ora di riempostare LightDM come display manager e seguire stavolta la prima
parte della guida Start LightDM with a delay.Vediamo se così anche LightDM
si avvia,e si supera lo schermo nero.Potresti anche cambiare versione di ubuntu e installare una 12.04 lts.

Grazie dei consigli brunik. Adesso non posso, ma procederò a reimpostare LightDM aggiungendo qualche secondo di ritardo questa sera. Vi farò sapere come si evolve la situazione. Riguardo il problema che segnala, e le schermate nere ti confesso la mia totale ignoranza in materia!
Per quanto riguarda cambiare versione di ubuntu in realtà avevo pensato di passare ad un'altra distribuzione se non dovessi riuscire a risolvere questi problemi sulla 13.04. Se non fosse che ho paura di compromettere la partizione con windows8 sopra. Questo non per paura di perdere i dati che comunque sono sul disco meccanico e non sullo ssd dove sono installati i sistemi operativi (ed ho una copia di sicurezza dei dati su hd esterno), ma per evitarmi la seccatura di dover formattare e reinstallare tutto windows8 che mi porterebbe via molto tempo:/ Ad ogni modo se non dovessi risucire a far funzionare la 13.04 credo proprio che quando avrò una giornata disponibile (casomai le cose dovessero andare storte) proverò a ripristinare il boot loader di windows, ed installare un'altra distribuzione (proverei ad usare EasyBCD).
Ad ogni modo un passo per volta. Questa sera provo a seguire la prima parte della guida e vediamo come va Sleepy
Grazie ancora del supporto Smile
Cooler Master Centurion 590 - Enermax 525W modu 82+ - Crucial m4 128GB - Barracuda Green SATA 6Gb/s 2TB - Intel Core i5-3570k - CPU Cooler Master Hyper 412 - MSI MPower Z77 - DDR3 Crucial Ballistix Smart Tracer - GTX 570 glh - Samsung P2450H - Logitech X-230
Cita messaggio
#6
Ok allora ho digitato dal terminale "sudo dpkg-reconfigure gdm"
Ho selezionato lightdm come display manager.
Ho riavviato, adesso mi appare la schermata dove ho tre scelte. Provo ad entrare nel mio account. Inserisco la psw ma nulla non entra!
Adesso sono entrato dalla sessione ospiti. Solo che non mi lascia fare nulla. A conferma che la psw che inserisco me la ricordo bene (me la ero pure segnata), entrato nella sessione ospiti per guardare i files sul disco meccanico mi ha chiesto la psw e la ha presa correttamente. Se lancio il terminale dalla sessione ospiti non mi fa fare nulla :/
Il fatto positivo è che è mi è apparsa correttamente la schermata, il fatto negativo è che non riesco più ad entrare con il mio account enrico, ma sono dovuto entrare come "ospite"! Idee per risolvere? Ho controllato attentamente che la psw che sono andato ad inserire sia corretta. Niente caps lock inserito. C'è solo una maiuscola alla fine. Comunque adesso non mi appare più nessun messaggio che riporta problemi o errori, e vedo nuovamente la barra sinistra tipica di unity dalla sessione ospiti. L'unico problema è che non riesco più ad entrare con il mio username e la mia psw, ma devo entrare da ospite. Tra le altre cose avevo impostato ubuntu quando lo avevo installato in modo tale che non mi chiedesse la psw all'avvio, ma immagino che essendo andato a riattivare il lightdm deve avere in qualche modo resettato le preferenze.
Come mi consigliate di procedere?

MODIFICA:
Ok la psw che inserisco alla schermata per entrare con il mio username è corretta. Infatti ho provato ad inserire una psw non corretta e mi compare una scritta in rosso che mi dice che la psw non è corretta. Quindi non riesco proprio più ad entrare con il mio username nella mia sezione con la psw corretta. Inserisco la psw, lo schermo cambia per un secondo e si sente un suono, però non entra e riporta alla schermata dove vado a scegliere di entrare come ospite.
Cooler Master Centurion 590 - Enermax 525W modu 82+ - Crucial m4 128GB - Barracuda Green SATA 6Gb/s 2TB - Intel Core i5-3570k - CPU Cooler Master Hyper 412 - MSI MPower Z77 - DDR3 Crucial Ballistix Smart Tracer - GTX 570 glh - Samsung P2450H - Logitech X-230
Cita messaggio
#7
Huh
Forse potresti creare un nuovo utente con privilegi di amministrazione usando la modalità ripristino http://wiki.ubuntu-it.org/Amministrazion...ripristino poi segui http://wiki.ubuntu-it.org/Sicurezza/Gest...d/Recupero dal punto adduser nomeutente

Cita messaggio
#8
Anch'io avevo i tuoi stessi problemi (schermo di boot con segnalazione di errori vari).
Ho installato in dual boot (con Win 7) tutte le versioni 64 bit Ubuntu e Linux Mint, ma la situazione era sempre la medesima (ho 8 Gb di ram).
Non sono riuscito a capire quale fosse il problema ed il mio SSD è perfettamente funzionante.
Ho "risolto" installando la versione 12.04 LTS a 32 bit.
L'unica prova che non ho fatto è quella di installare la 13.04 a 32 bit.
Ciao.
Cita messaggio
#9
Grazie per il contributo navi68 e brunik Smile Negli ultimi giorni purtroppo ho avuto poco tempo a disposizione quindi la situazione è sempre la stessa. Ad ogni modo ho deciso di risolvere il problema alla radice. Questo fine settimana voglio provare con Opensuse12.3 a 64bit. Ho letto ottime recensioni, quindi vorrei dargli una possibilità, sempre conservando la partizione di windows8. Vi farò sapere se l'operazione riesce, e se il problema si dovesse ripresentare.
Si navi68 confermo che anche il mio ssd è perfettamente funzionante. Grazie della testimonianza Smile Vi tengo aggiornati.
Cooler Master Centurion 590 - Enermax 525W modu 82+ - Crucial m4 128GB - Barracuda Green SATA 6Gb/s 2TB - Intel Core i5-3570k - CPU Cooler Master Hyper 412 - MSI MPower Z77 - DDR3 Crucial Ballistix Smart Tracer - GTX 570 glh - Samsung P2450H - Logitech X-230
Cita messaggio
#10
ciao, se risolvi con suse bene altrimenti visto che stai "provando" magari dai uno sguardo:
http://www.pclinuxos.com/?page_id=1867
magari KDE all'inizio lascia un poco disorientati per chi è abituato a gnome ma poi poco alla volta si impara ad aprezzarlo.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)