Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
ubuntu non parte dal disco clonato
#1
Il mio attuale disco fisso, su cui ci sono Windows XP e Ubuntu 10.04, ha ormai una certa età. Ho eseguito quindi per sicurezza una clonazione su un altro disco usando Acronis. Clonazione avvenuta con successo.
Per ulteriore prova ho poi sostituito il disco originale con il disco clonato e ho cercato di far partire Ubuntu che NON è partito.
La segnalazione di errore mi dice praticamente che non si tratta dello stesso device.
Come si può rimediare a questa cosa? Perchè altrimenti, se non fosse possibile, non avrebbe alcun senso eseguire copie del disco se poi risultano inutilizzabili una volta che il disco originale tira le cuoia.
Un ringraziamento anticipato a chi vorrà darmi qualche dritta.

 
Cita messaggio
#2
si è normale che non parta. clonando hai copiato pari pari i dati e lui ha registrato quelli relativi al disco di prima.
risolvi facilmente reinstallando il grub. usa una versione in live e segui queste indicazioni:
http://www.gmstyle.org/index.php/ubuntu-...-boot.html
Cita messaggio
#3
sei certo sia sufficiente reinstallare il grub ? se in fstab sono presenti i riferimenti UUID questi non corrispondono a quelli del nuovo disco e credo debbano essere cambiati
Un titolo ben azzeccato attira l'attenzione degli esperti in quel campo, fa risparmiare tempo a voi, aumenta la probabilità di successo.
Cita messaggio
#4
ben detto. per fare questo, nel terminale:
sudo blkid
appariranno tutti gli UUID delle tue partizioni, prendi nota di quello relativo alla partizione dove ora hai il sistema. sempre dal terminale apri come amministratore il fstab del sistema installato che trovi in system (computer), etc. correggi UUID ( lui riporta quello della vecchia partizione ) salva prima di uscire. fatto
Cita messaggio
#5
Grazie ad entrambi.
In effetti ho provato a usare il CD di SuperGrub con cui sono arrivato a poter caricare Grub dal disco clonato:
"Load Grub from Ubuntu 10.04 ... (device (HD1,3))"
Dall'elenco che mi appare dopo aver dato invio ho poi lanciato Ubuntu.
Come risposta ottengo però le seguenti segnalazioni di errore:
-"no such device 26e90412-fb98-....ecc"
-"no such partition"
-"you need to load the kernel first"
Credo che effettivamente occorra intervenire e modificare l'UUID.
Cercherò, adesso, basandomi anche su quanto ha scritto dxgiusti nell'ultimo messaggio di fare questo intervento.
Grazie ancora.
Cita messaggio
#6
Purtroppo non ho potuto eseguire alcun intervento per aggiornare l'UUID.
Prima che potessi farlo mi è partita la scheda madre.
A questo punto credo che con la nuova scheda madre dovrò reinstallare tutto, dato che non mi sembra sia possibile far funzionare il vecchio OS sia originale sia clonato su quello che ormai è diventato un nuovo (e diverso) computer.
Un cordiale saluto.
Cita messaggio
#7
In effetti esistono (ma solo per le versioni commerciali) le versioni Universal Restore che possono effettuare il riprostino dell'immagine di sistema anche in macchine diverse rispetto a quella da cui si era creata l'immagine.
Cita messaggio
#8
@dxgiusti: grazie per la 'dritta' (post#2), che mi ha permesso di riportare alla luce del sole una distro che ormai piangevo per dispersa... Ho memorizzato la procedura, perchè non si sa mai. [img]images/smilies/exclamation.gif[/img]
 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)