Forum Informatica 1 Majorana
[RISOLTO] problema risoluzione schermo - Versione stampabile

+- Forum Informatica 1 Majorana (http://www.istitutomajorana.it/forum)
+-- Forum: Sistemi Operativi: Ubuntu, Windows, Linux, Altri (http://www.istitutomajorana.it/forum/forumdisplay.php?fid=5)
+--- Forum: Personalizzazioni, Aspetto, Driver (http://www.istitutomajorana.it/forum/forumdisplay.php?fid=9)
+--- Discussione: [RISOLTO] problema risoluzione schermo (/showthread.php?tid=23988)

Pagine: 1 2 3 4


[RISOLTO] problema risoluzione schermo - mary75 - 27-05-2014

Salve a tutti , chiedo scusa se riapro questa discussione. 
Ho un monitor acer al 176 e scheda video ati radeon x600, quando digito il comando: cat /etc/x11/xorg.conf
mi dice file o directory non esistente.
Ho lo stesso problema di centramento schermo , come creo questo file?

 

 

 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - mary75 - 27-05-2014

Salve a tutti , chiedo scusa se riapro questa discussione. 
Ho un monitor acer al 176 e scheda video ati radeon x600, quando digito il comando: cat /etc/x11/xorg.conf
mi dice file o directory non esistente.
Ho lo stesso problema di centramento schermo , come creo questo file?

 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - roberto1155 - 27-05-2014

E' difficile vedere i problemi se nell'intestazione è indicato "RISOLTO". Comunque segui le seguenti istruzioni:
- aprire la console  di comando → Alt+Control+F2
- per disattivare il server X  → sudo service lightdm stop
- per creare il file xorg.conf → sudo X -configure
- per spostare il file xorg.conf nella cartella /etc/X11 → sudo mv xorg.conf.new /etc/X11/xorg.conf
- per riavviare il server X → sudo service  lightdm start
un comando alla volta. Poi con il comando:


Codice:
cat /etc/X11/xorg.conf

lo puoi vedere e lo posti


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - mary75 - 27-05-2014

[img]images/smilies/rolleyes.gif[/img] Tante grazie roberto 1155 questo e' il risultato
Codice:
:Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    Screen      3  "Screen3" RightOf "Screen2"
    Screen      4  "Screen4" RightOf "Screen3"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor2"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor3"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor4"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "kmsdev"                 # <str>
        #Option     "ShadowFB"               # [<bool>]
    Identifier  "Card0"
    Driver      "modesetting"
    BusID       "PCI:6:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "kmsdev"                 # <str>
        #Option     "ShadowFB"               # [<bool>]
    Identifier  "Card1"
    Driver      "modesetting"
    BusID       "PCI:6:0:1"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "ColorTiling"            # [<bool>]
        #Option     "ColorTiling2D"          # [<bool>]
        #Option     "RenderAccel"            # [<bool>]
        #Option     "SubPixelOrder"          # [<str>]
        #Option     "AccelMethod"            # <str>
        #Option     "EXAVSync"               # [<bool>]
        #Option     "EXAPixmaps"             # [<bool>]
        #Option     "ZaphodHeads"            # <str>
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "SwapbuffersWait"        # [<bool>]
    Identifier  "Card2"
    Driver      "radeon"
    BusID       "PCI:6:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "Rotate"                 # <str>
        #Option     "fbdev"                  # <str>
        #Option     "debug"                  # [<bool>]
    Identifier  "Card3"
    Driver      "fbdev"
    BusID       "PCI:6:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "DefaultRefresh"         # [<bool>]
        #Option     "ModeSetClearScreen"     # [<bool>]
    Identifier  "Card4"
    Driver      "vesa"
    BusID       "PCI:6:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen2"
    Device     "Card2"
    Monitor    "Monitor2"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen3"
    Device     "Card3"
    Monitor    "Monitor3"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen4"
    Device     "Card4"
    Monitor    "Monitor4"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

don@don-P5GD1-FM:~$



RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - mary75 - 29-05-2014

Non mi indica le frequenze da impostare come vandario, adesso cosa faccio ? ...in piu' ho notato un rallentamento sui video
 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - roberto1155 - 29-05-2014

Nel post con @vandario si trattava di una scheda grafica "nvidia", che ha, nei drive disponibili, delle utility particolari, nel tuo caso parliamo di "ati". Il rallentamento è dovuto al file xorg, che nel tuo caso è al momento è meglio eliminare. Il SO normalmente acquisisce i dati della grafica in modo autonomo, il file xorg.conf passa i dati al SO e nel tuo caso non dice nulla, forse è un problema di drive. Controlla da l'utility "Monitor" se il tuo monitor viene riconosciuto corretamente, magari posta una schermata. Posta anche il risultato del comando:


Codice:
sudo lshw -c display | grep driver

Controlla anche dai comandi del monitor se puoi centrare l'immagine. In un secondo tempo vediamo di configurare il file xorg se necesario
 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - roberto1155 - 29-05-2014

@mary75 - controlla la sigla del tu monitor, nella ricerca in rete mi dà acer V176L????
 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - mary75 - 29-05-2014

intanto ti ringrazio per la disponibilita' , questo e' il manuale del monitor:http://www.manualslib.com/manual/233020/Acer-Al1716.html?page=10#manual
 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - mary75 - 29-05-2014

questo e' quello che mi compare dando il tuo comando :

don@don-P5GD1-FM:~$ sudo lshw -c display | grep driver
[sudo] password for don:
       configuration: driver=radeon latency=0
don@don-P5GD1-FM:~$

 


RE: [RISOLTO] Ubuntu 13.10 risoluzione non corretta - roberto1155 - 29-05-2014

Citazione:
Controlla anche dai comandi del monitor se puoi centrare l'immagin
Hai fatto questo?? L'opzione "monitor"????.