Forum Informatica 1 Majorana
[RISOLTO] Errore gestore pacchetti - Versione stampabile

+- Forum Informatica 1 Majorana (http://www.istitutomajorana.it/forum)
+-- Forum: Sistemi Operativi: Ubuntu, Windows, Linux, Altri (http://www.istitutomajorana.it/forum/forumdisplay.php?fid=5)
+--- Forum: Ubuntu Plus Remix Supporto ed Aiuto (http://www.istitutomajorana.it/forum/forumdisplay.php?fid=41)
+--- Discussione: [RISOLTO] Errore gestore pacchetti (/showthread.php?tid=5076)

Pagine: 1 2 3 4


[RISOLTO] Errore gestore pacchetti - laudo - 12-03-2012

Buongiorno, ho ubuntu 10.04 remix plus 5.
Ieri volevo fare dei lavoretti con dei dvd, ho letto delle guide che consigliavano di installare questo sudo apt-get install libdvdread4 e questo sudo apt-get install libdvdcss2 pero' mi dava questo errore sudo apt-get install libdvdcss2
E: Tipo "“deb" non riconosciuto alla riga 56 nel file /etc/apt/sources.list
E: Impossibile leggere l'elenco dei sorgenti.
Quando ho spento il pc e poi l'ho riacceso nella barra superiore mi e' uscito un simbolo di divieto e se ci clicco sopra mi esce questo
Adesso non riesco piu ad andare ne in gestore aggiornamenti e in gestore pacchetti.
Consigli?
Grazie


RE: Errore gestore pacchetti - zafran - 12-03-2012

Prova a andare a vedere alla linea 56 del sources.list e vedi un po' se quelle virgolette in più ci sono anche lì (”).
Fai un confronto con la sintassi degli altri repo elencati.

E' un repo che hai aggiunto tu copiandolo da qualche parte?
Le virgolette in più riportate dall'errore non sono le stesse che hai citato nel post (“).


RE: Errore gestore pacchetti - laudo - 12-03-2012

(12-03-2012, 09:29 )zafran Ha scritto: Prova a andare a vedere alla linea 56 del sources.list e vedi un po' se quelle virgolette in più ci sono anche lì (”).
Fai un confronto con la sintassi degli altri repo elencati.

E' un repo che hai aggiunto tu copiandolo da qualche parte?
Le virgolette in più riportate dall'errore non sono le stesse che hai citato nel post (“).
Perdonami ma sono gia' fermo, dove dovrei vedere?
Si l'ho aggiunto copiandolo da una guida anzi erano parecchie guide che dicevano di installare quello.
Io ho copiato gli errori che mi da'.
Il problema e' che non riesco piu ad entrare ne in gestore pacchetti ne in gestore aggiornamenti




RE: Errore gestore pacchetti - Antonio_Cantaro - 12-03-2012

Da terminale dai il comando:

sudo gedit /etc/apt/sources.list

(avevo dimenticato gedit)

si pare un file, alla riga 56 vedi se trovi qualche pacchetto con le virgolette " "

Se ne trovi solo uno, all'inizio di riga inserisci il simbolo # e salva.

Riprova con gli aggiornamenti.


RE: Errore gestore pacchetti - zafran - 12-03-2012

Nel comando suggerito da antonio è rimasto un gedit incastrato nella tastiera.
Il comando per editare il file è
sudo gedit /etc/apt/sources.list

In pratica dovrebbe essere successo che copiando ti sei portato dietro le virgolette formattate(”) che il sistema ora ti mette in evidenza mettendole fra virgolette semplici nel messaggio d'errore.
Editando il file, potresti sistemare la sintassi della riga incriminata.
Se non funziona, mettendo un # a inizio riga dici al sistema di non considerare quella riga e quindi dovresti almeno poter riavviare synaptic e il sistema di aggiornamenti.


RE: Errore gestore pacchetti - laudo - 13-03-2012

Spero di non aver fatto una stupidata, nel frattempo che aspettavo delle Vostre risposte ho cercato su google.
Ho trovato una soluzione a una domanda nel forum di ubuntu.
Ho dato questo da terminale sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak
sudo gedit /etc/apt/sources.list
Ho cancellato il tutto e ho copiato questo deb http://it.archive.ubuntu.com/ubuntu/ hardy main universe restricted multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ hardy main universe restricted multiverse

deb http://security.ubuntu.com/ubuntu hardy-security main universe restricted multiverse
#deb-src http://security.ubuntu.com/ubuntu hardy-security main universe restricted multiverse

deb http://it.archive.ubuntu.com/ubuntu/ hardy-updates main universe restricted multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ hardy-updates main universe restricted multiverse

Ho salvato e poi ho dato sudo apt-get update

e poi sudo apt-get -f install

Per adesso tutto ok
Secondo voi ho fatto una cosa giusta?[/u]


RE: Errore gestore pacchetti - laudo - 13-03-2012

A dare il comando che dite voi cioe' questo sudo gedit /etc/apt/sources.list
mi da' questo




RE: Errore gestore pacchetti - Antonio_Cantaro - 13-03-2012

Praticamente non hai nessun repository e quindi non fai aggiornamenti.


RE: Errore gestore pacchetti - laudo - 13-03-2012

(13-03-2012, 22:03 )Antonio_Cantaro Ha scritto: Praticamente non hai nessun repository e quindi non fai aggiornamenti.
Bene sono contento.
Soluzione?
Se esiste?
Grazie prof.



RE: Errore gestore pacchetti - Antonio_Cantaro - 13-03-2012

Certo, vai in Sistema / Applicazioni

ed apri sorgenti software

poi metti le spunte nelle sezioni:

Software per Ubuntu

Altro software

http://www.istitutomajorana.it/files/ubuntu/38-amministrazione/06-synaptic-aggiornamenti.htm