Forum Informatica Majorana
[RISOLTO] Impostare risoluzione PC Linux LXDE - Versione stampabile

+- Forum Informatica Majorana (http://www.istitutomajorana.it/forum)
+-- Forum: Sistemi Operativi: Ubuntu, Windows, Linux, Altri (/Forum-Sistemi-Operativi-Ubuntu-Windows-Linux-Altri)
+--- Forum: PCLinuxOS e distribuzioni correlate (/Forum-PCLinuxOS-e-distribuzioni-correlate)
+--- Discussione: [RISOLTO] Impostare risoluzione PC Linux LXDE (/Thread-RISOLTO-Impostare-risoluzione-PC-Linux-LXDE)



[RISOLTO] Impostare risoluzione PC Linux LXDE - warp - 06-05-2012 11:51

Ho installato PC Linux LXDE su un altro pc desktop, con scheda video Nvidia Gt 440.

Andando come utente root in Configuration=>Nvidia Display settings, ottengo il messaggio:

"You do not appear to be using the Nvidia S driver. Please edit your X configuration file (just run "nvidia-xconfig" as root), and restart the X server.

Grazie dei suggerimenti.


RE: Impostare risoluzione PC Linux LXDE - monsee - 06-05-2012 15:10

Devi semplicemente aprire il Terminale (LXTerminal, nel tuo caso) e scrivere:

su

Ti verrà richiesta la password di root. Forniscila.
In questo modo, diventi "root". Fatto questo, devi scrivere (sempre nel medesimo LXTerminal):

nvidia-xconfig

e dare invio.

Seguirà la configurazione del tuo NVIDIA. Fatto questo, chiudi tutto con calma e riavvia il Server X (insomma, esci dalla sessione e poi rientraci... oppure direttamente riavvia il PC).
Comunque, in LXDE, per impostare la risoluzione dello schermo c'è anche uno specifico programma (grafico).


RE: Impostare risoluzione PC Linux LXDE - warp - 08-05-2012 11:04

Ho agito da "Configura il computer" e ho fatto riconoscere il monitor. Per la risoluzione ho scelto "automatica".

Il fatto è che non mi proponeva la risoluzione nativa, ovvero 1690*1050.

Adesso nemmeno si avvia l'interfaccia grafica, ma compare l'output di Xorg.


(06-05-2012 15:10 )monsee Ha scritto:  Devi semplicemente aprire il Terminale (LXTerminal, nel tuo caso) e scrivere:

su

Ti verrà richiesta la password di root. Forniscila.
In questo modo, diventi "root". Fatto questo, devi scrivere (sempre nel medesimo LXTerminal):

nvidia-xconfig

e dare invio.

Seguirà la configurazione del tuo NVIDIA. Fatto questo, chiudi tutto con calma e riavvia il Server X (insomma, esci dalla sessione e poi rientraci... oppure direttamente riavvia il PC).
Comunque, in LXDE, per impostare la risoluzione dello schermo c'è anche uno specifico programma (grafico).



RE: Impostare risoluzione PC Linux LXDE - monsee - 08-05-2012 11:29

Scusa, ma perchè mai hai preferito ignorare il mio suggerimento?
Se volevi agire comunque "da interfaccia grafica" va bene (figurati se non ti capisco!), però dovevi prima almeno chiedere DA QUALE programma avresti dovuto intervenire. Ti avrei risposto che potevi intervenire dal programma LXMonitor Settings (accessibile direttamente oppure tramite "Configure Your LXDesktop").
In quanto alla risoluzione, mi par che quella "nativa" tua sia non l'avevo mai nemmeno sentita, prima d'ora.
Sui miei 2 desktopPC uso uno schermo che ha una risoluzione, tuttavia, non molto dissimile (1680x1050) e PClinuxOS ci gira benissimo, riconoscendo al volo l'esatta risoluzione.
In quanto al cosa puoi fare adesso, onestamente non saprei che suggerirti. Con Xorg che non si avvia bisogna agir per forza da "riga di comando" e -onestamente- in questo genere di cose io non son certo un asso... Tant'è che -se fossi al posto tuo- io reinstallerei daccapo.


RE: Impostare risoluzione PC Linux LXDE - warp - 08-05-2012 14:02

Hai ragione Monsee, prima ho anche provato a fare come mi hai detto. Ho ottenuto un messaggio che non ricordo. Adesso provo a reinstallare e poi seguo le tue istruzioni.

la risoluzione è quella standard: 1680*1050, dunque standard.

(08-05-2012 11:29 )monsee Ha scritto:  Scusa, ma perchè mai hai preferito ignorare il mio suggerimento?
Se volevi agire comunque "da interfaccia grafica" va bene (figurati se non ti capisco!), però dovevi prima almeno chiedere DA QUALE programma avresti dovuto intervenire. Ti avrei risposto che potevi intervenire dal programma LXMonitor Settings (accessibile direttamente oppure tramite "Configure Your LXDesktop").
In quanto alla risoluzione, mi par che quella "nativa" tua sia non l'avevo mai nemmeno sentita, prima d'ora.
Sui miei 2 desktopPC uso uno schermo che ha una risoluzione, tuttavia, non molto dissimile (1680x1050) e PClinuxOS ci gira benissimo, riconoscendo al volo l'esatta risoluzione.
In quanto al cosa puoi fare adesso, onestamente non saprei che suggerirti. Con Xorg che non si avvia bisogna agir per forza da "riga di comando" e -onestamente- in questo genere di cose io non son certo un asso... Tant'è che -se fossi al posto tuo- io reinstallerei daccapo.



RE: Impostare risoluzione PC Linux LXDE - monsee - 08-05-2012 14:45

Se la tua risoluzione è 1680x1050, ti posso garantire che PCLinuxOS la supporta alla grande, perchè è la medesima risoluzione che uso nei miei 2 desktopPC... su entrambi ho installato PCLinuxOS a 32-bit (nelle versioni: LXDE-mini, LXDE, XFCE-Phoenix, XFCE-Phinx e ZEN-mini) e la risoluzione dello schermo funziona d'incanto.


RE: Impostare risoluzione PC Linux LXDE - warp - 08-05-2012 15:14

Ho digitato quanto mi hai detto e copio i messaggi di seguito: "[root@localhost gino]# nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

[root@localhost gino]# nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

[root@localhost gino]#

Inoltre, da "configure your LXdesktop", ho SOLO le seguenti 3 risoluzioni:

640*480
800*600
1024*768

Come posso andare avanti? Grazie.

(08-05-2012 14:45 )monsee Ha scritto:  Se la tua risoluzione è 1680x1050, ti posso garantire che PCLinuxOS la supporta alla grande, perchè è la medesima risoluzione che uso nei miei 2 desktopPC... su entrambi ho installato PCLinuxOS a 32-bit (nelle versioni: LXDE-mini, LXDE, XFCE-Phoenix, XFCE-Phinx e ZEN-mini) e la risoluzione dello schermo funziona d'incanto.



RE: Impostare risoluzione PC Linux LXDE - monsee - 08-05-2012 17:57

Procedi, per favore, ad installare (se non li hai già) o re-installare (se già li hai), tutti i seguenti pacchetti (normalmente, da Synaptic):

dkms-nvidia173
dkms-nvidia96xx
dkms-nvidia-current
x11-driver-video

x11-driver-video-nouveau
x11-driver-video-nv
x11-driver-video-nvidia173
x11-driver-video-nvidia96xx
x11-driver-video-nvidia-current


In realtà, alcuni di questi pacchetti (quelli che ho lasciato scritti a grandezza normale e grassetto) ti dovrebbero venir proposti da Synaptic quando selezionerai gli altri (quelli che ho invece scritto con caratteri ingranditi). Accetta tutti i pacchetti che Synaptic ti propone di installare.
Dopo aver installato tutto, procedi a riavviare il tuo PC.
A riavvio avvento, rientrato sul desktop, fai:
Menu/Altri programmi/Configurazione/LXMonitor Settings
Nella finestra che ti appare, imposta la risoluzione del tuo Monitor (presumo che sia un monitor VGA), ovvero 1680x1050, scegliendo anche la giusta frequenza di aggiornamento (... forse, 60.0?)... e togli la spunta (se c'è) alla voce relativa al DVI.
Dopo di che, clicca su "Applica".
La risoluzione da te impostata verrà immediatamente terstata. Se vedi che ti funziona bene, dai conferma.
Poi, riapri il programma LXMonitor Settings.
Ci ritroverai le impostazioni che hai dato. A questo punto, clicca su "Salva".
In questo modo, la configurazione verrà re-impostata automaticamente ad ogni avvio.


RE: Impostare risoluzione PC Linux LXDE - warp - 09-05-2012 08:08

Dopo aver dato 2 volte "nvidia-xconfig"
, come scritto nel messaggio precedente, ho riavviato e poi la risoluzione si è impostata in automatico correttamente. Da "display settings", ora ho 1680*1050 a 50 HZ.

Da Synaptic ho controllato i vari pacchetti che mi hai indicato e sono tutti presenti!

(08-05-2012 17:57 )monsee Ha scritto:  Procedi, per favore, ad installare (se non li hai già) o re-installare (se già li hai), tutti i seguenti pacchetti (normalmente, da Synaptic):

dkms-nvidia173
dkms-nvidia96xx
dkms-nvidia-current
x11-driver-video

x11-driver-video-nouveau
x11-driver-video-nv
x11-driver-video-nvidia173
x11-driver-video-nvidia96xx
x11-driver-video-nvidia-current


In realtà, alcuni di questi pacchetti (quelli che ho lasciato scritti a grandezza normale e grassetto) ti dovrebbero venir proposti da Synaptic quando selezionerai gli altri (quelli che ho invece scritto con caratteri ingranditi). Accetta tutti i pacchetti che Synaptic ti propone di installare.
Dopo aver installato tutto, procedi a riavviare il tuo PC.
A riavvio avvento, rientrato sul desktop, fai:
Menu/Altri programmi/Configurazione/LXMonitor Settings
Nella finestra che ti appare, imposta la risoluzione del tuo Monitor (presumo che sia un monitor VGA), ovvero 1680x1050, scegliendo anche la giusta frequenza di aggiornamento (... forse, 60.0?)... e togli la spunta (se c'è) alla voce relativa al DVI.
Dopo di che, clicca su "Applica".
La risoluzione da te impostata verrà immediatamente terstata. Se vedi che ti funziona bene, dai conferma.
Poi, riapri il programma LXMonitor Settings.
Ci ritroverai le impostazioni che hai dato. A questo punto, clicca su "Salva".
In questo modo, la configurazione verrà re-impostata automaticamente ad ogni avvio.



RE: Impostare risoluzione PC Linux LXDE - monsee - 09-05-2012 11:05

Bene, lietissimo che ora il problema tuo si sia risolto. Ti invito a mettere il
[RISOLTO]
nel titolo della Discussione, in conseguenza. Grazie.