SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
BIOS
#11
(27-10-2013, 07:41 )Barezzi Luigi Ha scritto: inoltre,fonte HP:
http://h10025.www1.hp.com/ewfrf/wc/docum...=c01374505
il link di HP non parla di virus ma di fallimento dell'update del BIOS, non c'entra niente con i malware.

(27-10-2013, 09:10 )Barezzi Luigi Ha scritto: strani, leggeri e sospetti malfuzionamenti che non pregiudicano l'utilizzo del pc sono evidenti
e quali sarebbero i malfunzionamenti? magari sono cose normalissime e non c'entrano niente coi virus. Se uno accusa un disturbo mica deve avere per forza il cancro!

(27-10-2013, 07:41 )Barezzi Luigi Ha scritto: Mai sentito parlare di Mebroni?
dai un ochiata qui:
http://www.hwfiles.it/news/mebromi-il-ma...38503.html
i "virus" da BIOS non sono una novità, esistevano già una ventina di anni fa, tanto che ad un certo punto nei BIOS fu inserita l'opzione di impedire la scrittura della CMOS (ora FLASH) per evitare il problema. Poi vennero introdotte le schede madri dual-bios, in modo che se il bios "eseguito" malfunzionasse poteva essere sovrascritto da uno sicuro e non modificabile.
Detto questo, per eliminare un eventuale virus da BIOS basta sovrascriverlo con una versione di BIOS pulita.
In ogni caso tu parli di Mebroni che può attaccare solo BIOS di marca AMI e solo certe versioni. Non esiste un trojan che può attaccare tutte le versioni di BIOS esistenti e di qualunque marca.

Se hai un problema col tuo computer hai ipotizzato una causa estremamente improbabile (anche se teoricamente possibile). Ma quale sarebbe il problema del computer?
Come detto prima se anche fosse un virus da BIOS sovrascrivi il BIOS, dopodiché dai una scansione con un live-cd apposito, per esempio quello Kasperski o quello di Avira, entrambi gratuiti

P.S.
non è vero che i BIOS si aggiornano solo con i .exe, le schede madri spesso hanno a bordo utility che eseguono l'aggiornamento del BIOS direttamente dal BIOS stesso, basta mettere il file .bin o .rom o .quellocheè su una pendrive; ce ne sono anche che aggiornano il BOS collegandosi direttamete ad Internet e, da qualche tempo, ci sono schede (Asus per esempio) che possono aggiornare il BOS perfino senza accendere il computer!
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#12
(27-10-2013, 12:11 )BAT Ha scritto:
(27-10-2013, 07:41 )Barezzi Luigi Ha scritto: inoltre,fonte HP:
http://h10025.www1.hp.com/ewfrf/wc/docum...=c01374505
il link di HP non parla di virus ma di fallimento dell'update del BIOS, non c'entra niente con i malware.

(27-10-2013, 09:10 )Barezzi Luigi Ha scritto: strani, leggeri e sospetti malfuzionamenti che non pregiudicano l'utilizzo del pc sono evidenti
e quali sarebbero i malfunzionamenti? magari sono cose normalissime e non c'entrano niente coi virus. Se uno accusa un disturbo mica deve avere per forza il cancro

(27-10-2013, 07:41 )Barezzi Luigi Ha scritto: Mai sentito parlare di Mebroni?
dai un ochiata qui:
http://www.hwfiles.it/news/mebromi-il-ma...38503.html
i "virus" da BIOS non sono una novità, esistevano già una ventina di anni fa, tanto che ad un certo punto nei BIOS fu inserita l'opzione di impedire la scrittura della CMOS (ora FLASH) per evitare il problema. Poi vennero introdotte le schede madri dual-bios, in modo che se il bios "eseguito" malfunzionasse poteva essere sovrascritto da uno sicuro e non modificabile.
Detto questo, per eliminare un eventuale virus da BIOS basta sovrascriverlo con una versione di BIOS pulita.
In ogni caso tu parli di Mebroni che può attaccare solo BIOS di marca AMI e solo certe versioni. Non esiste un trojan che può attaccare tutte le versioni di BIOS esistenti e di qualunque marca.

Se hai un problema col tuo computer hai ipotizzato una causa estremamente improbabile (anche se teoricamente possibile). Ma quale sarebbe il problema del computer?
Come detto prima se anche fosse un virus da BIOS sovrascrivi il BIOS, dopodiché dai una scansione con un live-cd apposito, per esempio quello Kasperski o quello di Avira, entrambi gratuiti

P.S.
non è vero che i BIOS si aggiornano solo con i .exe, le schede madri spesso hanno a bordo utility che eseguono l'aggiornamento del BIOS direttamente dal BIOS stesso, basta mettere il file .bin o .rom o .quellocheè su una pendrive; ce ne sono anche che aggiornano il BOS collegandosi direttamete ad Internet e, da qualche tempo, ci sono schede (Asus per esempio) che possono aggiornare il BOS perfino senza accendere il computer!

1 dal sito hp:
Il BIOS è stato aggiornato "in modo scorretto". Questo problema si verifica se si perde alimentazione durante l'aggiornamento del BIOS, oppure se si aggiorna il BIOS con un aggiornamento non scaricato da HP oppure quando un virus o un programma maligno modificano i dati del BIOS.
Se leggi fino in fondo:
oppure quando un virus o un programma maligno modificano i dati del BIOS.
quindi mi sembra abbastanza chiaro.
salto il punto due perchè molto lungo e mi seve il pc che ho al lavoro per essere più preciso sui messaggi che compaiono all' avvio ti aggiornerò domani quando andro al lavoro.
Punto 3 non ho un bios da sovrascrivere il pc è piuttosto datato e vorrei utilizzare quest' ultima soluzione in quanto non ho la certezza di avere e/o trovare un bios 100% compatibile.
Inoltre temo che questo pc sia stato dotato di un bios proprietario .
Ho un dvd di ripristino(che però non viene più rilevato all' avvio del pc) vi sono diverse cartelle bios ma non ho ancora capito come funzionano e/o se esiste una possibilità di utilizzarle.
Domani se sei ancora interessato ti farò una relazione sui malfunzionamenti che mi fanno pensare che il problema sia proprio nel bios del pc

Sono pienamente d' accordo con te
Mebromi puo attaccate bios Phoenix Technologies, su sistemi xp purtroppo proprio come nel mio pc

Grazie dell' interessamento
Luigi
Cita messaggio
#13
Già che ci sei, appena hai il PC sottomano cerca di descrivere precisamente l'hardware: marca e modello del PC e marca/modello di scheda madre,scheda grafica, tipo di hard disk, quantità di RAM, sistema operativo (comprensivo di aggiornamenti o service pack) ecc.
Se ha un BIOS proprietario è una buona notizia, difficilissimo che sia corrotto da un virus;
poi serve sapre che tipo di malfunzionamenti rilevi, se succede solo quando fai determinate azioni ecc. ecc.;
se il PC è vecchio i malfunzionamenti potrebbero dipendere dall'hardware un po' usurato, soprattutto il disco, oppure parte dei file di sistema rovinati.
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#14
(27-10-2013, 22:40 )BAT Ha scritto: Già che ci sei, appena hai il PC sottomano cerca di descrivere precisamente l'hardware: marca e modello del PC e marca/modello di scheda madre,scheda grafica, tipo di hard disk, quantità di RAM, sistema operativo (comprensivo di aggiornamenti o service pack) ecc.
Se ha un BIOS proprietario è una buona notizia, difficilissimo che sia corrotto da un virus;
poi serve sapre che tipo di malfunzionamenti rilevi, se succede solo quando fai determinate azioni ecc. ecc.;
se il PC è vecchio i malfunzionamenti potrebbero dipendere dall'hardware un po' usurato, soprattutto il disco, oppure parte dei file di sistema rovinati.

Malfunzionamenti:
tutto inizia dopo le ferie il pc è stato sconnesso dalla tensione per almeno una settimana .Al mio rientro una serie di bip e schermo nero morale dalla sequenza dei bip sembra che la scheda video sia andata, ma mi sorge un dubbio e provo a sostituire la batteria tampone che è completamente scarica.
Morale tutto riprende a funzionare ma non è la batteria in quando poco dopo si ripete il problema e devo agire sul jumper di reset del bios perchè anche a togliere e rimettere la batteria non sempre funziona.
Le provo un po tutte finche mi viene un' idea:
formatto tutto reinstallo alle condizioni di fabbrica installo ubuntu 5(che funziona sempre ma non si può più aggiornare) e da ubuntu mi lavoro il pc con antivirus e ubuntu MRT scansiono a più non posso windows XP che è spento e deve ancora essere avviato.
Morale trovo infezioni ancora prima che windows venga avviato per la seconda volta??????????????????
ora tutte le volte che accendo il pc mi compare:
cmos chec sum error defaults loaded warning! now system is in safe mode
Please re-setting cpu frequency in the cmos set up
Ma io non ho smanettato mai nessuna frequenza !!!! e poi il pc non dovrebbe tornare alle impostazioni di fabbrica?
2 all' avvio mi legge solo cd ma non dvd che vengono regolarmente letti a SO caricato.Non mi legge nemmeno il dvd originale di ripristino anzi se forzo la lettura dopo averlo caricato mi compare :
stop: c000021a fatal system error the session manager initialiaztion system process terminated wex pectedly with a status of 0x000003a(0x00000000ax 00000000ax) e questo mi fa pensare che esistesse un boot originale che si è modificato (potrebbe e4ssere stato anche modificato con un' installazione di ubuntu?)
Su xp se installalo Visua DBase 7.0 di borland(che uso per lavoro) all' avvio di vdbase mi compare un errore di runtime.
Ho tentato anche:
formatto tutto installo xp con licenza originale e vdbase mi da lo stesso errore di runtime
Installo su di un altro pc con seven virtualbox con la stessa versione di xp senza aggiornarla e vdbase funziona correttamente (?)
Ovviamente premetto che vdbase su questo pc ha sempre funzionato.
Le chiavette di boot usb create con ubuntu non tutte funzioanno.
Finziona solo una da 2G che non so nemmeno di che marca è e che ho ricevuto in omaggio e una vecchia kingsdom da 8G le altre funzionano un pò a simpatia nemmeno una kingsdom 16g comprata nuova per l' occasione per evitare eventuali inconvenienti.
Per il resto una volta Avviato UBUNTU MAJONIX(OTTIMO) tutto funziona perfettamente .Windows anche se no funziona VDbase( ma il suo aggiornamento db2k si) a parte lo uso con parsimonia perche temo che qualche operazione potrebbe reinescare tutto da capo.
Che pensare se non un problema di infezione del bios?
Compiuter Packard bell Istart xp home sp2
Bios Phoenix awar workstationsbios v.6.00pg an energy star ally amd sempron tm
1g ram
sceda video integrata Nvidia 6100
Hd seagate ata st3160212a
La scheda madre non riesco per ora ad identificarla se conosci qualche sistema ...
Scusa il poema ma credo che sia il minimo indispensabile per avere un quadro corretto della situazione
Grazie
Luigi
Cita messaggio
#15
Mebroni colpisce i BIOS Award non quelli Phoenix come nel tuo caso;
i messaggi che hai dal BIOS talvlta capitano (checksum error, CPU not detected, ecc. ecc.); quello che devi in questo oridine preceiso:
  • STACCARE FISICAMENTE la corrente (stacca il cavo dalla presa elettrica)
  • togliere la batteria al litio interna
  • aspettare circa 5 minuti in modo da far scaricare completamente tutti i condensatori, compresi quelli dell'alimentatore
  • reinserire la pila al litio (se è nuova è meglio)
  • riconnettere l'alimentazione
  • riaccendere il PC ed entrare immediatamente nel BIOS
  • caricare le impostazioni standard del BIOS (c'è una opzione apposita
  • verificare se devi modificare qualcosa nel BIOS per abilitare o disabilitare determinate funzioni
  • uscire dal BIOS salvando le nuova impostazioni
I problemi che denunci fanno pensare più alla corruzione dei file del sistema operativo (i motivi possono essere diversi: CD di installazione rovinato, hard disk rovinato ecc. ecc.); ci metto la mano sul fuoco che il BIOS non c'entra niente, comunque se vuoi escluderlo, suggerisco di andare nel sito del produttore e verificare di avere l'ultima versione disponibile. Potresti anche avere dei settori guasti su disco o parte della RAM difettosa. Insomma mi viene da pensare a tutto tranne che ad un improbabilissimo virus da BIOS.
Dopo aver verificato l'assenza di guasti hardware al prima cosa da fare sarebbe di formattare il disco fisso a BASSO LIVELLO (non con Gparted o confratelli); inoltre, visto che il PC è vecchio, sarebbe bene cambiare l'alimentatore.

Vedi se puoi lavorarci su, ma ti assicuro che l'ipotesi virus-nel-BIOS secondo me è "quasi" impossibile; e ci metto il "quasi" solo perché IN TEORIA è una delle migliaia di possibilità ma non ci credo. Tra l'altro i virus da BIOS in genere non sono studiati per fare danni ma per prendere il controllo del computer a tua insaputa: se lo rendessero inutilizzabile non ne trarrebbero vantaggio quelli che l'hanno sviluppato.
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#16
(28-10-2013, 12:53 )BAT Ha scritto: Mebroni colpisce i BIOS Award non quelli Phoenix come nel tuo caso;
i messaggi che hai dal BIOS talvlta capitano (checksum error, CPU not detected, ecc. ecc.); quello che devi in questo oridine preceiso:
  • STACCARE FISICAMENTE la corrente (stacca il cavo dalla presa elettrica)
  • togliere la batteria al litio interna
  • aspettare circa 5 minuti in modo da far scaricare completamente tutti i condensatori, compresi quelli dell'alimentatore
  • reinserire la pila al litio (se è nuova è meglio)
  • riconnettere l'alimentazione
  • riaccendere il PC ed entrare immediatamente nel BIOS
  • caricare le impostazioni standard del BIOS (c'è una opzione apposita
  • verificare se devi modificare qualcosa nel BIOS per abilitare o disabilitare determinate funzioni
  • uscire dal BIOS salvando le nuova impostazioni
I problemi che denunci fanno pensare più alla corruzione dei file del sistema operativo (i motivi possono essere diversi: CD di installazione rovinato, hard disk rovinato ecc. ecc.); ci metto la mano sul fuoco che il BIOS non c'entra niente, comunque se vuoi escluderlo, suggerisco di andare nel sito del produttore e verificare di avere l'ultima versione disponibile. Potresti anche avere dei settori guasti su disco o parte della RAM difettosa. Insomma mi viene da pensare a tutto tranne che ad un improbabilissimo virus da BIOS.
Dopo aver verificato l'assenza di guasti hardware al prima cosa da fare sarebbe di formattare il disco fisso a BASSO LIVELLO (non con Gparted o confratelli); inoltre, visto che il PC è vecchio, sarebbe bene cambiare l'alimentatore.

Vedi se puoi lavorarci su, ma ti assicuro che l'ipotesi virus-nel-BIOS secondo me è "quasi" impossibile; e ci metto il "quasi" solo perché IN TEORIA è una delle migliaia di possibilità ma non ci credo. Tra l'altro i virus da BIOS in genere non sono studiati per fare danni ma per prendere il controllo del computer a tua insaputa: se lo rendessero inutilizzabile non ne trarrebbero vantaggio quelli che l'hanno sviluppato.
Imessaggi del bios capitano tutte le volte anche quando ripristino le condizioni di default
Scusami ma non mi è chiaro quando ho scritto:
phoenix AWARD workstations bios v6.00pg
Award e phonix non sono la stessa azienda?
vedi qui:
http://www.award-bios.com/
La procedura della batteria che mi descivi fa parte del primo tentativo fatto diverse volte, così come il reset attraveso l' opzione del bios stesso.
Nel sito di PB inserendo il n° seriale o sn sel PC non si trova nessun aggiornamento del bios.
Ho testato sia la ram che la scheda video con delle utility che non hanno rilevato nulla.
E cosa mi dici delle infezioni trovate sul PC già dopo il primo avvio?
Potrebbe anche trattarsi di falsi positivi?
Il dvd di ripristino l' ho provato su di un altro pc PB funziona fino a quando mi chiede di ripristinare ovviamente non sono andato oltre.
Hd ho provato a testarlo è Ok.
All' alimentatore non avevo ancora pensato il pc è del 2006
Io mi sono fatto questa teoria:
infezione del bios-> modifica del settore o dell MBR (che potrebbe giustiificare il dvd che non si avvai)-> problemi a catena
qualche altra infezione che iimpedisce di leggere i dvd all' avvio???-> problemi a catena
Putroppo non riesco a trovare un bios sicuramente compatibile al 100x100 in quanto credo che sovrasciverlo potrebbe escludere parecchi ipotesi.
Perchè quando avvio i SO non ho poi nessun problema?(VDBASE a parte) il dvd riprende a funzionare così come tutte le chavette usb?
Lo so che non è facile ma chiedo a voi perchè sono un pò in difficoltà
Non è per caso che qualcuno di voi sa se è possibile estrarre dal dvd di ripristino il bios originale?
Allegato cartelle bios dal dvd di ripristino
Grazie
Luigi


Allegati Anteprime
   
Cita messaggio
#17
ops!
sulla marca del bios hai ragione tu, Award e Phoenix si sono fuse da un sacco di anni;

il problema di VDBASE FORSE è software, te lo dicono i messaggi di errore: manca un componente runtime; sul perché manchi ci sono varie possibilità: il vecchio componente runtime è stato eliminato e soatituito da una versione più recente (invece VDBASE ne richiedeva una specifica).
Googlando un po' ho trovato questa pagina: http://www.goldenstag.net/dbase/
dove dice ad un certo punto che VDBASE 7 non gira come si deve se sia nel BIOS che in Windows XP sono abilitate le opzione DEP (Data Execution Prevention, sono opzioni di sicurezza); che io sappia queste opzioni di sicurezza dovrebbero essere automaticamente attive su XP a partire dal SP2; secondo ciò che dice questa pagina dovresti entrare nel BIOS, cercare l'opzione e disabilitarla; a me questa soluzione, anche se dovesse funzionare, non piace per niente;
qui https://groups.google.com/forum/#!topic/...YibWMaGSeo
dicono che la versione 7 del software è piuttosto instabile ed incline ad errori e consigliano di usarne una più recente.

La faccenda dl DVD che non funziona è veramente curiosa;se ho ben capito ti legge al boot solo i CD ma non i DVD, che invece funzionano regolarmente DOPO l'avvio dl sistema operativo; questo mi fa pensare più ad un piccolo problema della testina di lettura del lettore DVD, forse è un po' difettosa e dovresti sostituire il lettore.
Puoi fare una prova: a PC spento e corrente staccata, stacca i cavi che connettono l'hard disk alla scheda madre, lascia collegato solo il lettore DVD; riaccendi il compuer, entra nel BIOS e setta il CD/DVD come disositivo di boot primario; a questo punto inserisci un live-DVD Linux; ora se esci dal BIOS dovrebbe avviarsi Linux da DVD ma, se non lo fa, limitati a premere il tasto RESET (se c'è) oppure fai CTRL+ALT+CANC per riavviare; queste operazioni fanno passare alcuni secondi durante i quali spero che la testina del lettore "entri a regime" e al secondo avvio legga il DVD; se non lo fa il lettore deve essere per forza difettoso.
Nota che in questo modo hai l'hard disk staccato ed anche se tu avessi un BIOS con virus non potrebbe fare niente; nota anche che l'eventuale presenza del virus non c'entra nulla col malfunzionamento del DVD (a questo punto dovrebbe essere innocente anche l'alimentatore, anche se cambiarlo non farebbe male).

Continuo ad essere scettico sul virus nel BIOS, anche perché non si capisce come ha fatto ad entrarci, qui non stiamo parlando di script avviati per errore, se ci fosse entrato qualcuno coi provilegi di amministratore ha eseguito qualcosa per alterare il BIOS e ha pure confermato l'operazione.

P.S.
A proposito: è meglio se tutte queste prove le fai; cerca meglio anche se nel sito Packard Bell c'è una qualsiasi versione decente di BIOS per il tuo PC; ti faccio notare che, se fosse vera l'ipotesi virus (cosa a cui non credo) e NON trovi un altro BIOS, quel computer non devi usarlo mai più, né per Windows né per Linux.
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#18
(28-10-2013, 17:18 )BAT Ha scritto: ops!
sulla marca del bios hai ragione tu, Award e Phoenix si sono fuse da un sacco di anni;

il problema di VDBASE FORSE è software, te lo dicono i messaggi di errore: manca un componente runtime; sul perché manchi ci sono varie possibilità: il vecchio componente runtime è stato eliminato e soatituito da una versione più recente (invece VDBASE ne richiedeva una specifica).
Googlando un po' ho trovato questa pagina: http://www.goldenstag.net/dbase/
dove dice ad un certo punto che VDBASE 7 non gira come si deve se sia nel BIOS che in Windows XP sono abilitate le opzione DEP (Data Execution Prevention, sono opzioni di sicurezza); che io sappia queste opzioni di sicurezza dovrebbero essere automaticamente attive su XP a partire dal SP2; secondo ciò che dice questa pagina dovresti entrare nel BIOS, cercare l'opzione e disabilitarla; a me questa soluzione, anche se dovesse funzionare, non piace per niente;
qui https://groups.google.com/forum/#!topic/...YibWMaGSeo
dicono che la versione 7 del software è piuttosto instabile ed incline ad errori e consigliano di usarne una più recente.

La faccenda dl DVD che non funziona è veramente curiosa;se ho ben capito ti legge al boot solo i CD ma non i DVD, che invece funzionano regolarmente DOPO l'avvio dl sistema operativo; questo mi fa pensare più ad un piccolo problema della testina di lettura del lettore DVD, forse è un po' difettosa e dovresti sostituire il lettore.
Puoi fare una prova: a PC spento e corrente staccata, stacca i cavi che connettono l'hard disk alla scheda madre, lascia collegato solo il lettore DVD; riaccendi il compuer, entra nel BIOS e setta il CD/DVD come disositivo di boot primario; a questo punto inserisci un live-DVD Linux; ora se esci dal BIOS dovrebbe avviarsi Linux da DVD ma, se non lo fa, limitati a premere il tasto RESET (se c'è) oppure fai CTRL+ALT+CANC per riavviare; queste operazioni fanno passare alcuni secondi durante i quali spero che la testina del lettore "entri a regime" e al secondo avvio legga il DVD; se non lo fa il lettore deve essere per forza difettoso.
Nota che in questo modo hai l'hard disk staccato ed anche se tu avessi un BIOS con virus non potrebbe fare niente; nota anche che l'eventuale presenza del virus non c'entra nulla col malfunzionamento del DVD (a questo punto dovrebbe essere innocente anche l'alimentatore, anche se cambiarlo non farebbe male).

Continuo ad essere scettico sul virus nel BIOS, anche perché non si capisce come ha fatto ad entrarci, qui non stiamo parlando di script avviati per errore, se ci fosse entrato qualcuno coi provilegi di amministratore ha eseguito qualcosa per alterare il BIOS e ha pure confermato l'operazione.

P.S.
A proposito: è meglio se tutte queste prove le fai; cerca meglio anche se nel sito Packard Bell c'è una qualsiasi versione decente di BIOS per il tuo PC; ti faccio notare che, se fosse vera l'ipotesi virus (cosa a cui non credo) e NON trovi un altro BIOS, quel computer non devi usarlo mai più, né per Windows né per Linux.

Runtime eliminato?
vdbase ha sempre funzionato su questo pc, poi è successo qualche cosa(credo anche di sapere cosa) ho dovuto formattare, e da allora vdabse 7 non ha più funzionato (ma la versione succesiva db2k si) così come il dvd di ripristino........
Se ripristino a condizioni di fabbrica dovrei rimettere tutto il so come all'inizio quando funzionava, non trovi?
disattivare parametri di sicurezza........umhhhhh puzza parecchio anche a me!
VDBASE LO USO DA WINDOS 98 ed ha svolto sempre ed egregiamente il suo lavoro, è eccezionale spiccio e solido come la roccia(la Borlan era una garanzia)non l' ho mai trovato instabile nonostante l' ho utilizzato benissimo su tutti i sistemi operativi, vista compreso(qualche problema con le stampe dei report). con seven ho avuto qualche problema(funziona ma non stampa più) ma dopo oltre 10 anni credo che si possa anche accettare.
Mi trovo perfettamente d' accordo con te, invece di continuare a cercare come potere eliminare il problema non mi resta che provare a sostituire il bios(che è anche l'unica condizione per pulirlo) e vedere cosa succede altrimenti non mi rimane altro che mettere in pensione il pc .
Ok per Xp ma non capisco per quale motivo non dovrei utilizzare il PC con linux.
Per la procedura di ricavare il bios dalle cartelle del disco di ripristino ?
Possibile che non esista un sistema per capire se il bios è infetto?

Grazie per l tempo che mi hai dedicato
Luigi B.
Cita messaggio
#19
(28-10-2013, 19:21 )Barezzi Luigi Ha scritto: Runtime eliminato?
vdbase ha sempre funzionato su questo pc, poi è successo qualche cosa(credo anche di sapere cosa) ho dovuto formattare, e da allora vdabse 7 non ha più funzionato (ma la versione succesiva db2k si) così come il dvd di ripristino
significa che nel reinstallarlo va storto qualcosa o dimentichi (o semplicemente non sai) che c'è altro da installare; in particolare i moduli runtime potrebbero essere librerie del Visual C apposite; il problema è "vai a sapere quali"... probabilmente prima della formattazione le avevi e ora non ce l'hai più; in ogni caso NON è una questione di virus.
Per quanto riguarda il DVD che non funziona più te l'jho già detto: potrebbe essere semplicemente rovinato il lettore; per verificarlo smontane uno da un PC che ha un lettore DVD integro e montalo sul PC incriminato.

(28-10-2013, 19:21 )Barezzi Luigi Ha scritto: Se ripristino a condizioni di fabbrica dovrei rimettere tutto il so come all'inizio quando funzionava, non trovi?
il DVD di ripristino riporta il PC alle condizioni di fabbrica se è stato costruito al primo avviodel PC; questo NON comprende VDBASE, ma solo Windows XP ed eventuali SW aggiuntivi preinstallati da Packard Bell.

Il motivo per cui non dovresti usarlo neanche con Linux è che un virus da BIOS compie come prima azione l'infezione del MBR; questo può implicare la modifica delle partizione e la perdita di tutti i dati.
A meno che tu suei uno di quelli che crede alla gigantesca boiata che "Linux è immune ai virus", allora usalo e tienti tutti i guai che ne deriveranno.

Comunque ti ripeto che secondo me il problema non è un virus nel BIOS; se hai veramente dei virus si eliminano cancellando tutte le partizioni e riformattando, oltre a sovrascrivere il MBR con un CD di boot. A questo proposito secondo me hai usato gli strumenti sbagliati: invece di Linux MRT usa Kasperski Rescue Disk (https://support.kaspersky.com/viruses/rescuedisk) oppure Avira Rescue System (https://www.avira.com/en/download/produc...cue-system); o semplicemente stacca l'hard disk, ontalo su un altro computer e scansionalo da li.

I software per Windows 98 sono tutt'altro che granitici; inoltre non si è mai sentito che un virus prenda di mira un applicativo Borland come dbase; tra l'altro se è una versione per Windows 98 non c'è niente di strano che il programma funzioni male: prova ad usare l'esecuzione in modalità compatibile (click col tasto destro del mouse sull'eseguible di VDBASE, seleziona "Propretà" e li dentro ci dovrebbe essere l'opzione per eseguirlo in modalità compatibile Win98). Se il software è così vecchio ha senso il suggerimento dell'altro post, ossia disabilitare il DEP nel BIOS (tanto XP da SP2 in poi ha le protezioni della memoria abilitate in modo predefinito e non si possono disabilitare). Del runtime presunto mancante ho già detto.

Capire se hai un virus nel BIOS? monta l'hard disk su un altro computer (senza virus) e formattalo a basso livello con Low Level Format tool (http://hddguru.com/software/HDD-LLF-Low-...rmat-Tool/). Poi rimontalo e installa solo Windows da un CD pulito. Poi riavvia il computer (se c'è un virus nel BIOS farà la sua cattiva azione di insinuarsi nel MBR del disco e replicarsi su una partizione). A questo punto riavvia con un cd di boot con antivirus (Kasperski o Avira) e fai una scansione. Se trovi infezioni il virus c'è; però poi scansiona il CD con cui installi Windows, potrebbe essere li dentro.
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#20
(28-10-2013, 20:57 )BAT Ha scritto:
(28-10-2013, 19:21 )Barezzi Luigi Ha scritto: Runtime eliminato?
vdbase ha sempre funzionato su questo pc, poi è successo qualche cosa(credo anche di sapere cosa) ho dovuto formattare, e da allora vdabse 7 non ha più funzionato (ma la versione succesiva db2k si) così come il dvd di ripristino
significa che nel reinstallarlo va storto qualcosa o dimentichi (o semplicemente non sai) che c'è altro da installare; in particolare i moduli runtime potrebbero essere librerie del Visual C apposite; il problema è "vai a sapere quali"... probabilmente prima della formattazione le avevi e ora non ce l'hai più; in ogni caso NON è una questione di virus.
Per quanto riguarda il DVD che non funziona più te l'jho già detto: potrebbe essere semplicemente rovinato il lettore; per verificarlo smontane uno da un PC che ha un lettore DVD integro e montalo sul PC incriminato.

(28-10-2013, 19:21 )Barezzi Luigi Ha scritto: Se ripristino a condizioni di fabbrica dovrei rimettere tutto il so come all'inizio quando funzionava, non trovi?
il DVD di ripristino riporta il PC alle condizioni di fabbrica se è stato costruito al primo avviodel PC; questo NON comprende VDBASE, ma solo Windows XP ed eventuali SW aggiuntivi preinstallati da Packard Bell.

Il motivo per cui non dovresti usarlo neanche con Linux è che un virus da BIOS compie come prima azione l'infezione del MBR; questo può implicare la modifica delle partizione e la perdita di tutti i dati.
A meno che tu suei uno di quelli che crede alla gigantesca boiata che "Linux è immune ai virus", allora usalo e tienti tutti i guai che ne deriveranno.

Comunque ti ripeto che secondo me il problema non è un virus nel BIOS; se hai veramente dei virus si eliminano cancellando tutte le partizioni e riformattando, oltre a sovrascrivere il MBR con un CD di boot. A questo proposito secondo me hai usato gli strumenti sbagliati: invece di Linux MRT usa Kasperski Rescue Disk (https://support.kaspersky.com/viruses/rescuedisk) oppure Avira Rescue System (https://www.avira.com/en/download/produc...cue-system); o semplicemente stacca l'hard disk, ontalo su un altro computer e scansionalo da li.

I software per Windows 98 sono tutt'altro che granitici; inoltre non si è mai sentito che un virus prenda di mira un applicativo Borland come dbase; tra l'altro se è una versione per Windows 98 non c'è niente di strano che il programma funzioni male: prova ad usare l'esecuzione in modalità compatibile (click col tasto destro del mouse sull'eseguible di VDBASE, seleziona "Propretà" e li dentro ci dovrebbe essere l'opzione per eseguirlo in modalità compatibile Win98). Se il software è così vecchio ha senso il suggerimento dell'altro post, ossia disabilitare il DEP nel BIOS (tanto XP da SP2 in poi ha le protezioni della memoria abilitate in modo predefinito e non si possono disabilitare). Del runtime presunto mancante ho già detto.

Capire se hai un virus nel BIOS? monta l'hard disk su un altro computer (senza virus) e formattalo a basso livello con Low Level Format tool (http://hddguru.com/software/HDD-LLF-Low-...rmat-Tool/). Poi rimontalo e installa solo Windows da un CD pulito. Poi riavvia il computer (se c'è un virus nel BIOS farà la sua cattiva azione di insinuarsi nel MBR del disco e replicarsi su una partizione). A questo punto riavvia con un cd di boot con antivirus (Kasperski o Avira) e fai una scansione. Se trovi infezioni il virus c'è; però poi scansiona il CD con cui installi Windows, potrebbe essere li dentro.


LAPALISSIANO ! !
GRAZIE Mille
ps
VDBASE in modalità compatibile? lo uso da anni ed è la prima cosa che ho fatto Questo è l'unico pc con xp sul quale non funziona(anche se a suo tempo ha funzionato)
Sicuramente dipende cosa ci fai con vdbase ma ti garantisco che fino ad oggi ho costruito applicazioni anche piuttosto complicate e riesco a farlo girare ancora tranquillamente senza problemi.
D' altronde chi vende applicazioni deve sempre cercare di venderti anche gli aggiornamenti non trovi?
Peccato che non giri su Linux e le sue derivate e/o non esista un clone
Giusto per la cronaca il dvd di ripristino come tutti gli altri dei miei pc è stato creato alla prima accensione ed ha sempre funzionato finoi ad ora..
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)