SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
configurazione client ltsp
#41
I servizi attivi per il sistema thin client, quindi ltsp, dhcp e tutto cio che hai configurato per attivare il sistema stesso.

dhcpd.conf
/etc/hosts
lts.conf
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#42
(01-02-2012, 10:09 )francater Ha scritto: I servizi attivi per il sistema thin client, quindi ltsp, dhcp e tutto cio che hai configurato per attivare il sistema stesso.

Ciao ho provato a copiare il contenuto di mariofiore in mario01 e rinominare quest'ultimo come mariofiore ma niente da fare! Penso sia unproplema collegato a qualche permesso particolare e questi sono i permessi della home
Codice:
mariofiore@mariofiore-desktop:~$ ls -l /home
totale 56
drwxr-xr-x 33 insegnanti users       4096 2012-01-21 10:43 insegnanti
drwx------  2 root       root       16384 2011-09-01 10:22 lost+found
drwxr-xr-x 21 mario01    users       4096 2012-01-21 11:55 mario01
drwxr-xr-x 20 mario02    users       4096 2012-01-20 11:58 mario02
drwxr-xr-x 22 mario05    users       4096 2012-01-20 17:23 mario05
drwxr-xr-x 20 mario06    users       4096 2012-01-20 12:07 mario06
drwxr-xr-x 25 mario07    users       4096 2012-01-21 10:51 mario07
drwxr-xr-x 21 mario08    users       4096 2012-01-20 17:23 mario08
drwxr-xr-x 23 mario100   mario100    4096 2012-01-21 11:55 mario100
drwxr-xr-x 30 mariofiore mariofiore  4096 2012-01-25 18:21 mariofiore
drwxrwxrwx  3 mariofiore mariofiore  4096 2011-11-12 14:14 partimag
Non vedo niente di particolare!

Comunque ecco quello che chiedi:

dhcpd.conf
Codice:
#
#
# Default LTSP dhcpd.conf config file.
#

authoritative;

subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.20 192.168.0.250;
    option domain-name "example.com";
    option domain-name-servers 192.168.0.1;
    option broadcast-address 192.168.0.255;
    option routers 192.168.0.1;
#    next-server 192.168.1.1;
#    get-lease-hostnames true;
    option subnet-mask 255.255.255.0;
    option root-path "/opt/ltsp/i386";
    if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
        filename "/ltsp/i386/pxelinux.0";
    } else {
        filename "/ltsp/i386/nbi.img";
    }
}


/etc/hosts
Codice:
127.0.0.1    localhost
127.0.1.1    mariofiore-desktop

#192.168.0.1        client01.ltsp    client01

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

lts.conf
Codice:
# This is the default lts.conf file for ltsp 5.
# For more information about valid options please see:
# /usr/share/doc/ltsp-client/examples/lts-parameters.txt.gz
# in the client environment.
#
# Note that things like sound and local device support are
# auto-enabled if the corresponding packages are installed,
# there is no need to manually set these options anymore.
#
# **** THIS FILE SHOULD NO LONGER BE USED FROM HERE !!! ****
#
# With the introduction of the nbd/unionfs/squashfs structure
# the lts.conf file moved to the tftp root please create:
# /var/lib/tftpboot/ltsp/i386/lts.conf instead for your changes
#
# In case you want to use the lts.conf here, this still works,
# but you need to run ltsp-update-image after every change.
#[example]
#key=value

[default]
LDM_DIRECTX=True
    X_COLOR_DEPTH=16
    LOCALDEV=True
    SOUND=True
    NBD_SWAP=True
    SYSLOG_HOST=server
    XKBLAYOUT=it

[00:D0:B7:20:AB:1B]
    XSERVER = vesa

[00:50:04:65:DD:D7]
    XSERVER = vesa

[00:50:04:0B:51:45]
    XSERVER = vesa

[00:50:04:BB:07:D0]
    XSERVER = vesa

[00:01:02:B0:27:E7]
    XSERVER = vesa

[00:13:21:06:89:FD]
    XSERVER = vesa

#[00:13:21:06:A7:E3]
#    XSERVER = i915
#    NBD_SWAP= False    
#    RUNLEVEL= 3

#[00:14:C2:03:4E:20]
#    XSERVER = i915
#    NBD_SWAP= False    
#    RUNLEVEL= 3

#[00:13:21:06:A8:1B]
#    XSERVER = i915
#    NBD_SWAP= False    
#    RUNLEVEL= 3

#[00:13:21:06:A7:17]
#    XSERVER = i915
#    NBD_SWAP= False    
#    RUNLEVEL= 3

Grazie
Samuele

Cita messaggio
#43
L'unica cosa strana è che, nei permessi utente nella home, mario01 e mario08 hanno lo stesso id.
Per il resto sembra tutto regolare, elimina uno dei due utenti (o tutti e due) e riprova.
Poi, eventualmente, ripristina

XSERVER = i915
NBD_SWAP= False

in lts.conf per le macchine PIV.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#44
(02-02-2012, 19:44 )francater Ha scritto: L'unica cosa strana è che, nei permessi utente nella home, mario01 e mario08 hanno lo stesso id.
Per il resto sembra tutto regolare, elimina uno dei due utenti (o tutti e due) e riprova.
Poi, eventualmente, ripristina

XSERVER = i915
NBD_SWAP= False

in lts.conf per le macchine PIV.

...Niente da fare non parte niente! Anzi se faccio qualche modifica al macaddress non arrivano neanche alla schermata di loginConfused
...per velocizzare ho installato ubuntu sui PIV!
Comunque le prove posso farle lo stesso...
Installando tutto su hard disk funziona benissimo solo che la cassa audio interna al case non funziona come se lo avviassi da lan...finzionano solo le casse esterne se le collego alla scheda audio integrata(ma questo è un altro problema)
AngryAngryAngrynon so nemmeno che prove fare perchè il fatto che l'utente mariofiore mi permetta di loggarmi mi fa supporre che il problema non dipenda dalla configurazione di lts.conf

Hai qualche metodo per il troubleshooting da indicarmi?
Cita messaggio
#45
Sinceramente no, è la prima volta che mi capita una cosa del genere.
Abbiamo messo mani ovunque, il fatto è che non riesci a loggarti solo con quei PIV. Visto che comunque hai installato il sistema lì sopra puoi vedere come riconosce l'hardware.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#46
(06-02-2012, 22:56 )francater Ha scritto: Sinceramente no, è la prima volta che mi capita una cosa del genere.
Abbiamo messo mani ovunque, il fatto è che non riesci a loggarti solo con quei PIV. Visto che comunque hai installato il sistema lì sopra puoi vedere come riconosce l'hardware.

Al post 24 ti ho inviato l'output del comando lshw dato dalla live di edubuntu (11.04 mi sembra)...è questo che intendi?

Comunque dalla vetta della mia grande ignoranza penso che non sia un problema di driver perchè(AngryAngry è questo che mi fa impazzire) l'utente mariofiore(e prima che cancellassi la cartella anche mario01) carica benissimo tutto.
Potrebbe esserci qualche file di configurazione da qualche parte dove c'è scritto "solo tu mariofiore puoi loggarti e caricare il sistema operativo"?
L'immagine del kernel la carica e arriva al desktop di login...e proprio da questo punto in poi che sembra ci sia una "selezione"...

Caro francater mi dispiace assillarti...se ti sto stressando non farti problemi mandami pure a quel paese e io risolverò tutto con un'installazione da locale...è nella mia indole risolvere i problemi senza desistere!

fammi sapere se sei disposto a continuare...senza impegno!

Grazie ancora
Samuele
Cita messaggio
#47
Non preoccuparti, rimango con te Exclamation

Facciamo una prova su /etc/hosts

Inserisci esplicitamente le macchine PIV... i due utenti con lo stesso ID esistono ancora? Se si eliminali.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#48
(07-02-2012, 17:37 )francater Ha scritto: Non preoccuparti, rimango con te Exclamation

Facciamo una prova su /etc/hosts

Inserisci esplicitamente le macchine PIV... i due utenti con lo stesso ID esistono ancora? Se si eliminali.

Grazie per la disponibilità al "martirio"...RolleyesRolleyesRolleyes

Allora una domanda prima...
Se inserisco i PIV in hosts devo associarli ad un IP statico ma il dhcp assegna uno dinamico...dovrei fare una configurazione del genere?Huh

http://www.riminilug.it/tiki-index.php?p...zione_Rete

...modificando a che dhcpd.conf?
Cita messaggio
#49
Si, esattamente così.
Sono soltanto delle prove che non comportano grandi modifiche ai file di configurazione (salvatene sempre una copia prima), ma che ci servono per cercare di restringere le cause del problema.Huh
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)