SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Digikam e anteprima foto
#21
(12-12-2012, 21:41 )Imer Ha scritto: Non capisco , digikam riconosce la macchina e la trovo anche in elenco su quelle supportate quindi non dovrebbe aver nessun problema.
...
CIao IMer

Sicuramente tu sai riconoscere un giapponese se lo vedi, ma non vuol dire che tu ci sappia anche parlare. Per la macchina fotografica è grosso mod la stessa cosa.

gphoto2 è un programma che ti permette di "dialogare" con la macchina fotografica, nei limiti che la macchina consente.

il linguaggio da usare non è poi molto difficile.
A titolo di esempio ti allego uno script che avevo fatto per scaricare e cancellare le foto, visto che fino a qualche tempo fa la mia camera nemmeno veniva riconosciuta in automatico...

Codice:
#!/bin/sh
clear
echo
echo "********************************************"
echo "********** SCARICAMENTO FOTO ***************"
echo "********************************************"
echo
cd /home/ale/fototmp
gphoto2 -Pf /store_00010001/DCIM/102CANON
echo
echo -n “ VUOI CANCELLARE LE FOTO DALLA FOTOCAMERA?[s/n] “
echo
read sure
if [[ $sure = "s" ]]
then
echo “* Rimuovo LE FOTO...“
sudo gphoto2 -DR
echo
echo “* Rimozione foto effettuata“
echo
else echo “* Rimozione foto non eseguita.“
echo
fi
echo “* PROGRAMMA TERMINATO.“
sleep 2
a dieci anni il mondo è fantasia, a vent'anni possibilità, a trenta speranza. A quaranta è riflessione, a cinquanta... vi saprò dire.
Cita messaggio
#22
Allora prima di tutto grazie , poi ho un nuovo aggiornamento , non avevo capito che il problema non era digikam , ma la libreria di gphoto2 a cui si appoggia , cambiando i parametri di ricerca sono arrivato a questo link:

http://askubuntu.com/questions/143433/ho...-importing

Il programma è diverso , ma credo che il problema sia identico , ora io ho scaricato la libreria dall'ultima voce che trovo in fondo alla discussione
https://launchpad.net/ubuntu/+source/lib...2/2.4.11-3

ma adesso non mi è chiaro che cosa devo fare , se devo fare il solito ./configure , make e make install o devo fare altro , chi mi puo' aiutare ?

Ciao IMer
Cita messaggio
#23
Allora, la faccenda non è semplicissima: a quanto pare è un bug della libreria libgphoto2.
Da quello che scrivono qui, per correggerlo devi installare la patch, e per fare ciò ci sono due modi:

1) dal link che hai segnalato tu ti scarichi il pacchetto .deb corrispondente alla tua architettura (i386 o AmD64) e lo installi con GDebi o con synaptic

2) ti scarichi i sorgenti di libgphoto2 e le installi con il solito ./configure > make > make install

La cosa però che non mi convince è che quelle librerie mi sembrano parecchio vecchie: non so quanto ubuntu sia aggiornato, ma su Arch si usano le 2.4.14-1 o addirittura ci sono le beta delle 2.5.0-1, mentre nell'articolo che hai trovato si parla delle 2.2.4.
hai controllato che librerie usa la tua versione di Ubuntu? Mi pare impossibile che utilizzi ancora le 2.2.4...

P.S. per controllare apri un terminale, spostati in /lib o /lib64 a seconda del tuo SO e lancia il comando:
find libgphoto2 | grep canon
a dieci anni il mondo è fantasia, a vent'anni possibilità, a trenta speranza. A quaranta è riflessione, a cinquanta... vi saprò dire.
Cita messaggio
#24
Ciao ,
il comando ha reso questo:

imer@imer-AOD255:/usr/lib/i386-linux-gnu$ find libgphoto2 | grep canon
libgphoto2/2.4.14/canon.so
libgphoto2/2.4.14/canon.a

però come vedi la libreria è stata trovata non nella dir da te indicata.
Il fatto che funzionava con la versione 10.04 poteva essere semplicemente perchè c'era la versione vecchia della libreria ? , non c'è modo di disinstallare questa versione e forzare l'installazione della vecchia libreria ? o conviene applicare la path

Ciao IMer
Cita messaggio
#25
La patch era per una versione precedente. Ho i miei dubbi che funzioni anche per la 2.4.14 (che tra l'altro dovrebbe essere già patchata,in quanto successiva). Il fatto che la cartella sia leggermente diversa invece potrebbe dipendere dal fatto che io uso arch e tu ubuntu.

Su google non trovo nulla circa questo bug, più recente di un anno fa... magari il tuo problema non deriva da libgphoto2.
a dieci anni il mondo è fantasia, a vent'anni possibilità, a trenta speranza. A quaranta è riflessione, a cinquanta... vi saprò dire.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)