Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Accesso rapido a NAS
#1
Buongiorno a tutti.
In UBUNTU 14.04 tramite "esplora rete" dal menù di file si può accedere alla NAS, che nel mio caso è della WD. Il tutto è molto lento ed io in sincerità non ho mai provato ad accedervi tramite l'opzione "connetti al server", in quanto non saprei come fare.
Per caso leggendo questo articolo sula NAS ho trovato un modo estremamente veloce. Per chi non volesse perdere tempo metto i comandi essenziali dell'articolo:
Codice:
First, I changed directory to my home directory and created a nfs directory in there:
$ cd $HOME
$ mkdir nfs

Then I applied the following three shell commands:
$ sudo apt-get install nfs-common
$ showmount -e
$ sudo mount -o soft,intr,rsize=8192,wsize=8192 192.168.1.xxx:/nfs /home//nfs/

Ho seguito la procedura, ma giunto al  showmount -e  mi appare il seguente messaggio "clnt_create: RPC: Program not registered"

Se io ignoro il messaggio e eseguo tutta la procedura, mi si apre un segnalibri con nfs e cliccando su questo quasi istantaneamente mi si apre tutta la NAS, ma al riavvio scompare il tutto e dovrei ricominciare da capo. Inoltre io nel commando, oltra a sostituire le xxx con 007 inserisco mato tra le 2 // (la directory dove ho la home con nfs )

Consigli?
Grazie a tutti.
Disperato Ubuntu 14.04, PRIMA non per amore ma per tigna, ma dopo 16.04 solo amore Heart
Cita messaggio
Grazie da:
#2
Probabilmente devi editare il file /etc/exports (trovi degli esempi all'interno del file stesso). Vedi se QUESTA guida può esserti utile
Linux User # 207701 - L'intelligenza non è non commettere errori, ma scoprire subito il modo di trarne profitto.
Cita messaggio
Grazie da: s.moretti , s.moretti
#3
La procedura si è inceppata quando il terminale mi ha dato s

Codice:
* Not starting NFS kernel daemon: no exports.
 Sono andato in giro e la cosa si è ingigantita per le mie possibilità.
Ci rinuncio e grazie
Disperato Ubuntu 14.04, PRIMA non per amore ma per tigna, ma dopo 16.04 solo amore Heart
Cita messaggio
Grazie da:
#4
Ciao,
io per montare senza troppi problemi , carico il NAS SYNOLOGY con uno script contenente:

sudo mount -t cifs "//192.168.1.100/NOMECARTELLAdelNAS" -o user=admin,pass=AAAAA,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/TUONOMEUTENTELINUX/NAS/NOMECARTELLA"

192.168.1.100 è l'IP FISSO del NAS

DEVI prima creare logicamente la cartella, dove vuoi, nel tuo linux... per esempio in
/home/TUONOMEUTENTELINUX/NAS/NOMECARTELLA che vuoi montare... io ne ho create 5 per avere montato tutte lecartelle...
Cita messaggio
Grazie da:
#5
Scusami, stavo fuori e sono tornato solo oggi.
Per non sbagliare  io ho in 192.168.007 WDMYCLOUD dove vi sono tre cartelle:
la prima è Topogigio (esempio)
la seconda è Public
la terza è Smartware
il mio nome linus e le mie directories sono , partendo da computer, home/mato/home , questa ultima home contiene tutte le immagini, musiche ed altro. 

Quindi io dovrei dare questo commando dal terminale a prescindere che la mia nas sta su 007

sudo mount -t cifs "//192.168.1.100/Topogigio" -o user=topogigio,pass=XXXXXX,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/mato/NAS/Topogigio"
e ripetere il tutto cambiando il nome della cartellaall'inizio e poi in fondo al commando in Public e poi Smartware.
Ultimo dilemma: che commando devo usare per montare una cartella?
Grazie di tutto
Disperato Ubuntu 14.04, PRIMA non per amore ma per tigna, ma dopo 16.04 solo amore Heart
Cita messaggio
Grazie da:
#6
Ci ero riuscito, ma non mi ero accorto che era una sblive senza persistenza.
Quando ho ripetuto gli stessi passi sul sistema installato con il commando
sudo mount -t cifs "//192.168.1.007[ PRIMA con il 100 non funzionava, mentre andava bene con il oo7]/Public" -o user=XXXX,pass=XXXXXXX=#],uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/mnt/public"
m i da come errore
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Disperato Ubuntu 14.04, PRIMA non per amore ma per tigna, ma dopo 16.04 solo amore Heart
Cita messaggio
Grazie da:
#7
Io uso MINT MATE 17.3 che sarebbe praticamente ubuntu 14.04 con la stringa che ti ho riportato.

Il problema puo essere che DEVI ABILITARE l'utente e password sul NAS...
Io ho creato diversi utenti, quello come amministratore ed utente "ospite" ognuno con due nomi utenti e password e privilegi diversi impostati sul NAS in modo che posso accedere solo per leggere o anche per scrivere e modificare tutti i files sul NAS.
Ti riporto il mio bash completo:

Codice:
#!/bin/bash

clear
echo -e "\033[1;37m************************************************
        MENU PRINCIPALE OPZIONI ed UTILITY  
************************************************ $(tput sgr0)"
echo "$(tput setab 2)- CARTELLE di RETE NAS - - - - - - $(tput sgr0)"
echo "  0 x SMONTA tutte cartelle di rete ed ESCE"
echo "  2 x Monta tutte cartelle NAS in SCRITTURA!"
echo "  3 x Monta SCAMBIO in scrittura"
echo " "
echo -e "\033[1;37m Pemi INVIO x Uscire oppure immetti la tua scelta! $(tput sgr0)"
read scegli

# 0 smonta cartelle
if [ "$scegli" == "0" ]; then
sudo umount -a -t cifs;

# 2 Monta tutte cartelle NAS in scrittura
elif [ "$scegli" == "2" ]; then
sudo mount -t cifs "//192.168.1.100/SCAMBIO" -o user=admin,pass=XXXX,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/linux/NAS/SCAMBIO"
sudo mount -t cifs "//192.168.1.100/FOTOGRAFIE" -o user=admin,pass=XXXX,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/linux/NAS/FOTOGRAFIE"
sudo mount -t cifs "//192.168.1.100/Archivio" -o user=admin,pass=XXXX,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/linux/NAS/ARCHIVIO"
sudo mount -t cifs "//192.168.1.100/MUSICA" -o user=admin,pass=XXXX,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/linux/NAS/MUSICA"
~/Scrivania/START.sh;

# 3 Monta SCAMBIO in scrittura e resto in LETTURA
elif [ "$scegli" == "3" ]; then
sudo mount -t cifs "//192.168.1.100/SCAMBIO" -o user=admin,pass=XXXX,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 "/home/linux/NAS/SCAMBIO"
sudo mount -t cifs "//192.168.1.100/FOTOGRAFIE" -o user=ospite,pass=ospite "/home/linux/NAS/FOTOGRAFIE"
sudo mount -t cifs "//192.168.1.100/Archivio" -o user=ospite,pass=ospite "/home/linux/NAS/ARCHIVIO"
sudo mount -t cifs "//192.168.1.100/MUSICA" -o user=ospite,pass=ospite "/home/linux/NAS/MUSICA"
~/Scrivania/START.sh;

elif [ "$scegli" == "" ]; then exit
fi

exit
Cita messaggio
Grazie da:
#8
Grazie per la risposta, ma non so come utilizzare o montare il bash.
Tuttavia ti vorrei segnalare che su un altro pc, sempre con UBUNTU 14.04 plus remix, le tue istruzioni sono andate tutte a buon fine e posso accedere a tutte le cartelle molto velocemente, ma.... perdo le cartelle NAS quando chiudo
Disperato Ubuntu 14.04, PRIMA non per amore ma per tigna, ma dopo 16.04 solo amore Heart
Cita messaggio
Grazie da:
#9
Cyberbob, ti ringrazio molto perchè con le tue indicazioni ho risolto. Ti segnsalo solo che ho dovuto usare \\192.168.1.7 in quanto io l'ho ipostato fisso.
Fatto uno script in sh, messo sulla scrivania, lo lancio ad ogni apertura se serve.
Grazie di nuovo.
Disperato Ubuntu 14.04, PRIMA non per amore ma per tigna, ma dopo 16.04 solo amore Heart
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)