Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Avanzamento versione Ubuntu server da 13.10 a 14.04
#1
Salve a tutti, e da tempo che mi riprometto di aggiornare e finalmente e venuto il giorno, solo che mi da alcuni errori es:

Se tento di installare un pacchetto
Codice:
pi@pi:~$ sudo apt-get install socat
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto socat
pi@pi:~$

se voglio aggiornare normalmente:

Codice:
pi@pi:~$ sudo apt-get update
Err http://old-releases.ubuntu.com saucy InRelease

Err http://old-releases.ubuntu.com saucy-security InRelease

Err http://old-releases.ubuntu.com saucy-updates InRelease

Err http://old-releases.ubuntu.com saucy-proposed InRelease

Err http://old-releases.ubuntu.com saucy Release.gpg
 Impossibile risolvere "old-releases.ubuntu.com"
Err http://old-releases.ubuntu.com saucy-security Release.gpg
 Impossibile risolvere "old-releases.ubuntu.com"
Err http://old-releases.ubuntu.com saucy-updates Release.gpg
 Impossibile risolvere "old-releases.ubuntu.com"
Err http://old-releases.ubuntu.com saucy-proposed Release.gpg
 Impossibile risolvere "old-releases.ubuntu.com"
Lettura elenco dei pacchetti... Fatto
W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy/InRelease

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy-security/InRelease

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy-updates/InRelease

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy-proposed/InRelease

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy/Release.gpg  Impossibile risolvere "old-releases.ubuntu.com"

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy-security/Release.gpg  Impossibile risolvere "old-releases.ubuntu.com"

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy-updates/Release.gpg  Impossibile risolvere "old-releases.ubuntu.com"

W: Impossibile recuperare http://old-releases.ubuntu.com/ubuntu/dists/saucy-proposed/Release.gpg  Impossibile risolvere "old-releases.ubuntu.com"

W: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.
pi@pi:~$

E di conseguenza non posso avanzare di versione
Questi i repo (ho seguito queste istruzioni :http://wiki.ubuntu-it.org/Repository/SourcesList/EOL)
Codice:
deb http://old-releases.ubuntu.com/ubuntu/ saucy main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ saucy main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ saucy-security main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ saucy-security main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ saucy-updates main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ saucy-updates main universe restricted multiverse


##proposed

deb http://old-releases.ubuntu.com/ubuntu/ saucy-proposed main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ saucy-proposed main restricted universe multiverse

Voglio evitare un formattone che mi porterebbe via un mare di tempo.

Grazie in anticipio a tutti per l'aiuto e la pazienza At
Cita messaggio
Grazie da:
#2
Citazione:Avanzamento via rete da 13.10 a 14.04 LTS per sistemi server Ubuntu (raccomandato)
Installare il pacchetto update-manager-core, se non è già installato, con il seguente comando:
sudo apt-get install update-manager-core
Modificare con i privilegi di amministrazione la seguente riga nel file /etc/update-manager/release-upgrades:
Prompt=lts
sostituendo la dicitura lts, o qualsiasi altro valore trovato, in normal. Per esempio:
Prompt=normal
Avviare lo strumento di avanzamento con il seguente comando:
do-release-upgrade
Seguire le istruzioni a schermo.
fonte: wiky
Cita messaggio
Grazie da:
#3
Grazie Dxgiusti per la risposta
provando ad installare update-manager-core mi da:
Codice:
pi@pi:~$ sudo apt-get install update-manager-core
[sudo] password for pi:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
update-manager-core è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
pi@pi:~$ sudo update-manager-core
sudo: update-manager-core: comando non trovato

Se avvio il comando do-release-upgrade mi da:
Codice:
pi@pi:~$ sudo do-release-upgrade
[sudo] password for pi:
Checking for a new Ubuntu release
No new release found
pi@pi:~$

credo che il problema sia nelle repository ma non riesco a risolvere
Cita messaggio
Grazie da:
#4
hai modificato il file come spiegato ( salva prima di chiudere )
Cita messaggio
Grazie da:
#5
Si da normal a lts

Codice:
# Default behavior for the release upgrader.

[DEFAULT]
# Default prompting behavior, valid options:
#
#  never  - Never check for a new release.
#  normal - Check to see if a new release is available.  If more than one new
#           release is found, the release upgrader will attempt to upgrade to
#           the release that immediately succeeds the currently-running
#           release.
#  lts    - Check to see if a new LTS release is available.  The upgrader
#           will attempt to upgrade to the first LTS release available after
#           the currently-running one.  Note that this option should not be
#           used if the currently-running release is not itself an LTS
#           release, since in that case the upgrader won't be able to
#           determine if a newer release is available.
Prompt=lts
Cita messaggio
Grazie da:
#6
il wiky dice:

Prompt=normal

poi avviare con:

do-release-upgrade
Cita messaggio
Grazie da:
#7
Stessa cosa con normal e con lts
Cita messaggio
Grazie da:
#8
non saprei più cosa dirti. se credi che i repo eol siano in qualche modo responsabili, rinomina la tua sources.list tipo original_sources.list in modo da averla sempre disponibile, quindi ricreane una "pulita":
https://gist.github.com/syst3mw0rm/8163897/download#
Cita messaggio
Grazie da:
#9
boh, potresti provare a mettere in sources.list i repo di trusty e poi dare un
Codice:
sudo apt-get dist-upgrade
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#10
Nulla da fare da sempre 0 installati, 0 aggionati, 0 non aggiornato, 0 da non rimuovere, anche cambiando i repo.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)