Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Come si blocca il Kernel?
#1
Ciao,

Su Ubuntu 14.04 Mate ho provato  a bloccare i pacchetti del kernel cioè i due linux headers più i due linux-image alla versione 3.16.0.33

   

ma il gestore pacchetti mi vuole installare per forza la versione 3.16.0.53.

   

Siccome ho appena reinstallato, e se passo da all'ultima versione viene fuori un errore riguardo un sensore che rileva la temperature dell'   hardware.
Marilù
Cita messaggio
Grazie da:
#2
Vedi che te lo chiede? Puoi decidere tu cosa installare/aggiornare.
Freedom isn't free-La libertà non è gratuita.
Per cercare su questo forum: site:istitutomajorana.it/forum2/ [termini della ricerca]
oppure http://www.istitutomajorana.it/informati...lo-forum-2
Cita messaggio
Grazie da:
#3
Non riesco a deselezionare i 4 pacchetti del kernel, clicco su deseleziona ma non si può.
Marilù
Cita messaggio
Grazie da:
#4
boh, dovrebbe bloccarli, prova anche questi, chiudi synaptic e gestore aggiornamenti

Codice:
echo 'linux-image-3.16.0-33-generic hold' | sudo dpkg --set-selections


Codice:
echo 'linux-image-extra-3.16.0-33-generic hold' | sudo dpkg --set-selections


Codice:
echo 'linux-headers-3.16.0-33 hold' | sudo dpkg --set-selections


Codice:
echo 'linux-headers-3.16.0-33-generic hold' | sudo dpkg --set-selections
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: Marilù
#5
(11-11-2015,12:59 )Marilù Ha scritto: Non riesco a deselezionare i 4 pacchetti del kernel, clicco su deseleziona ma non si può.

È vero non si può deselezionarli, avevo provato a bloccare in synaptic, ma quando si aggiorna installa e attiva cmq quello ultimo,per adesso dopo che si è installato l'ultimo ripristino quello che voglio usare e tenere, non ho ancora provato i comandi di tuxino, ma forse  Undecided  agiscono via terminale come per interfaccia grafica con synaptic.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#6
Si ho riavviato ma non permette di deselezionare.
Marilù
Cita messaggio
Grazie da:
#7
credo che se blocchi il pacchetto lui ti installa in synaptic quelli nuovi ma dovresti utilizzare quelli vecchi ( invece di blocca non si attiva sui vecchi la riga "forza versione".
Cita messaggio
Grazie da:
#8
sinceramente non ho capito cosa vuoi dire , per usare il kernel vecchio posso farlo con grub custmizer.

Però non mi sembra normale che bisogna per forza aggiornare il kernel
Marilù
Cita messaggio
Grazie da:
#9
ubuntu aggiorna il kernel che hai, non una nuova versione. se hai 3.16.xxxxxx aggiornerà se ne hai bisogno quello, non passerai mai ad una diversa versione. sempre 3.16.xxxxxx sarà.
Cita messaggio
Grazie da: Marilù
#10
Si, però capita, raramente, che anche stando nella medesima versione l'aggiornamento non funzioni qualcosa,come il precedente, mi sembra Undecided il caso di marilù.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da: Marilù


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)