Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Compilazione Gimp 2.9
#1
Salve a tutti, sto usando, con soddisfazione, Pclos Xfce a64 bit. Come da titolo non riesco a compilare Gimp, quando arrivo qui mi restituisce questo:
cd ../gegl
[giuseppe@localhost gegl (master)]$ ./autogen.sh --prefix=$PREFIX && make && make install
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
configure.ac:557: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:557: the top level
configure.ac:557: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:557: the top level
autoreconf: configure.ac: tracing
configure.ac:557: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:557: the top level
autoreconf: running: libtoolize --copy --force
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
configure.ac:557: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:557: the top level
configure.ac:557: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:557: the top level
autoreconf: running: /usr/bin/autoconf --force
configure.ac:557: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:557: the top level
configure:18168: error: possibly undefined macro: AM_NLS
     If this token and others are legitimate, please use m4_pattern_allow.
     See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
checking whether make supports nested variables... yes
configure: error: cannot find install-sh, install.sh, or shtool in "." "./.." "./../.."
Qualcuno può aiutarmi??
Cita messaggio
Grazie da:
#2
ciao aquila. non ti posso aiutare, le mie capacità sono molto limitate. ti segnalo un post:
http://www.pclinuxos.com/forum/index.php...093.0.html
come puoi vedere loro sono fortemente contrari ad installare fuori dai repo ( poi ognuno è libero di fare quello che meglio crede, ci mancherebbe altro )
Cita messaggio
Grazie da:
#3
Quoto.

Sembra proprio che il problema sia interno al tar, insomma che non trovanndo l'install dove se lo aspetta, tutto si blocchi.
Se anche tu trovassi l'install che cerca, sapresti dove metterlo perché lo trovi anche lui?
Sei partito da un .tar.gz generico, giusto?
C'è l'install? Potresti provare a metterlo da qualche parte e sperare che lo trovi.

Se non c'è, (e avendo molta voglia di smanettare) potresti provare a installarlo su un'altro sistema tipo fedora o debian, cercare di capire se anche lì dà lo stesso errore e se no tentare il recupero di install da copiare in pclos assumendo che i path per le installazioni siano diversi (il che ho notato che è vero ma solo fino a un certo punto).
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png]

. . . . . Posto il posto, posto : . . . Libera Informatica in Libero Stato !!!
Cita messaggio
Grazie da:
#4
Sono partito da qui :
$ mkdir gimp-test && cd gimp-test
$ git clone git://git.gnome.org/babl
$ git clone git://git.gnome.org/gegl
$ git clone git://git.gnome.org/gimp.
La stranezza è che su Sabayon funziona perfettamente solo che, per adesso, ho tolto questa distro.
Cita messaggio
Grazie da:
#5
Infatti sabayon e pclinux partono da radici abbastanza lontane.

Di git ne so praticamente nulla (installi da utente?), sorry.
Comunque resta il fatto che sarebbe meglio rimanere all'interno dei repo 'di casa'.
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png]

. . . . . Posto il posto, posto : . . . Libera Informatica in Libero Stato !!!
Cita messaggio
Grazie da:
#6
In teoria dovrebbe compilarsi su qualsiasi distro GNU/Linux. Si la compilazione è da utente e non root.
Cita messaggio
Grazie da:
#7
https://sparewotw.wordpress.com/2012/03/...4-2012-02/

La procedura rimane tuttora invaariata indipendentemente dal de in uso, leggersi comunque con cura le note in rosso . Il gioco non vale la candela , anche perchè Gimp 2.9 è previsto entro il primo semestre di quest' anno e la pazienza rimane la virtù principale dei forti. Alla resa dei conti finale poi Gimp-2.9 non aggiunge al momento nulla di nuovo e purtroppo gran parte dei filtri e plugin disponibili con la versione corrente , resta tagliata fuori per conflitto di versione.
Cita messaggio
Grazie da:
#8
Beh, qualcosa di nuovo c'è, il supporto da 16 bit in su anche in gamma lineare che, per uno che converte in B&W, è il massimo.
Ciao. E muchas gracias.
Cita messaggio
Grazie da:
#9
il supporto da 16 bit in su è presente anche nella versione corrente , basta installarla completa di tutti i plugins e filtri di supporto disponibili , che sono una marea. Se ti accontenti di un apt-get install gimp no di sicuro. Gimp è già da circa due anni che può supportare anche filtri photoshop al quale ha ormai ben poco da invidiare.
Cita messaggio
Grazie da:
#10
Che Gimp  2.8 accetti i plugin di Photoshop questo lo so, che abbia il supporto a 16 bit per canale mi giunge nuova.
Evidentemente io come altri, che stiamo aspettando la versione 2.10, non ce ne siamo accorti. Ti sarei grato se mi volessi indicare quali plugin devo installare, dato che non mi accontento di un "apt-get install".
Ciao.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)