Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Configurazione Chiave wifi Asus AC51
#1
Salve,
Ho acquistato la chiavetta wifi dual band Asus ac51, per connettermi ad internet utilizzando il secondo canale (5 Ghz) del mio router.
Purtroppo il mio Ubuntu 15.10 non la riconosce automaticamente e, andando a controllare nel cd in dotazione, vi è anche la procedura d'installazione per i driver Linux. Purtroppo io non so come utilizzarla, potreste gentilmente spiegarmela? La inserisco in allegato.

Anticipatamente grazie.....


Allegati
.txt   Quick Start DPO.txt (Dimensione: 2,1 KB / Download: 7)
Cita messaggio
Grazie da:
#2
non ho molta esperienza in questo tipo di procedura, visto che nessun altro si è fatto avanti provo a darti una mano io.
innanzi tutto dovresti avere sul cd un file mt7610u_wifi_sta_vxxxx_dpo_xxxxxxxx.tar.bz2 dove le xxxxx stanno per la versione del driver e dovresti copiare il file sulla tua /home ed estrai l'archivio (è come uno .zip su windows) così da avere una cartella mt7610u_wifi_sta_vxxxx_dpo_xxxxxxxx
poi devi aprire il terminale e digitare:
sudo apt-get update
sudo apt-get install build-essential
adesso da terminale entriamo nella cartella che hai creato:
cd mt7610u_wifi_sta_vxxxx_dpo_xxxxxxxx
e dai il comando:
makefile
se ti chiede di impostare delle variabili dovrebbero essere queste: MODE = STA e TARGET = LINUX
poi dovresti entrare nel file config.mk presente nella cartella /os/linux:
cd /os/linux
gedit config.mk
e correggere questi parametri da n (no) a y (yes):
# Support wpa_supplicant
HAS_WPA_SUPPLICANT = y
# Support for Native WpaSupplicant Network Maganger
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT = y
salva e chiudi; adesso torniamo nella cartella mt7610u_wifi_sta_vxxxx_dpo_xxxxxxxx:
cd ..
cd ..
controlla che effettivamente sei nella cartella giusta (prima del $ ti dovrebbe comparire il percorso completo) e dai i comandi:
make
sudo make install

adesso dovresti riavviare e dovrebbe funzionare. Per favore
se in un qualsiasi passaggio ti risponde con un errore, è inutile che prosegui, fermati e posta l'errore (per copiare sul terminale seleziona il testo col mouse e usa la combinazione di tasti ctrl+shift+c).
spero di non averti scritto stupidaggini... Idea sbagliata
ciao Smile
Scusate il ritardo...  Angel
Grazie a chi dice Grazie  At
Usate l'errore come chiave di ricerca su Google
Cita messaggio
Grazie da:
#3
Ciao, scusa il ritardo ma, non mi era stato segnalato che vi era una risposta nella discussione.

Detto questo, ho eseguito tutti i passaggi fino al makefile dove, il terminale riporta degli errori che ti posto sotto.

/home/marco/driver/Linux/os/linux/../../sta/sta_cfg.c:5401:85: error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time]
intf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, _
                                                                    ^
/home/marco/driver/Linux/os/linux/../../sta/sta_cfg.c:5401:95: error: macro "__TIME__" might prevent reproducible builds [-Werror=date-time]
, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, __TIME__ );
                                                                    ^
cc1: some warnings being treated as errors
scripts/Makefile.build:258: set di istruzioni per l'obiettivo "/home/marco/driver/Linux/os/linux/../../sta/sta_cfg.o" non riuscito
make[2]: *** [/home/marco/driver/Linux/os/linux/../../sta/sta_cfg.o] Errore 1
Makefile:1398: set di istruzioni per l'obiettivo "_module_/home/marco/driver/Linux/os/linux" non riuscito
make[1]: *** [_module_/home/marco/driver/Linux/os/linux] Errore 2
make[1]: uscita dalla directory "/usr/src/linux-headers-4.2.0-23-generic"
Makefile:393: set di istruzioni per l'obiettivo "LINUX" non riuscito
make: *** [LINUX] Errore 2

Spero tu ci capisca qualcosa.
Intanto grazie......
Cita messaggio
Grazie da:
#4
come ti ho scritto ho conoscenze scarse dell'argomento; ipotizzo che il tuo driver sia "vecchio" rispetto al kernel utilizzato e quindi in autotutela il sistema impedisce la modifica del kernel con dei moduli vecchi per evitare che il kernel vada in blocco (edit: non è sicuro, ma essendo un modulo vecchio potrebbe capitare).
si può risolvere? sì, così: https://askubuntu.com/questions/593566/h...ucible-bui
come si fa? purtroppo non lo so  Idea
speriamo che qualche altro membro più esperto di me in materia intervenga.
ciao
Scusate il ritardo...  Angel
Grazie a chi dice Grazie  At
Usate l'errore come chiave di ricerca su Google
Cita messaggio
Grazie da:
#5
Molto gentile lo stesso Tongue
Ora provo con il link che mi hai postato, poi speriamo in qualche altro che abbia voglia di aiutarmi.....

Grazie lo stesso At
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)