SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 1 voto(i) - 5 media
  • 1
  • 2
  • 3
  • 4
  • 5
Cookis e Privacy - Adeguamento la Guida Completa
#11
Prova ad usare il codice uno che trovi nel file di testo: LEGGIMI

Se funziona poi aggiungi quanto manca.

define('EUCOOKIELAW_DISALLOWED_DOMAINS', '.doubleclick.net; .google.com; .sofotex.com; .google.it; html5shim.googlecode.com; http://www.google-analytics.com; .googleapis.com; http://www.youtube-nocookie.com; youtu.be; .youtube.com; .vimeo.com; http://www.pinterest.com; .googlesyndication.com');

Guarda bene dove inserire il codice. La riga che hai postato, con quei tag [php] non va bene. Nella guida hai l'immagine di dove e come inserire il codice.
Cita messaggio
Grazie da: bump
#12
Grazie mille, ci sono riuscita, ho aggiunto tutti i vari domini e ora appena entro sul sito ho solo i 3 cookies di Mybb ([lastactive], [lastvisit], sid)..grazie mille
Cita messaggio
Grazie da:
#13
Di nulla.
Cita messaggio
Grazie da:
#14
Buonasera,
ho riscontrato un altro problema nell'installazione del codice lato client su sito joomla.
Ho seguito le istruzioni indicate su: http://www.istitutomajorana.it/index.php...&Itemid=33

Disabilitando javascript non mi appare però alcun banner. Come mai?

Di seguito inserisco il dodice del file index.php presente nella root del mio sito dopo la modifica:


.txt   log.txt (Dimensione: 2,41 KB / Download: 1)


Ringrazio anticipatamente.
Cita messaggio
Grazie da:
#15
Hai cancellato i cookie per provare?

Se hai già accettato i cookie per un anno non ti comparirà il banner.

Se invece hai cancellato i cookie prima della prova allora ti indico come inserire meglio il codice, ossia più in alto:

<?php
/**
* @package Joomla.Site
*
* @copyright Copyright © 2005 - 2015 Open Source Matters, Inc. All rights reserved.
* @license GNU General Public License version 2 or later; see LICENSE.txt
*/
/**
* Define the application's minimum supported PHP version as a constant so it can be referenced within the application.
*/

----> IN QUESTA POSIZIONE  <-----

define('JOOMLA_MINIMUM_PHP', '5.3.10');

if (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<'))
{
die('Your host needs to use PHP ' . JOOMLA_MINIMUM_PHP . ' or higher to run this version of Joomla!');
}
Cita messaggio
Grazie da:
#16
I cookie sono stati cancellati.
Ho provato a modificare la posizione dello script così come mi ha indicato, ma continua a non funzionare.

Faccio presente che utilizzo un template particolare, nel quale non è presente la riga con <head> e pertanto ho dovuto inserire il codice lato client all'interno di un banner.
Cita messaggio
Grazie da:
#17
Quel codice va inserito solo lato Server, ossia nel file index.php della cartella principale (root).

Se hai un template particolare, allora il codice lato client lo inserisci in un modulo:

http://www.istitutomajorana.it/index.php...&Itemid=33

guarda:

- m - ATTENZIONE se non trovate la riga con <head> significa ....
Cita messaggio
Grazie da:
#18
Probabilmente non mi sono spiegato bene.
Io ho interpretato la guida nel seguente modo:

a) il codice per il lato server  va inserito sempre e comunque nel file index.php della root

b) il codice lato client va inserito di norma nel file index.php della cartella del template utilizzato. Se però si usa un template particolare il CODICE JAVASCRIPT per il lato client va inserito in un modulo.

Pertanto:

- ho inserito il codice php per il"lato server" nell'index.php della root
- ho inserito il codice javascript per il lato client in un banner.

Ho interpretato bene la guida?
Cita messaggio
Grazie da:
#19
Aggiornamento: credo di aver individuato la causa del problema anche se non ne conosco la soluzione.
Nella home page del sito è infatti presente un modulo per i contatti (precisamente si tratta dell'estensione "coalaweb form"). Se disattivo tale modulo il banner mi compare regolarmente.
Cita messaggio
Grazie da:
#20
Prova a cambiare posizione al modulo banner, vi sono alcune posizioni in cui non funziona ed altre in cui funziona.

Probabilmente i due moduli (nelle posizioni in cui si trovano), vanno in conflitto.

L'interpretazione della guida, che tu hai fatto, è corretta.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: