Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Decifrare le formule di Calc
#1
Qualcuno può aiutarmi come posso imparare a comprendere le formule più complesse, per esempio:
=SE(O(H11="";H11="R";H11="A";H11="VP";H11="CO";H11="RR";H11="CS";H11="PL";H11="RC";H11="PL");0;SE(I11-H11-0,25<0;0,25-(I11-H11);0))

=SE(O(VAL.TESTO(H11)=1;VAL.TESTO(I11)=1;H11="";H11="R";H11="A";H11="VP";H11="CO";H11="RR";H11="CS";H11="PL";H11="RC";H11="PL");0;SE(I11-H11-0,25<0;0;I11-H11-0,25))

Nel foglio in cui lavoro ho anche altre formule così complesse. Volevo capire se ce la faccio a capire come leggere la loro sintassi. Sarebbe importante controllare se c'é qualche errore.
Ciao
Cita messaggio
Grazie da:
#2
Si tratta di una funzione SE con una funziona O e un'altro SE annidato.
Diciamo che la "traduzione" è: SE è vero che si verifica una delle condizioni della funzione O il risultato è 0; se è falso, SE l'operazione I11-H11-0,25<0,  è vera fai 0,25-(I11-H11), altrimenti il valore è 0.
mandi...Eugenio
Cita messaggio
Grazie da:
#3
Potrebbe tornare utile usare la "Creazione guidata funzione", che, nel pannello "Struttura" mostra, sotto forma di albero, come sono nidificate le funzioni. In questo modo diventano anche più visibili eventuali errori.
Si tratta del pulsantino con "fx" e una stellina disegnata sopra, a fianco della barra di digitazione.
"Saper gestire le informazioni è più importante che saperle trovare."

http://www.LibreSoftwareclub.it
Cita messaggio
Grazie da:
#4
Qual è la traduzioni di queste:
=SE(E(I11<>0;$V$7="F");1;0)

=SE(O(H11="";VAL.TESTO(H11)=1);0;SOMMA(SE(E(AC11>(1/47);AC11<=(1,5/24));1;SE(AC11>(1,5/24);2;0)))+SE(AD11>(5,5/24);6;SE(AD11>(4,5/24);5;SE(AD11>(3,5/24);4;SE(AD11>(2,5/24);3;SE(AD11>(1,5/24);2;SE(AD11>(0,5/24);1;0)))))))

=SE(I11>=(H11+(6/24));(H11+(6/24))-(22/24);SE(I11<(H11+(6/24));I11-(22/24);0))

   

@GreyBear61:
in questa funzione da dove si capisce se eventualmente ci fosse un errore?
Ciao
Cita messaggio
Grazie da:
#5
(14-01-2018,15:04 )eu66 Ha scritto: Si tratta di una funzione SE con una funziona O e un'altro SE annidato.
Diciamo che la "traduzione" è: SE è vero che si verifica una delle condizioni della funzione O il risultato è 0; se è falso, SE l'operazione I11-H11-0,25<0,  è vera fai 0,25-(I11-H11), altrimenti il valore è 0.

Questa traduzione vale solo per la prima formula?
Perché si mettono le funzione SE, O, E. Non basterebbe mettere solo la funzione SE (vero o falso)?
VAL.TESTO a che serve?
Ciao
Cita messaggio
Grazie da:
#6
Le funzioni E e O si usano rispettivamente quando nella funzione SE si devono inserire più condizioni che devono essere rispettate tutte per E o almeno una con O.
La funzione VAL.TESTO serve per capire se il contenuto della cella è un testo, in questo caso la risposta è VERO (o 1), altrimenti (se è un numero) la risposta è FALSO (o 0)
La seconda formula è simile alla prima cioè se una delle condizioni della funzione O è vera metti 0. Poi c'è l'altro se che dice che se il risultato dell'operazione è minore di 0 metti lo 0 altrimenti fai la formula indicata.
mandi...Eugenio
Cita messaggio
Grazie da:
#7
L'errore lo capisci tu perchè non ti da il risultato che ti aspetti, quindi, in base a questo, modifichi di conseguenza la formula.
(non è che Calc ti segnala in che punto della formula hai un errore, non è mica un indovino: Calc o comunque il pc, sono dei somari: eseguono un mucchio di operazioni anche complicatissime in base a ciò che tu gli dici di fare, giusto o sbagliato che sia).
Per trovare un errore devi separare le formule che sono contenute in tutto il formulone e così potrai capire pezzo per pezzo dove sta l'errore: ricorda che in un foglio di calcolo valgono le stesse regole della matematica delle medie riguardo le precedenze e le condizioni di vero/falso.

@Perché si mettono le funzione SE, O, E. Non basterebbe mettere solo la funzione SE (vero o falso)?
con la E vuol dire che se tutte le condizioni sono vere allora fai qualcosa, altrimenti altro;
con la O vuol dire che basta una condizione vera per fare qualcosa, altrimenti altro.
(uguale identico alla matematica).

@VAL.TESTO che funzione è, a che serve?
scrive vero o falso se nella cella specificata trova un testo o no.

@=SE(E(I11<>0;$V$7="F");1;0)
Se i11 (cioè il suo contenuto) è diverso da zero e in v7 c'è F, scrivi 1, altrimenti 0

@=SE(O(H11="";VAL.TESTO(H11)=1);0;SOMMA(SE(E(AC11>(1/47);AC11<=(1,5/24));1;SE(AC11>(1,5/24);2;0)))+SE(AD11>(5,5/24);6;SE(AD11>(4,5/24);5;SE(AD11>(3,5/24);4;SE(AD11>(2,5/24);3;SE(AD11>(1,5/24);2;SE(AD11>(0,5/24);1;0)))))))
Se la h11 è vuota oppure c'è un testo, allora scrive zero, altrimenti se AC11>(1/47);AC11<=(1,5/24)) somma 1 più tutti i successivi SE (se si verifica la rispettiva condizione)

@=SE(I11>=(H11+(6/24));(H11+(6/24))-(22/24);SE(I11<(H11+(6/24));I11-(22/24);0))
Se i11 è maggiore o uguale a h11+6/24, allora fai (H11+(6/24))-(22/24), altrimenti se i11 è minore di H11+6/24, allora fa  I11-(22/24), altrimenti zero

Come ti ha detto GreyBear61 è più facile vedere le condizioni di test, di vero e di falso: cliccaci sopra che si evidenzia la parte che stai esaminando, soprattutto in questo caso che la formula è lunghetta.
Cita messaggio
Grazie da:
#8
Il punto è che per creare queste formule ci vuole un buon bagaglio di conoscenze e bisogna essere bravi in matematica. Io credo che non ci riuscirò mai.
Ma bisogna non arrendersi.
Ciao
Cita messaggio
Grazie da:
#9
Le formule che hai scritto sono sì un pò lunghe, ma in realtà non sono difficili: non serve sapere alla perfezione come funziona Calc, ti basterebbe una minima conoscenza delle formule che usi più spesso, cioè il SE, SOMMA, SOMMA.SE, E, O, MAX, MIN. Una volta note queste o altre che non ti ho elencato ma che usi sempre, vedrai che poi con l'esperienza riuscirai a capire come funzionano e a che cosa servono anche le altre.
Essere bravi in matematica aiuta, ma a questo livello è sufficiente che ti ricordi come funzionano le parentesi, gli operatori aritmetici (+ - * / ^) e le precedenze tra di essi.

Quindi:
se ti danno un file in cui inserire i dati, ma non ottieni il risultato corretto, fai presente la cosa con chi ha scritto le formule;
se invece le formule le inserisci tu, allora ti do un consiglio per cominciare (che vale anche nel precedente caso se devi ricontrollare qualcosa): non partire subito in quinta a scrivere formule lunghe e annidate, fai un pezzo per volta e poi con l'esperienza potrai unire direttamente questi pezzi; fatti uno schema su un foglio di carta, cioè utilizza prima carta e penna, su cui scrivi quello che vuoi fare, come lo diresti a voce e non con la sintassi di Calc; quando hai in mente cosa fare allora traduci quello che hai scritto o pensato nel linguaggio di Calc: fai inoltre due conti a mano per vedere se poi leggendo il risultato che ti da Calc è quello che ti aspetti.
Cita messaggio
Grazie da:
#10
Mi hanno dato un file, modificato da una seconda persona, in più l'ho trasferito da Execel in Calc , quindi la mia preoccupazione è se ci fosse qualche errore. Per questo volevo studiare queste formule.
Ovviamente per controllare manualmente tutti i risultati delle formule ci vorrebbero due giorni.
Andrebbe bene se controllo manualmente tutti risultati della prima riga e poi trascino tutte le formule nelle righe sottostante. È un'idea.
Ciao
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)