Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Disc. divisa] driver stampante Brother MFC-L2700DW
#1
Enzinux, ti invidio: a te se non altro la stampante funziona. A me nemmeno quella!
Hai voglia di darmi delle istruzioni molto basiche, a prova di idiota, per fan funzionare almeno la stampante sotto Ubuntu 16.04?
La cosa ironica è che Ubuntu la dà per installata: però non stampa niente.
Cita messaggio
Grazie da:
#2
(12-08-2016,08:37 )dxgiusti Ha scritto: in questi giorni pclos ha rilasciato un kernel nuovo. prova dopo aver aggiornato il sistema ad installarlo. un tentativo ma chissà.......

Grazie dxgiusti. Ma dimenticavo di dire che non ho pclos: ho Ubuntu 16.04 a 64 bit.
Forse in Canonical hanno tolto i driver da questa release, che invece potrebbe esserci ancora nel vecchio Ubuntu 14.04: ma ho una scheda madre di ultima generazione, e quando tento di installare Ubuntu 14.04 il sistema va subito in crash.
Grazie in ogni caso.
Se qualcuno ha altri suggerimenti si faccia avanti!
Cita messaggio
Grazie da:
#3
Sad 
In effetti, alla pagina Support.Brother.com, la Brother mette i file da scaricare e da installare per far funzionare la stampante.  Sono io che non sono capace di installarli.
Cita messaggio
Grazie da:
#4
divido discussione.
Cita messaggio
Grazie da:
#5
Se sono pacchetti .deb mettili in una cartella dove non ci sono altri file.deb, click dx in uno punto vuoto e clicca su Apri un terminale qui e copia incolla questa riga

Codice:
sudo dpkg -i *.deb

dai invio, la password (che non vedrai ma che viene presa) e di nuovo invio.
Comunque se vuoi maggior aiuto sarebbe utile che mettessi il modello della stampante, così si può vedere se è supportata.


Allegati Anteprime
   
Cita messaggio
Grazie da: medjmax
#6
prova a seguire qui, brother mette a disposizione uno script che fa tutto lui

http://wiki.ubuntu-it.org/Hardware/Stamp...DriverTool


per la tua ecco lo script e una volta scaricato segui il wiki

http://support.brother.com/g/b/downloadh...&type3=625
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: medjmax
#7
(13-08-2016,10:59 )eu66 Ha scritto: Se sono pacchetti .deb mettili in una cartella dove non ci sono altri file.deb, click dx in uno punto vuoto e clicca su Apri un terminale qui e copia incolla questa riga

Codice:
sudo dpkg -i *.deb

dai invio, la password (che non vedrai ma che viene presa) e di nuovo invio.
Comunque se vuoi maggior aiuto sarebbe utile che mettessi il modello della stampante, così si può vedere se è supportata.



Grazie, eu66. La multifunzione è una Brother MFC-L2700DW. Ora cerco di superare la mia imperizia con il terminale e provo a fare quello che mi suggerisci.
Cita messaggio
Grazie da:
#8
(13-08-2016,11:14 )tuxino Ha scritto: prova a seguire qui, brother mette a disposizione uno script che fa tutto lui

http://wiki.ubuntu-it.org/Hardware/Stamp...DriverTool


per la tua ecco lo script e una volta scaricato segui il wiki

http://support.brother.com/g/b/downloadh...&type3=625

Grazie Tuxino. Ho provato a scaricare lo "script che fa tutto lui", ossia il linux-brprinter-installer-2.0.0-1, ma non riesco ad eseguirlo nel terminale.  Ovviamente prima seleziono  Modifica>Preferenze>Comportamento>Chiedere ogni volta, e poi seleziono File>Proprietà>Permessi>Consentire l'esecuzione del file come programma: clicco sullo script, compare la scritta "ESEGUI NEL TERMINALE", ma quando clicco sulla scritta non succede niente, lo script non parte e la scritta si chiude subito.
Cita messaggio
Grazie da:
#9
le istruzioni, dicono di estrarlo, tu lo hai estratto? se si, l'hai estratto in /home/Scaricati?


se l'hai estratto in /home/Scaricati, portati nella directory da terminale
Codice:
cd Scaricati
e poi dai il comando per lanciarlo
Codice:
sudo bash linux-brprinter-installer-2.0.0-1

e poi segui il wiki
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#10
Sì,l'ho estratto in Scaricati, ma non mi ero messo nella directory Scaricati!
Adesso mi ci sono messo, ed ecco cosa viene fuori da terminale. Non ho però capito cosa si intensa per URI del dispositivo (device URI), perciò ho risposto NO:

max@ubu1604:~$ cd Scaricati
max@ubu1604:~/Scaricati$ sudo bash linux-brprinter-installer-2.0.0-1
[sudo] password di max:
Input model name -> MFC-L2700DW

You are going to install following packages.
mfcl2700dwlpr-3.2.0-1.i386.deb
mfcl2700dwcupswrapper-3.2.0-1.i386.deb
brscan4-0.4.3-3.amd64.deb
brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Trovato:1 http://it.archive.ubuntu.com/ubuntu xenial InRelease
Scaricamento di:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [94,5 kB]
Trovato:3 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease
Trovato:4 http://archive.canonical.com/ubuntu xenial InRelease
Trovato:5 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease
Ign:6 http://dl.google.com/linux/chrome/deb stable InRelease
Trovato:7 http://dl.google.com/linux/chrome/deb stable Release
Recuperati 94,5 kB in 4s (22,6 kB/s)
Lettura elenco dei pacchetti... Fatto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Il pacchetto ia32-libs non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente
Tuttavia questi pacchetti lo sostituiscono:
lib32ncurses5 lib32z1

E: Il pacchetto "ia32-libs" non ha candidati da installare
dpkg -x mfcl2700dwlpr-3.2.0-1.i386.deb /
dpkg -x mfcl2700dwcupswrapper-3.2.0-1.i386.deb /
(Lettura del database... 245895 file e directory attualmente installati.)
Rimozione di mfcl2700dwcupswrapper:i386 (3.2.0-1)...
lpadmin: Non esiste la stampante o la classe.
Eliminazione dei file di configurazione di mfcl2700dwcupswrapper:i386 (3.2.0-1)...
dpkg-deb: generazione del pacchetto "mfcl2700dwlpr" in "mfcl2700dwlpr-3.2.0-1a.i386.deb".
dpkg -b ./brother_driver_packdir mfcl2700dwlpr-3.2.0-1a.i386.deb
dpkg-deb: generazione del pacchetto "mfcl2700dwcupswrapper" in "mfcl2700dwcupswrapper-3.2.0-1a.i386.deb".
dpkg -b ./brother_driver_packdir mfcl2700dwcupswrapper-3.2.0-1a.i386.deb
dpkg -i --force-all mfcl2700dwlpr-3.2.0-1a.i386.deb
(Lettura del database... 245891 file e directory attualmente installati.)
Preparativi per estrarre mfcl2700dwlpr-3.2.0-1a.i386.deb...
Estrazione di mfcl2700dwlpr:i386 (3.2.0-1) su (3.2.0-1)...
Configurazione di mfcl2700dwlpr:i386 (3.2.0-1)...
dpkg -i --force-all mfcl2700dwcupswrapper-3.2.0-1a.i386.deb
Selezionato il pacchetto mfcl2700dwcupswrapper:i386 non precedentemente selezionato.
(Lettura del database... 245891 file e directory attualmente installati.)
Preparativi per estrarre mfcl2700dwcupswrapper-3.2.0-1a.i386.deb...
Estrazione di mfcl2700dwcupswrapper:i386 (3.2.0-1)...
Configurazione di mfcl2700dwcupswrapper:i386 (3.2.0-1)...
lpadmin -p MFCL2700DW -E -v usb://Brother/MFC-L2700DW%20series?serial=E73944D6N405484 -P /usr/share/ppd/brother/brother-MFCL2700DW-cups-en.ppd
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->y

wait 5s.
lpr -P MFCL2700DW /usr/share/cups/data/testprint
You are going to install following packages.
brscan4-0.4.3-3.amd64.deb
dpkg -i --force-all brscan4-0.4.3-3.amd64.deb
(Lettura del database... 245896 file e directory attualmente installati.)
Preparativi per estrarre brscan4-0.4.3-3.amd64.deb...
Estrazione di brscan4 (0.4.3-3) su (0.4.3-3)...
Configurazione di brscan4 (0.4.3-3)...
This software is based in part on the work of the Independent JPEG Group.
You are going to install following packages.
brscan-skey-0.2.4-1.amd64.deb
dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
(Lettura del database... 245896 file e directory attualmente installati.)
Preparativi per estrarre brscan-skey-0.2.4-1.amd64.deb...
Estrazione di brscan-skey (0.2.4-1) su (0.2.4-1)...
Configurazione di brscan-skey (0.2.4-1)...
Hit Enter/Return key.
max@ubu1604:~/Scaricati$

Andando su Impostazioni di sistema>stampanti la stampante risulta regolarmente installata. Ma continua a non stampare.
Su un altro disco ho installato Linux Mint 18 (Sara): diversamente da Ubuntu, Mint se la installa subito da solo. Ma non stampa nemmeno con Mint. Il cavo USB è regolarmente attaccato.
Cita messaggio
Grazie da:


Vai al forum: