Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Errore: Broken count > 0 Ubuntu 15.10
#1
Ciao, premetto che sono un assoluto neofita di ubuntu e sono tutt'altro che un esperto informatico. Dopo mesi che Windows 8 mi dava vari problemi, mi sono deciso a provare Linux ed ho scaricato Ubuntu 15.10 (per il momento, però, continuo a mantenere anche Windows su computer).
Per un paio di giorni è andato tutto bene, anche grazie agli aiuti/suggerimenti che ho trovato in rete, poi ho deciso di installare OpenOffice (usandolo anche al lavoro mi trovo più a mio agio che LibreOffice). Mi dava un messaggio di errore e, sempre cercando delle soluzioni su internet, ho letto che è preferibile disinstallare LibreOffice perché può creare conflitti con OpenOffice. Così ho fatto, ed in effetti dopo mi ha installato regolarmente OpenOffice. Dopo, però, ogni volta che provo ad installare qualche altro programma dall'Ubuntu Software Center mi dice che "il pacchetto e danneggiato" e non me lo consente.
In alto a dx dello schermo trovo un messaggio di errore che dice: Si è verificato un errore. Per ulteriori informazioni sull'errore avviare il gestore pacchetti tramite il menù richiamabile con un clic del tasto destro del mouse, oppure dare il comando apt-get da terminale. Il messaggio di errore è: "Errore: Broken count > 0". Di solito questo significa che i pacchetti installati presentano delle dipendenze irrisolte. Ho provato ad aprire il terminale e digitare apt-get, ma mi mostra solo delle istruzioni e il significato del comando.
Insomma non ho idea di cosa fare...avete suggerimenti?
Grazie mille.
Cita messaggio
Grazie da:
#2
Dai questi comandi uno alla volta nel terminale e posta qui l'output che ti da ognuno di loro,inserendo i listati tra i tag codice.
Codice:
sudo apt-get update
Codice:
sudo apt-get upgrade
Codice:
sudo apt-get install -f
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#3
Ho dato i comandi consigliati, questo è quello che mi risponde il sistema.

Codice:
stefano@stefano-System-Product-Name:~$ sudo apt- get update
[sudo] password di stefano:
sudo: apt-: comando non trovato
stefano@stefano-System-Product-Name:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
libreoffice-core : Dipende: libreoffice-common (> 1:5.0.5~rc2) ma non è installato
libreoffice-java-common : Dipende: libreoffice-common ma non è installato
libreoffice-l10n-it : Dipende: libreoffice-common ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.
stefano@stefano-System-Product-Name:~$ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
 kde-l10n-it
Usare "apt-get autoremove" per rimuoverlo.
I seguenti pacchetti saranno inoltre installati:
 libreoffice-common
Pacchetti suggeriti:
 libreoffice-style-breeze libreoffice-style-crystal
 libreoffice-style-hicontrast libreoffice-style-oxygen libreoffice-style-sifr
 libreoffice-style-tango
I seguenti pacchetti NUOVI saranno installati:
 libreoffice-common
0 aggiornati, 1 installati, 0 da rimuovere e 43 non aggiornati.
22 non completamente installati o rimossi.
È necessario scaricare 0 B/22,4 MB di archivi.
Dopo quest'operazione, verranno occupati 84,5 MB di spazio su disco.
Continuare? [S/n]
Cita messaggio
Grazie da:
#4
scusa avevo sbagliato  gli spazi del primo comando, rifai da capo tutti i tre comandi ed accosenti, il primo comando è:
sudo apt-get update
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#5
...fatto. Questa volta è venuta fuori più roba...


Codice:
stefano@stefano-System-Product-Name:~$ sudo apt-get update
[sudo] password di stefano:
Trovato http://it.archive.ubuntu.com wily InRelease
Scaricamento di:1 http://it.archive.ubuntu.com wily-updates InRelease [65,9 kB]
Scaricamento di:2 http://security.ubuntu.com wily-security InRelease [65,9 kB]
Trovato http://it.archive.ubuntu.com wily-backports InRelease                  
Trovato http://it.archive.ubuntu.com wily/main Sources                        
Trovato http://it.archive.ubuntu.com wily/restricted Sources                
Trovato http://it.archive.ubuntu.com wily/universe Sources                  
Trovato http://it.archive.ubuntu.com wily/multiverse Sources          
Trovato http://it.archive.ubuntu.com wily/main amd64 Packages
Scaricamento di:3 http://security.ubuntu.com wily-security/main Sources [37,2 kB]
Trovato http://it.archive.ubuntu.com wily/restricted amd64 Packages          
Trovato http://it.archive.ubuntu.com wily/universe amd64 Packages              
Trovato http://it.archive.ubuntu.com wily/multiverse amd64 Packages    
Scaricamento di:4 http://security.ubuntu.com wily-security/restricted Sources [2.854 B]
Trovato http://it.archive.ubuntu.com wily/main i386 Packages                  
Trovato http://it.archive.ubuntu.com wily/restricted i386 Packages      
Scaricamento di:5 http://security.ubuntu.com wily-security/universe Sources [7.420 B]
Trovato http://it.archive.ubuntu.com wily/universe i386 Packages              
Trovato http://it.archive.ubuntu.com wily/multiverse i386 Packages        
Scaricamento di:6 http://security.ubuntu.com wily-security/multiverse Sources [2.772 B]
Trovato http://it.archive.ubuntu.com wily/main Translation-it                  
Trovato http://it.archive.ubuntu.com wily/main Translation-en                  
Trovato http://it.archive.ubuntu.com wily/multiverse Translation-it      
Scaricamento di:7 http://security.ubuntu.com wily-security/main amd64 Packages [122 kB]
Trovato http://it.archive.ubuntu.com wily/multiverse Translation-en            
Trovato http://it.archive.ubuntu.com wily/restricted Translation-it            
Trovato http://it.archive.ubuntu.com wily/restricted Translation-en            
Trovato http://it.archive.ubuntu.com wily/universe Translation-it              
Trovato http://it.archive.ubuntu.com wily/universe Translation-en        
Scaricamento di:8 http://security.ubuntu.com wily-security/restricted amd64 Packages [10,9 kB]
Scaricamento di:9 http://it.archive.ubuntu.com wily-updates/main Sources [57,5 kB]
Scaricamento di:10 http://security.ubuntu.com wily-security/universe amd64 Packages [43,2 kB]
Scaricamento di:11 http://it.archive.ubuntu.com wily-updates/restricted Sources [3.741 B]
Scaricamento di:12 http://it.archive.ubuntu.com wily-updates/universe Sources [14,5 kB]
Scaricamento di:13 http://security.ubuntu.com wily-security/multiverse amd64 Packages [6.249 B]
Scaricamento di:14 http://it.archive.ubuntu.com wily-updates/multiverse Sources [2.772 B]
Scaricamento di:15 http://it.archive.ubuntu.com wily-updates/main amd64 Packages [167 kB]
Scaricamento di:16 http://security.ubuntu.com wily-security/main i386 Packages [120 kB]
Scaricamento di:17 http://it.archive.ubuntu.com wily-updates/restricted amd64 Packages [13,3 kB]
Scaricamento di:18 http://security.ubuntu.com wily-security/restricted i386 Packages [10,8 kB]
Scaricamento di:19 http://it.archive.ubuntu.com wily-updates/universe amd64 Packages [67,0 kB]
Scaricamento di:20 http://security.ubuntu.com wily-security/universe i386 Packages [43,3 kB]
Scaricamento di:21 http://it.archive.ubuntu.com wily-updates/multiverse amd64 Packages [6.249 B]
Scaricamento di:22 http://security.ubuntu.com wily-security/multiverse i386 Packages [6.434 B]
Scaricamento di:23 http://it.archive.ubuntu.com wily-updates/main i386 Packages [163 kB]
Trovato http://security.ubuntu.com wily-security/main Translation-en          
Trovato http://security.ubuntu.com wily-security/multiverse Translation-en    
Scaricamento di:24 http://it.archive.ubuntu.com wily-updates/restricted i386 Packages [13,4 kB]
Scaricamento di:25 http://it.archive.ubuntu.com wily-updates/universe i386 Packages [64,2 kB]
Trovato http://security.ubuntu.com wily-security/restricted Translation-en
Scaricamento di:26 http://it.archive.ubuntu.com wily-updates/multiverse i386 Packages [6.434 B]
Trovato http://security.ubuntu.com wily-security/universe Translation-en      
Scaricamento di:27 http://it.archive.ubuntu.com wily-updates/main Translation-en [77,1 kB]
Scaricamento di:28 http://it.archive.ubuntu.com wily-updates/multiverse Translation-en [2.806 B]
Scaricamento di:29 http://it.archive.ubuntu.com wily-updates/restricted Translation-en [3.024 B]
Scaricamento di:30 http://it.archive.ubuntu.com wily-updates/universe Translation-en [43,0 kB]
Trovato http://it.archive.ubuntu.com wily-backports/main Sources
Trovato http://it.archive.ubuntu.com wily-backports/restricted Sources
Trovato http://it.archive.ubuntu.com wily-backports/universe Sources
Trovato http://it.archive.ubuntu.com wily-backports/multiverse Sources
Trovato http://it.archive.ubuntu.com wily-backports/main amd64 Packages
Trovato http://it.archive.ubuntu.com wily-backports/restricted amd64 Packages
Trovato http://it.archive.ubuntu.com wily-backports/universe amd64 Packages
Trovato http://it.archive.ubuntu.com wily-backports/multiverse amd64 Packages
Trovato http://it.archive.ubuntu.com wily-backports/main i386 Packages
Trovato http://it.archive.ubuntu.com wily-backports/restricted i386 Packages
Trovato http://it.archive.ubuntu.com wily-backports/universe i386 Packages
Trovato http://it.archive.ubuntu.com wily-backports/multiverse i386 Packages
Trovato http://it.archive.ubuntu.com wily-backports/main Translation-en
Trovato http://it.archive.ubuntu.com wily-backports/multiverse Translation-en
Trovato http://it.archive.ubuntu.com wily-backports/restricted Translation-en
Trovato http://it.archive.ubuntu.com wily-backports/universe Translation-en
Recuperati 1.251 kB in 5s (210 kB/s)
Lettura elenco dei pacchetti... Fatto
stefano@stefano-System-Product-Name:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
libreoffice-core : Dipende: libreoffice-common (> 1:5.0.5~rc2) ma non è installato
libreoffice-java-common : Dipende: libreoffice-common ma non è installato
libreoffice-l10n-it : Dipende: libreoffice-common ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.
stefano@stefano-System-Product-Name:~$ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
 kde-l10n-it
Usare "apt-get autoremove" per rimuoverlo.
I seguenti pacchetti saranno inoltre installati:
 libreoffice-common
Pacchetti suggeriti:
 libreoffice-style-breeze libreoffice-style-crystal
 libreoffice-style-hicontrast libreoffice-style-oxygen libreoffice-style-sifr
 libreoffice-style-tango
I seguenti pacchetti NUOVI saranno installati:
 libreoffice-common
0 aggiornati, 1 installati, 0 da rimuovere e 48 non aggiornati.
22 non completamente installati o rimossi.
È necessario scaricare 0 B/22,4 MB di archivi.
Dopo quest'operazione, verranno occupati 84,5 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 255202 file e directory attualmente installati.)
Preparativi per estrarre .../libreoffice-common_1%3a5.0.5~rc2-0ubuntu2_all.deb...
Estrazione di libreoffice-common (1:5.0.5~rc2-0ubuntu2)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libreoffice-common_1%3a5.0.5~rc2-0ubuntu2_all.deb (--unpack):
tentata sovrascrittura di "/usr/bin/soffice" presente anche nel pacchetto openoffice-debian-menus 4.1.2-9782
rmdir: rimozione di "/var/lib/libreoffice/share/prereg/" non riuscita: File o directory non esistente
rmdir: rimozione di "/var/lib/libreoffice/share/" non riuscita: File o directory non esistente
rmdir: rimozione di "/var/lib/libreoffice/program/" non riuscita: File o directory non esistente
rmdir: rimozione di "/var/lib/libreoffice" non riuscita: File o directory non esistente
rmdir: rimozione di "/var/lib/libreoffice" non riuscita: File o directory non esistente
Elaborazione dei trigger per gnome-menus (3.13.3-6ubuntu1)...
Elaborazione dei trigger per desktop-file-utils (0.22-1ubuntu3)...
Elaborazione dei trigger per bamfdaemon (0.5.2~bzr0+15.10.20150627.1-0ubuntu1)...
Rebuilding /usr/share/applications/bamf-2.index...
Elaborazione dei trigger per mime-support (3.58ubuntu1)...
Elaborazione dei trigger per shared-mime-info (1.3-1)...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Cita messaggio
Grazie da:
#6
ora dai
sudo dpkg --force-all -i /var/cache/apt/archives/libreoffice-common_1%3a5.0.5~rc2-0ubuntu2_all.deb
e poi
sudo apt-get install -f

quindi posta la risposta
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#7
Ecco il risultato...

P.S.: grazie mille per l'aiuto che mi stai dando!


Codice:
stefano@stefano-System-Product-Name:~$ sudo dpkg --force-all -i /var/cache/apt/archives/libreoffice-common_1%3a5.0.5~rc2-0ubuntu2_all.deb
[sudo] password di stefano:
(Lettura del database... 255202 file e directory attualmente installati.)
Preparativi per estrarre .../libreoffice-common_1%3a5.0.5~rc2-0ubuntu2_all.deb...
Estrazione di libreoffice-common (1:5.0.5~rc2-0ubuntu2)...
dpkg: attenzione: viene ignorato il problema poiché è usata l'opzione --force:
dpkg: attenzione: tentata sovrascrittura di "/usr/bin/soffice" presente anche nel pacchetto openoffice-debian-menus 4.1.2-9782
Configurazione di libreoffice-common (1:5.0.5~rc2-0ubuntu2)...

Il file di configurazione "/etc/bash_completion.d/libreoffice.sh" non esiste nel sistema.
Viene installato il nuovo file come richiesto.

Il file di configurazione "/etc/libreoffice/psprint.conf" non esiste nel sistema.
Viene installato il nuovo file come richiesto.

Il file di configurazione "/etc/libreoffice/soffice.sh" non esiste nel sistema.
Viene installato il nuovo file come richiesto.

Il file di configurazione "/etc/libreoffice/sofficerc" non esiste nel sistema.
Viene installato il nuovo file come richiesto.
Elaborazione dei trigger per gnome-menus (3.13.3-6ubuntu1)...
Elaborazione dei trigger per desktop-file-utils (0.22-1ubuntu3)...
Elaborazione dei trigger per bamfdaemon (0.5.2~bzr0+15.10.20150627.1-0ubuntu1)...
Rebuilding /usr/share/applications/bamf-2.index...
Elaborazione dei trigger per mime-support (3.58ubuntu1)...
Elaborazione dei trigger per shared-mime-info (1.3-1)...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
sudo apt-get install -f
Elaborazione dei trigger per man-db (2.7.4-1)...
Elaborazione dei trigger per hicolor-icon-theme (0.15-0ubuntu1)...
stefano@stefano-System-Product-Name:~$ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
 kde-l10n-it
Usare "apt-get autoremove" per rimuoverlo.
0 aggiornati, 0 installati, 0 da rimuovere e 48 non aggiornati.
22 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Configurazione di libreoffice-core (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-pdfimport (1:5.0.2-0ubuntu1)...
Configurazione di libreoffice-base-drivers (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-base-core (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-base (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-calc (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-draw (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-impress (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-math (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-report-builder-bin (1:5.0.2-0ubuntu1)...
Configurazione di libreoffice-writer (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-avmedia-backend-gstreamer (1:5.0.2-0ubuntu1)...
Configurazione di libreoffice-java-common (1:5.0.5~rc2-0ubuntu2)...
Configurazione di python3-uno (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-gtk (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-gnome (1:5.0.5~rc2-0ubuntu2)...
Configurazione di libreoffice-l10n-it (1:5.0.2-0ubuntu1)...
Configurazione di libreoffice-help-it (1:5.0.2-0ubuntu1)...
Configurazione di libreoffice-sdbc-firebird (1:5.0.2-0ubuntu1)...
Configurazione di libreoffice-sdbc-hsqldb (1:5.0.2-0ubuntu1)...
Configurazione di mythes-it (2.0.7.gh.deb1-4.1)...
stefano@stefano-System-Product-Name:~$
Cita messaggio
Grazie da:
#8
Ora sembra a posto,prova a lanciare writer, per vedere.

p.S.è tardi sono fuso, intendevo dire che adesso non dovrebbe più darti errori negli installamenti.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#9
....siiiii!!!! Ora scarica senza problemi!  [Immagine: http://www.istitutomajorana.it/forum2/im...gif/at.gif]
Non so veramente come ringraziarti, e non solo per la soluzione al mio problema.
E' fantastico vedere che esiste un mondo dove ci sono persone che stanno sveglie fino alle 2 di notte per aiutarti gratuitamente...credo proprio che una delle prossime scelte che farò sarà quella di eliminare completamente windows dal mio computer.
Spero anche in futuro di trovare il tempo per leggere/studiare il (molto) materiale disponibile in rete per poter approfondire Linux e magari rendermi più autonomo nella risoluzione dei problemi (...ovviamente ho seguito pedissequamente le tue istruzioni...ma non ho capito niente di quello che ho fatto!)
Grazie ancora e...buonanotte!
Cita messaggio
Grazie da:
#10
comunque libreoffice non mi pare che è rimosso, anzi, dall'ultimo apt-get install -f si vede che l'ha configurato
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)