Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
HD Sata rimosso rallenta l'avvio.
#1
Buongiorno. Ho un pc con installato Ubuntu 14.04 con due dischi ssd per i sistemi di Ubuntu e Windows 7. Ho anche due dischi dati meccanici, e volendone sostituire uno, mi sono accorto che staccandolo, il computer impiegava più tempo ad avviarsi, lo stesso sostituendolo, invece rimettendo il vecchio disco tornava ad essere veloce. Non è che il ritardo sia molto, ma è seccante che per sostituire un disco si rallenti l'avvio.
Un'idea per risolvere, per favore.
Cita messaggio
Grazie da:
#2
quando parli di avvio lento ti riferisci a win oppure succede lo stesso con Ubuntu ?
a me capita che se stacco il masterizzatore win 8 non si avvia.
Cita messaggio
Grazie da:
#3
Hai ragione, non avevo specificato. Rallenta soltanto Ubuntu, l'avvio di di Seven rimane lo stesso.
E' come se la mancanza o la sostituzione del disco faccia perdere tempo al sistema.
Nel disco c'era l'area di swap, l'ho spostata ma fa lo stesso, ho provato ad invertire i cavetti, ma fa lo stesso.
Nel disco ci sono soltanto documenti, foto, ecc. e niente files di sistema. Se reinserisco il disco torna a partire velocemente.
Controllando il report dell'avvio di Ubuntu, ho visto che il ritardo si verifica nel momento che va a montare la partizione con il sistema operativo, ma non capisco perchè, non dovrebbe entrarci niente.
Cita messaggio
Grazie da:
#4
se avevi la swap su quello potrebbe essere, la cerca e non la trova........ se hai spostato la swap, devi necessariamente modificare il file fstab altrimenti lui non la vede e cerca sempre la vecchia. se avevi montato in automatico il disco, lui lo cerca e non lo vede. prova a verificare. se sei in difficoltà posta che ti diremo come fare.
Cita messaggio
Grazie da:
#5
Grazie per le risposte.
La swap ho provato sia a spostarla che disattivarla tramite fstab. Si, il disco viene montato in automatico, in fstab non c'è alcun riferimento al disco in questione, ma soltanto a quelli di sistema. Comunque posto fstab.

Codice:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb4 during installation
UUID=7667ab8b-2d5f-46d9-8697-ad1e9fd2cc5a /                ext4 noatime,discard,data=writeback,nobh,errors=remount-ro 0       1

# /boot/efi was on /dev/sda1 during installation
UUID=6EC4-7B4D  /boot/efi       vfat    defaults        0       1

# /home was on /dev/sdb2 during installation
UUID=1c16621d-7b82-4432-a6af-344b0d8414b0 /home           ext4 noatime,discard,data=writeback,nobh,errors=remount-ro 0       2

# swap su ssd:
UUID=4401f305-01fe-4b26-a859-0c10a3eb021a   none            swap    sw              0       0
# swap su hd:
#UUID=434ed742-588d-4216-926b-45c8a78c2a9b none            swap    sw              0       0



# temp e log su RAM
tmpfs /tmp tmpfs nosuid,noatime,mode=1777 0 0
tmpfs /var/log tmpfs defaults,noatime,mode=0755 0 0
tmpfs /var/tmp tmpfs defaults,noatime,mode=1777 0 0
none /var/run tmpfs mode=0755,size=2m,noatime,nosuid 0 0
none /var/lock tmpfs mode=1777,size=2m,noatime,nosuid,nodev,noexec 0 0

le uuid si riferiscono tutti a partizioni dei dischi di sistema, comunque posto il comando blkik, per aiutare a leggerlo:

Codice:
claudio@fisso:~$ sudo blkid
[sudo] password for claudio:
/dev/sda1: UUID="6EC4-7B4D" TYPE="vfat"
/dev/sda3: UUID="66D6C8F3D6C8C491" TYPE="ntfs"
/dev/sdb1: UUID="2071-8FB6" TYPE="vfat"
/dev/sdb2: UUID="1c16621d-7b82-4432-a6af-344b0d8414b0" TYPE="ext4"
/dev/sdb3: UUID="4401f305-01fe-4b26-a859-0c10a3eb021a" TYPE="swap"
/dev/sdb4: UUID="7667ab8b-2d5f-46d9-8697-ad1e9fd2cc5a" TYPE="ext4"
/dev/sdc1: UUID="434ed742-588d-4216-926b-45c8a78c2a9b" TYPE="swap"
/dev/sdc2: LABEL="ext4int" UUID="33ed362d-52d2-463c-a003-855bdbe9d420" TYPE="ext4"
/dev/sdc3: LABEL="HDFAT" UUID="7264276A64272FF1" TYPE="ntfs"
/dev/sdc4: LABEL="ntfsint" UUID="4CD8BF90D8BF7734" TYPE="ntfs"
claudio@fisso:~$
Il disco che da problemi è sdc.
E' un disco di dati che viene montato in automatico. Ma come potrei evitare che il sistema continui a  cercarlo se non c'è?
Cita messaggio
Grazie da:
#6
nel tuo fstab c'è la riga

# swap su hd:
#UUID=434ed742-588d-4216-926b-45c8a78c2a9b none swap sw 0 0

che si riferisce proprio a hdc, quindi la devi togliere, anche se non capisco perché usi la swap anche su ssd, non ci tieni a conservarlo al meglio ?
Cita messaggio
Grazie da:
#7
Nella riga c'è il cancelletto davanti, quindi è come se la riga fosse cancellata. La swap era su quel disco, ora la ho temporaneamente spostata su ssd per i problemi sul disco che dicevo. Appena risolta la cosa, sostituirei il disco, toglierei il canelletto, metterei l'UUID del nuovo disco e disattiverei la swap su ssd.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)