Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
HP scanjet 4600
#1
Lo scanner HP scanjet 4600 non viene riconosciuto da XSane.

http://www.sane-project.org/cgi-bin/driv...s=any&v=&p=

http://www.sane-project.org/unsupported/...-4600.html

In rete ho trovato solo questa discussione
http://www.chmil.org/hp4600linux/

Ho provato a seguire le istruzioni, ma senza riuscire nell'intento. In particolare mi manca "libusb-devel" che non è presente nel pacchetto per Ubuntu 14.04.2

Questo il mio: lsb_release -a && uname -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:core-4.1-ia32:core-4.1-noarchConfusedecurity-4.0-ia32Confusedecurity-4.0-noarchConfusedecurity-4.1-ia32Confusedecurity-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty
Linux HP-PAV-2014 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:01 UTC 2014 i686 i686 i686 GNU/Linux

alla richiesta: dpkg -l libusb
dpkg-query: nessun pacchetto corrispondente a libusb

Qualche suggerimento?
Grazie
Cita messaggio
Grazie da:
#2
sicuramente avrai installato:

Citazione:hplip

primo passo per hp. poi guardando nel gestore pacchetti vedo > libusb-dev < ora non saprei se ti può aiutare.
Cita messaggio
Grazie da:
#3
hplip c'era già
da gestore pacchetti ho installato libusb-dev

precedentemente, non l'ho detto, avevo scaricato il pacchetto "hp4600-master" da compilare, il cui README.md è questo:

HP4600 for Linux
======

Basic HP4600 scanner software for Linux

This software is dumb. I mean it doesn't really have any options and just replays the commands as a sort of blackbox magic incantation to produce a 600dpi color scan from the HP4600 scanner. No calibration, nothing else.

The software consists of two binaries, the USB replay and data capture and an image corrector.

The USB replay is, as I said, dumb.

The image corrector is required because the scanning elements on the scanner head have about a 7 pixel overlap and some offset. The image corrector fixes this. The colors will be slightly off in each bar which will be more or less noticable depending on the image scanned.

Good luck.

###Dependencies:
Compiling the binaries requires _legacy_ libusb-devel (~v0.1.4).
The one-step script uses Perl/Tk.

###Compiling:

```
gcc hp4600-scanfullpage.c -o hp4600scanfullfile -lusb
gcc -o fixhp4600output fixhp4600output.c
```

Ho seguito l'istruzione, pur non avendo libusb-devel e la compilazione è avvenuta nella cartella che avevo posto in Scrivania. Suppongo che il contenuto della cartella "hp4600-master" vada messo altrove. Ma dove?
Cita messaggio
Grazie da:
#4
Con lo scanner collegato e acceso dai il comando:
Codice:
hp-doctor
e vedi quali errorri ti dà.
Cita messaggio
Grazie da:
#5
qui
http://hplipopensource.com/hplip-web/sup...index.html
se selezioni il tuo scanner, dice che hplip non supporta gli scanjet, quindi da quel lato credo che ci sia niente da fare

e anche sane lo dà non supportato
http://www.sane-project.org/sane-mfgs.ht...TT-PACKARD

credo che non riuscirai a usare lo scanner
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#6
(21-05-2015,23:53 )roberto1155 Ha scritto: Con lo scanner collegato e acceso dai il comando:

Codice:
hp-doctor
e vedi quali errorri ti dà.

con hp-doctor, mi dà questi errori:
(tralascio il resto e riporto solo errori in rosso e avvertimenti in viola)


Checking for Deprecated items....
error: This distro (i.e ubuntu 14.04) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y

Checking for HPLIP updates....

error: Failed to locate hp-upgrade utility


Checking for Dependencies....
warning: ubuntu-14.04 version is not supported. Using ubuntu-13.10 versions dependencies to verify and install...


HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro 14.04 version


--------------------------
| External Dependencies |
--------------------------
error: dbus DBus REQUIRED - 1.6.18 MISSING 'DBUS may not be installed or not running'

error: cups CUPS REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'


-------------------------
| General Dependencies |
-------------------------
error: libcrypto OpenSSL-Crypto-Lib REQUIRED - 1.0.1 MISSING 'libcrypto needs to be installed'


error: libjpeg JPEG-Lib REQUIRED - - MISSING 'libjpeg needs to be installed'


error: python-devel Python-SDK REQUIRED 2.2 2.7.6 MISSING 'python-devel needs to be installed'


error: cups-devel CUPS-SDK REQUIRED - - MISSING 'cups-devel needs to be installed'
error: sane-devel SANE-SDK REQUIRED - - MISSING 'sane-devel needs to be installed'
error: libusb USB-Lib REQUIRED - 1.0 MISSING 'libusb needs to be installed'

error: cups-image CUPS-Image-Lib REQUIRED - - MISSING 'cups-image needs to be installed'
error: libnetsnmp-devel SNMP-Networking-SDK REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
------------------------------

| Compile Time Dependencies |
------------------------------
error: libtool Build-tools REQUIRED - - MISSING 'libtool needs to be installed'

----------------------


| Python Extentions |
----------------------
cupsext CUPS-Extension REQUIRED - 3.14.3 OK -
pcardext PhotoCard-Extension REQUIRED - 3.14.3 OK -
hpmudext IO-Extension REQUIRED - 3.14.3 OK -

-----------------------
| Scan Configuration |
-----------------------
hpaio HPLIP-SANE-Backend REQUIRED - 3.14.3 OK 'hpaio found in /etc/sane.d/dll.conf'
scanext Scan-SANE-Extension REQUIRED - 3.14.3 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------
No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------
No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------
Hewlett-Packard-HP-LaserJet-P1006
---------------------------------
Type: Unknown
Device URI: usb://HP/LaserJet%20P1006?serial=AA1648S
PPD: /etc/cups/ppd/Hewlett-Packard-HP-LaserJet-P1006.ppd
PPD Description: HP LaserJet P1006 Foomatic/foo2xqx (recommended)
Printer status: la stampante Hewlett-Packard-HP-LaserJet-P1006 è inattiva. è stata abilitata da mer 13 mag 2015 15:07:55 CEST
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

--------------
| PERMISSION |
--------------

Missing Required Dependencies
-----------------------------
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libcups2' package is missing or 'cups' service is not running.
error: 'openssl' package is missing/incompatible
error: 'libjpeg-dev' package is missing/incompatible
error: 'python-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing or 'cups' service is not running.
error: 'cups-bsd' package is missing or 'cups' service is not running.
error: 'cups-client' package is missing or 'cups' service is not running.
error: 'libsane-dev' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing or 'cups' service is not running.
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'libtool' package is missing/incompatible

ENTER SUDO PASSWORD
-------------------
Please enter the sudoer (sfera)'s password:
Do you want to update repository and Install missing/incompatible packages. (a=install all*, c=custom_install, s=skip):a
Updating repository
-------------------
cmd =sudo dpkg --configure -a
cmd =sudo apt-get install --yes --force-yes -f
cmd =sudo apt-get update
warning: Failed to update Repository, check if any update/installation is running.
Installing Missing/Incompatible packages
----------------------------------------
cmd =sudo apt-get install --assume-yes libcups2-dev
cmd =sudo apt-get install --assume-yes cups-bsd
cmd =sudo apt-get install --assume-yes libjpeg-dev
cmd =sudo apt-get install --assume-yes libsane-dev
cmd =sudo apt-get install --assume-yes libsnmp-dev
cmd =sudo apt-get install --assume-yes libcupsimage2-dev
cmd =sudo apt-get install --assume-yes openssl
cmd =sudo apt-get install --assume-yes libdbus-1-dev
cmd =sudo apt-get install --assume-yes libcups2
cmd =sudo apt-get install --assume-yes cups-client
cmd =sudo apt-get install --assume-yes snmp-mibs-downloader
cmd =sudo apt-get install --assume-yes libtool
cmd =sudo apt-get install --assume-yes python-dev
cmd =sudo apt-get install --assume-yes libusb-1.0.0-dev

Checking Permissions....
Permissions are correct.

Checking for Configured Queues....
warning: Device Hewlett-Packard-HP-LaserJet-P1006 is not HPLIP installed. Device must use the hp: or hpfax: to function in HPLIP.

error: 'Hewlett-Packard-HP-LaserJet-P1006' is not configured using HPLIP. Need to remove and re-cofigure using hp-setup.
Do you want to remove and re-configure? (y=yes*, n=no, q=quit) ? n

Checking for HP Properitery Plugin's....
No plug-in printers are configured.

Diagnose completed...




Come dicevo sopra, ho trovato queste istruzioni
http://www.chmil.org/hp4600linux/

ho scaricato questi script da compilare
https://github.com/Triften/hp4600

ma non so in quale cartella vanno messi
(per prova l'ho fatto in Scrivania, ma so che non è quello il posto giusto)
Cita messaggio
Grazie da:
#7
Fai attenzione che hplip che hai non va bene per la 14.4, dal sito dell'hp devi scaricare i hplip 3.15.4 ed installarlo.
Cita messaggio
Grazie da:
#8
(25-05-2015,12:18 )roberto1155 Ha scritto: Fai attenzione che hplip che hai non va bene per la 14.4, dal sito dell'hp devi scaricare i hplip 3.15.4 ed installarlo.

Ho scaricato hplip-3.15.4.tar.gz,
ho seguito da qui http://hplipopensource.com/hplip-web/ins...buntu.html le istruzioni per installare, ma prima di arrivare in fondo l'installazione mi si ferma con
....

/bin/sed: can't read Linux/hplip-3.15.4/libhpmud.la: No such file or directory
libtool: link: `Linux/hplip-3.15.4/libhpmud.la' is not a valid libtool archive
make: *** [libhpipp.la] Errore 1
....
python: can't open file './installer/fix_symlink.py': [Errno 2] No such file or directory



Al di là della versione più aggiornata di hplip, in Sane Supported Scanners - Search Engine
http://www.sane-project.org/cgi-bin/driv...l=&bus=usb
si dice che ScanJet 4600 è Not supported e si rimanda a
http://www.chmil.org/hp4600linux/
dove è presentata una soluzione alternativa in forma per me piuttosto criptica (ci ho provato senza successo essendo a digiuno di linguaggi di programmazione e da qui la mia richiesta di aiuto)
Cita messaggio
Grazie da:
#9
La cartella hplip-3.15.4 in quale cartella è stata decomprerssa (o dove si trova ora)???
Cita messaggio
Grazie da:
#10
(27-05-2015,11:59 )roberto1155 Ha scritto: La cartella hplip-3.15.4 in quale cartella è stata decomprerssa (o dove si trova ora)???

Molto probabilmente in un posto sbagliato, ma non so dove avrei dovuto farlo...è stata decompressa in una cartella nominata ad hoc sulla scrivania. Dove avrei dovuto farlo?

Suppongo sia lo stesso errore che ho fatto cercando di seguire la procedura indicata in http://www.chmil.org/hp4600linux/
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)