Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Installare stampante Canon Ip1600
#1
Ciao ragazzi,
su ubuntu Lts 16.04 su pc fisso... dovrei collegarci questa stampante: Canon Ip 1600.
Ho provato a seguire questa guida: hhttps://wiki.ubuntu-it.org/Hardware/Sta ... ixmaIP1600
Ma qualcosa come al solito è andato storto:
Codice:
cd ~/
ubix@pc2:~$ tar -xvf 24301.tgz
guideip2200-2.60-1.tar.gz
iP2200_Linux_260.tar.gz
cnijfilter-common-2.60-4.src.rpm
cnijfilter-ip4200-2.60-4.i386.rpm
cnijfilter-ip4200-lprng-2.60-4.i386.rpm
ubix@pc2:~$ mkdir iP2200_Linux_260
ubix@pc2:~$ mv iP2200_Linux_260.tar.gz iP2200_Linux_260
ubix@pc2:~$ cd iP2200_Linux_260
ubix@pc2:~/iP2200_Linux_260$ tar -xzf iP2200_Linux_260.tar.gz
ubix@pc2:~/iP2200_Linux_260$ sudo alien --to-deb --scripts *i386.rpm
[sudo] password di ubix:
Can't exec "gcc": File o directory non esistente at /usr/share/perl5/Dpkg/Arch.pm line 126.
dpkg-architecture: Avviso: cannot determine CC system type, falling back to default (native compilation)
cnijfilter-common-2.60-1.i386.rpm is for architecture i386 ; the package cannot be built on this system
ubix@pc2:~/iP2200_Linux_260$ sudo alien --to-deb --scripts *i386.rpm
Can't exec "gcc": File o directory non esistente at /usr/share/perl5/Dpkg/Arch.pm line 126.
dpkg-architecture: Avviso: cannot determine CC system type, falling back to default (native compilation)
cnijfilter-common-2.60-1.i386.rpm is for architecture i386 ; the package cannot be built on this system
ubix@pc2:~/iP2200_Linux_260$
ubix@pc2:~/iP2200_Linux_260$ sudo alien --to-deb --scripts *i386.rpm
Can't exec "gcc": File o directory non esistente at /usr/share/perl5/Dpkg/Arch.pm line 126.
dpkg-architecture: Avviso: cannot determine CC system type, falling back to default (native compilation)
cnijfilter-common-2.60-1.i386.rpm is for architecture i386 ; the package cannot be built on this system
ubix@pc2:~/iP2200_Linux_260$ sudo dpkg -i *.deb
dpkg: errore nell'elaborare l'archivio *.deb (--install):
impossibile accedere all'archivio: File o directory non esistente
Si sono verificati degli errori nell'elaborazione:
*.deb
ubix@pc2:~/iP2200_Linux_260$
Cita messaggio
Grazie da:
#2
Il collegamento è che hai inserito suppongo sia questo:
https://wiki.ubuntu-it.org/Hardware/Stam...ixmaIP1600

che però è stato dichiarato non aggiornato (nel 2016):
https://forum.ubuntu-it.org/viewtopic.php?f=9&t=613609

difatti un'altro utente si è perso per strada seguendo la guida:
https://forum.ubuntu-it.org/viewtopic.php?f=9&t=618258

Il problema è che se vai nella seconda pagina, in fondo è stato rimosso il supporto a xenial:
http://ppa.launchpad.net/michael-gruz/ca...ntu/dists/

essendo l'ultimo firmato al 2014, probabilmente non funziona a dovere.

## soluzione:
Ti invito invece a seguire questa (link sotto), dove pare un utente con la stessa versione di Ubuntu 16.04 >
http://tipsonubuntu.com/2016/08/14/canon...ntu-16-04/

Ho verificato che in effetti nel PPA di "inameiname" c'è anche xenial, ma non ho potuto seguire la guida non avendo nè una Canon, nè Ubuntu.
Cita messaggio
Grazie da:
#3
Allora ho provato a seguire la guida, scaricato i pacchetti, però quando vado ad installare la nuova stampante, scelgo i drive scaricati della canon e mi appaiono una lista di stampanti da scegliere.

Purtroppo non c'è la Pixma Ip 1600.. ho provato col modello più simile ma non ho avuto successo...
Cita messaggio
Grazie da:
#4
Difatti lo sapevo (IP 1600 non presente), ma come si evince dal commento del 10/04/2017 di usare il file iP1800.
Hai tentato questa strada?

Devi seguire alla lettera tutti i passi, magari alla richiesta di sovrascrivere il file "cnijfilter" dai ok, visto il tentativo andato a vuoto nel #1. Al termine spegni il pc.
Al nuovo avvio prima accendi la stampante collegata al pc, poi il pc medesimo.


Io ho letto che un paio di persone con questo metodo, anche perchè al momento è l'unico, ci sono riuscite.
Alternative per ora non ce ne sono, se non radicali.
a) cambi stampante.
b) emuli XP (o Seven) e installi il suo vetusto driver.
Cita messaggio
Grazie da:
#5
Penso di aver sbagliato io.. ho seguito la guida ed installato i pacchetti come indicato.. poi cosa devo fare? Devo andare in stampanti, penso e crearne una nuova... come ho fatto il dubbio è come faccio a far prendere al sistema i pacchetti che ho salvato come driver validi? Spiegami i passaggi, grazie...
Cita messaggio
Grazie da:
#6
Se hai seguito tutti i punti, inserendo la iP1800 al momento opportuno, dalle tue Impostazioni > Stampanti dovrebbe già essere visualizzabile l'icona della Canon (oppure Canon nomemodello).

Poi apri uno dei qualunque programmi in Grafica, siano Gimp piuttosto che Pinta o gThumb e provi a lanciare una stampa nell'apposito menù a tendina.
(a te essendo la tua stampante limitata alla sola stampa, se non erro, Simple Scan non serve a nulla, dato che l'utility viene usata solo per la scansione).

Una volta che tutte le prove/test sono a posto devi rimuovere il PPA manualmente da Software e Aggiornamenti, cliccandoci sopra e togliendo la spunta a "inameiname/stable".



Se ancora non compare, l'ultima verifica la puoi dare, con la stampante accesa e collegata in usb al pc, tramite Terminale, digita il comando:
Citazione:lsusb

e poi Invio.

Come output a cascata dovrebbe darti:
Citazione:Bus 00X Device 0XX: ID 0XYX:XXXY Canon, Inc.

dove al posto delle X e Y ci sono numeri e lettere.
Questo output significa che l'hardware è stato riconosciuto ed è pronto per essere utilizzato.

Se ancora non compare, qualcosa è andato storto nei passaggi sopra, che ripeto da Ubuntu sono gli unici funzionanti (grazie ai driver aggiornati), pertanto dovrai controllare e rifare i passaggi.
Cita messaggio
Grazie da:
#7
Allora, non ci sono riuscito ancora... uno dei pacchetti comunque quando lo installo mi da dei problemi... riproverò nei prossimi giorni, secondo me però quando collego la stampante non riesco a far cercare i driver giusti ad Ubuntu che li va a cercare sempre in quelli che già ha di suo...
ho avuto da fare qualche settimana, ora ho riprovato... nel nenù atendina applicazioni, e poi grafica vedo che sono state installate le voci "Canon-printer-mantenance" e "Canon-Printe-Monitor", ma cliccandoci sopra non ottengo nulla., non si apre nulla.

Nel frattempo ho installato playonlinux, che dovrebbe permettere di far funzionare eseguibili di xp... potrei sfruttarlo per far funzionare questa stampante? e come?
Cita messaggio
Grazie da:
#8
Per me ti vai ad impegolare in una questione che poi difficilmente riesci a risolvere.

PlayOnLinux non è che una versione con "gui" facilitata di Wine, e storicamente, è difficile far funzionare i driver sia delle  stampanti sia degli scanner in quelle condizioni.
Qualcuno è riuscito, ma installando prima correttamente da sistema Linux:
https://askubuntu.com/questions/864874/i...layonlinux
via Cups.

Ti conviene virtualizzare XP o Seven o altra copia legale in tuo possesso e da lì installi il driver proprio per il tuo sistema operativo Windows. Io tenterei con VirtualBox, che è il passo più semplice da compiere, già provato anche da altri, per esempio:
http://www.istitutomajorana.it/forum2/Th...x-con-Wine
Cita messaggio
Grazie da:
#9
Sul pc ho un'altra partizione con W10 ma nemmeno li sembra funzionare la stampante... proviamo a virtualizzare xp... cosa devo fare?
Cita messaggio
Grazie da:
#10
Ci credo perché solo il modulo aggiuntivo del driver è compatibile con Seven (quindi anche usabile con 8, 8.1 e 10), ma non quello relativo al modulo driver effettivo che rimane solo per Windows XP sia a 32 che a 64-bit.

Per la soluzione con l'uso della VM:

In pratica ti devi procurare una copia di XP (a 32 o a 64-bit, ma meglio da 32 per usarlo su VM).
Scarichi i due driver per la stampante:
https://www.canon.it/support/consumer_pr...p1600.aspx

Se sei su Ubuntu a 64 bit come mi par di capire, basta che installi la versione di VirtualBox e fai partire una copia del CD o una ISO di XP dopo aver settato a mano i vari parametri.
ATTENZIONE:
ad aggiungere sia le Guest Additions (devi installarle) ma soprattutto i VirtualBox_Extension_Pack che di fatto fanno funzionare i moduli USB della tua stampante!!
NB:
ad ogni versione di VirtualBox corrisponde la sua per Guest ed Extension, quindi se hai difficoltà a cercarli, ti allego direttamente il link da cui puoi prelevarli:
https://download.virtualbox.org/virtualbox/

Una maxiguida su VBox è questa:
https://www.chimerarevo.com/linux/guida-...ne-230576/
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)