Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Installazione Ubuntu su supporto usb.
#1
Buongiorno, ho un problema che non riesco a risolvere.
Ho un portatile hp del 2016 con win 10 installato. Intel i3 con 4 giga di ran.
Ho provato a caricare una iso su pendrive con Rufus e altri programmi. Avendo formattato in ext4, all'avvio mi partiva win10 e non la live di Backbox caricata.
Dopo di che formatto in fat32, carico la iso, e la live parte.

Prendo una seconda penna usb dove voglio caricare l'installazione persistente. Dalla live di Bb clicco installa e faccio l'installazione (come da guide) sulla seconda penna usb. 
Mi ritrovo dopo un'ora di installazione con la Backbox installata. Spengo il pc, inserisco solo la penna con installazione persistente ed avvio...... e mi carica win10.
Da quanto ho capito il problema è che l'installazione pers. ha file system ext4 che all'avvio non viene rilevato.
Provo a fare una seconda installazione persistente in fat32 ma neppure parte, dicendo che Linux non vuole quel file system.
Le ho provate tutte. Ho disabilitato secure boot, cambiato unità fisica alla penna, fast boot non ce l'ho..., provato con un tool di win a creare una installazione persistente partendo da una iso e in questo caso funziona ma parte in live.
Non credo che il problema sia Backbox (proverò a installare ubuntu, ma non ci vogliono dieci minuti... non posso fare infinite prove).
Perché la live parte ma l'installazione vera e propria non ne vuole sapere?

Ringrazio anticipatamente. 
P.s.: ho cercato ovunque documentazione ma nello specifico ho trovato ben poco.


edit esabatad: discussione spostata nella sezione Installazione e Disinstallazione
Cita messaggio
Grazie da:
#2
scusami l'ignoranza, ma puoi spiegare meglio dove hai installato ubuntu?
l'avvio del sistema 10 come avviene? ( da EFI oppure da MBR )
bisognerà dire a chi gestisce l'avvio che c'è anche ubuntu.
Cita messaggio
Grazie da: cicca79
#3
(15-09-2017,12:30 )dxgiusti Ha scritto: scusami l'ignoranza, ma puoi spiegare meglio dove hai installato ubuntu?
l'avvio del sistema 10 come avviene? ( da EFI oppure da MBR )
bisognerà dire a chi gestisce l'avvio che c'è anche ubuntu.

win10 è installato come da fabbrica sul pc (sull'hd) e per non modificare partizioni ho installato ubuntu su un supporto esterno (una penna usb).
A quanto ne so ho un sistema UEFI ma sono alquanto ignorante in merito.

Però non capisco bene a cosa ti riferisci con "l'avvio del sistema 10..." lui parte normale dall'a hd.
Il mio hd è partizionato con la tipica struttura efi e anche nel bios è in modalità efi o uefi. La iso è una 64bit.

Se inserisco l'installatore (su penna usb) ed avvio il pc, mi parte ubuntu che mi chiede se voglio installarlo o provarlo senza installarlo su schermo nero.
Se inserisco la penna con la versione installata mi aspetterei che partisse come fa l'installatore invece parte win10 come non vedesse la usb.

Ps: da quando ho fatto la prima installazione su penna usb ho notato due cambiamenti:
1) quando premevo f10 all'avvio mi apriva la schermata stile dos delle impostazioni comprese quelle per il bios. Adesso se premo f10 all'avvio mi apre una schermata in grafica e da lì posso accedere a quella stile dos.
2) la seconda volta che ho fatto l'installazione al momento di decidere dove installare ubuntu non mi chiedeva più se volevo metterlo a fianco di win dicendomi che qualcosa che non ricordo a riguardo del bootloader. In pratica è scomparsa la scelta automatica di installare ubuntu di fianco a win10. La prima installazione c'era la seconda no (tutte le volte installato su penna usb) (HD interno mai volontariamente toccato).

Grazie mille per la risposta.
Cita messaggio
Grazie da:
#4
da quanto dici il tuo computer si avvia tramite EFI. questo vuol dire che sul tuo hd hai una partizione appunto efi dove è installato l'avvio ( il tuo leggerà in quella partizione cosa avviare ). tu ora installi ubuntu su di un dispositivo esterno ( ovviamente dovrà essere installato in modalità UEFI ) e dovrai posizionare l'avvio sulla partizione EFI del tuo hd. in questo modo all'avvio ti verrà presentata la solita schermata del dualboot. due cose molto importanti da sottolineare:

  1. in questo modo se dovessi avviare il computer senza il supporto esterno potrebbe non avviarsi più nulla ( è da verificare )
  2. ripristinare l'avvio originale di 10 in EFI non è cosa semplice. ti consiglio di creare una immagine della sola partizione EFI, sarà un gioco ripristinare la "normalità" del riavvio. io uso clonezilla ma anche altri vanno bene.
Cita messaggio
Grazie da: cicca79
#5
(15-09-2017,13:40 )dxgiusti Ha scritto: da quanto dici il tuo computer si avvia tramite EFI. questo vuol dire che sul tuo hd hai una partizione appunto efi dove è installato l'avvio ( il tuo leggerà in quella partizione cosa avviare ). tu ora installi ubuntu su di un dispositivo esterno ( ovviamente dovrà essere installato in modalità UEFI ) e dovrai posizionare l'avvio sulla partizione EFI del tuo hd. in questo modo all'avvio ti verrà presentata la solita schermata del dualboot. due cose molto importanti da sottolineare:

  1. in questo modo se dovessi avviare il computer senza il supporto esterno potrebbe non avviarsi più nulla ( è da verificare )
  2. ripristinare l'avvio originale di 10 in EFI non è cosa semplice. ti consiglio di creare una immagine della sola partizione EFI, sarà un gioco ripristinare la "normalità" del riavvio. io uso clonezilla ma anche altri vanno bene.

Sinceramente avevo capito fosse molto più facile. Non me la sento di apportare modifiche troppo "in profondità". Poi non riuscirei a risolvere eventuali problemi e sarebbe una catena.
Ti ringrazio per la spiegazione, ciao.
Cita messaggio
Grazie da:
#6
puoi sempre installare virtualbox su 10 e virtualizzare una installazione definitiva di ubuntu. non interferirai mai con il 10 installato ed il suo avvio.
Cita messaggio
Grazie da: cicca79
#7
(15-09-2017,14:03 )dxgiusti Ha scritto: puoi sempre installare virtualbox su 10 e virtualizzare una installazione definitiva di ubuntu. non interferirai mai con il 10 installato ed il suo avvio.

L'ho già fatto e ci ho installato Mint. Il fatto è che il mio pc risulta lento quando deve fare girare la vm. 
Visto che l'installabile lo vede direttamente senza problemi pensavo facesse lo stesso con la versione installata. Ho letto diverse guide e visto diversi video e nessuno ha avuto problemi. Bastava mettere l'unità usb come prima e partivano le installazioni su hd esterni.
Mah.
Sono convinto che il problema sia che la ext4 non la veda all'avvio.
Comunque grazie del tempo...
Ciao
Cita messaggio
Grazie da:
#8
Per fare partire un sistema operativo inserito in una memoria esterna non basta mettere l'unità dove è presente la memoria come prima a partire quando si accende il pc? 
Se metto la usb come prima un'unità dovrebbe leggere prima lì e se trova qualcosa dovrebbe caricarlo. Logico che se trova un video non lo carica, ma un sistema operativo dovrebbe caricarlo.
Cita messaggio
Grazie da:
#9
potrebbe essere. prova.
ricordati che il tuo sistema avvia tramite EFI quindi dovrai fare una installazione in quella modalità >>> tabelle partizioni disco in GPT, ecc.ecc.
dovrai sempre cambiare l'ordine di avvio del disco dal bios/efi prima di ogni avvio.
Cita messaggio
Grazie da: cicca79
#10
Ho letto la discussione, ma mi sembra di non avere capito bene il problema. Io ho UEFI e per utilizzare un sistema linux caricato su una chiavetta in live al'avvio premo F11 e seleziono la chiavetta inserita; questo non è facile al primo tentativo perché mi compaiono parecchie opzioni usb, ma basta provarle tutte per scoprire quale è quella giusta.
Spero di avere azzeccato quale è il tuo problema
Cari saluti a tutti
Cita messaggio
Grazie da: cicca79


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)