Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Job failed to start | error processing package | dependency problems
#1
Sto provando a installare il desktop su ubuntu 14.04 per poter accedere via VNC alla mia VPS.
Sto usando un servizio di cloud computing dove in pratica si possono creare, installare e distruggere le istanze di ubuntu

Mi collego con putty al server e accedo come root (unico utente)

Dopo apt-get update il comando da me digitato è:

apt-get install gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal

Inizia lo scaricamento dei pacchetti e poi l'installazione. Sembra procedere bene, ma ad un certo punto ecco un mare di errori:

Codice:
start: Job failed to start
invoke-rc.d: initscript systemd-logind, action "start" failed.
dpkg: error processing package libpam-systemd:amd64 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of policykit-1:
policykit-1 depends on libpam-systemd; however:
 Package libpam-systemd:amd64 is not configured yet.

dpkg: error processing package policykit-1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of colord:
colord depends on policykit-1 (>= 0.103); however:
 Package policykit-1 is not configured yet.

dpkg: error processing package colord (--configure):
dependency problems - leaving unconfigured
Setting up upower (0.9.23-2ubuntu1) ...
Setting up gnome-power-manager (3.8.2-1ubuntu2) ...
Setting up gnome-session-bin (3.9.90-0ubuntu12) ...
update-alternatives: using /usr/bin/gnome-session to provide /usr/bin/x-session-manager (x-session-manager) in auto mode
Setting up gnome-session (3.9.90-0ubuntu12) ...
dpkg: dependency problems prevent configuration of policykit-1-gnome:
policykit-1-gnome depends on policykit-1; however:
 Package policykit-1 is not configured yet.

dpkg: error processing package policykit-1-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-session-flashback:
gnome-session-flashback depends on policykit-1-gnome; however:
 Package policykit-1-gnome is not configured yet.

dpkg: error processing package gnome-session-flashback (--configure):
dependency problems - leaving unconfigured
Setting up indicator-power (12.10.6+14.04.20140411-0ubuntu1) ...
Setting up indicator-session (12.10.5+14.04.20140410-0ubuntu1) ...
dpkg: dependency problems prevent configuration of pulseaudio:
pulseaudio depends on libpam-systemd; however:
 Package libpam-systemd:amd64 is not configured yet.

dpkg: error processing package pulseaudio (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcanberra-pulse:amd64:
libcanberra-pulse:amd64 depends on pulseaudio; however:
 Package pulseaudio is not configured yet.

dpkg: error processing package libcanberra-pulse:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-x11:
pulseaudio-module-x11 depends on pulseaudio; however:
 Package pulseaudio is not configured yet.

dpkg: error processing package pulseaudio-module-x11 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-system-service:
ubuntu-system-service depends on policykit-1; however:
 Package policykit-1 is not configured yet.

dpkg: error processing package ubuntu-system-service (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-sound:
indicator-sound depends on pulseaudio; however:
 Package pulseaudio is not configured yet.

dpkg: error processing package indicator-sound (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-control-center:
unity-control-center depends on indicator-sound; however:
 Package indicator-sound is not configured yet.

dpkg: error processing package unity-control-center (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-control-center-signon:
unity-control-center-signon depends on unity-control-center; however:
 Package unity-control-center is not configured yet.

dpkg: error processing package unity-control-center-signon (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of aptdaemon:
aptdaemon depends on policykit-1; however:
 Package policykit-1 is not configured yet.

dpkg: error processing package aptdaemon (--configure):
dependency problems - leaving unconfigured
Processing triggers for dictionaries-common (1.20.5) ...
aspell-autobuildhash: processing: en [en-common]
aspell-autobuildhash: processing: en [en-variant_0]
aspell-autobuildhash: processing: en [en-variant_1]
aspell-autobuildhash: processing: en [en-variant_2]
aspell-autobuildhash: processing: en [en-w_accents-only]
aspell-autobuildhash: processing: en [en-wo_accents-only]
aspell-autobuildhash: processing: en [en_CA-variant_0]
aspell-autobuildhash: processing: en [en_CA-variant_1]
aspell-autobuildhash: processing: en [en_CA-w_accents-only]
aspell-autobuildhash: processing: en [en_CA-wo_accents-only]
aspell-autobuildhash: processing: en [en_GB-ise-w_accents-only]
aspell-autobuildhash: processing: en [en_GB-ise-wo_accents-only]
aspell-autobuildhash: processing: en [en_GB-ize-w_accents-only]
aspell-autobuildhash: processing: en [en_GB-ize-wo_accents-only]
aspell-autobuildhash: processing: en [en_GB-variant_0]
aspell-autobuildhash: processing: en [en_GB-variant_1]
aspell-autobuildhash: processing: en [en_US-w_accents-only]
aspell-autobuildhash: processing: en [en_US-wo_accents-only]
Setting up hunspell-en-us (20070829-4ubuntu3) ...
Setting up libenchant1c2a:amd64 (1.6.0-10ubuntu1) ...
Setting up libwebkitgtk-3.0-0:amd64 (2.4.7-1~ubuntu1) ...
Setting up libgoa-backend-1.0-1:amd64 (3.10.3-0ubuntu1) ...
Setting up enchant (1.6.0-10ubuntu1) ...
Setting up zenity (3.8.0-1ubuntu1) ...
Setting up libyelp0 (3.10.2-0ubuntu1) ...
Setting up yelp (3.10.2-0ubuntu1) ...
Setting up gnome-user-guide (3.8.2-1) ...
Setting up aspell (0.60.7~20110707-1ubuntu1) ...
Processing triggers for dictionaries-common (1.20.5) ...
Setting up aspell-en (7.1-0-1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Setting up avahi-utils (0.6.31-4ubuntu1) ...
Setting up gnome-bluetooth (3.8.2.1-0ubuntu4.1) ...
Setting up libnss-mdns:amd64 (0.10-6) ...
First installation detected...
Checking NSS setup...
Processing triggers for sgml-base (1.26+nmu4ubuntu1) ...
Setting up libmetacity-private0a (1:2.34.13-0ubuntu4) ...
Setting up libnss3-nssdb (2:3.17.1-0ubuntu0.14.04.2) ...
Setting up libnss3:amd64 (2:3.17.1-0ubuntu0.14.04.2) ...
Setting up liboauth0:amd64 (1.0.1-1) ...
Setting up gnome-icon-theme (3.10.0-0ubuntu2) ...
Setting up brasero (3.10.0-0ubuntu1) ...
Setting up libcamel-1.2-45 (3.10.4-0ubuntu1.5) ...
Setting up libedataserver-1.2-18 (3.10.4-0ubuntu1.5) ...
Setting up libebackend-1.2-7 (3.10.4-0ubuntu1.5) ...
Setting up libebook-contacts-1.2-0 (3.10.4-0ubuntu1.5) ...
Setting up libedata-book-1.2-20 (3.10.4-0ubuntu1.5) ...
Setting up libebook-1.2-14 (3.10.4-0ubuntu1.5) ...
Setting up libecal-1.2-16 (3.10.4-0ubuntu1.5) ...
Setting up libedata-cal-1.2-23 (3.10.4-0ubuntu1.5) ...
Setting up libgdata13 (0.14.1-1) ...
Setting up evolution-data-server (3.10.4-0ubuntu1.5) ...
Setting up evolution-data-server-online-accounts (3.10.4-0ubuntu1.5) ...
Setting up gconf-service-backend (3.2.6-0ubuntu2) ...
Setting up gconf-service (3.2.6-0ubuntu2) ...
Setting up gconf2 (3.2.6-0ubuntu2) ...
update-alternatives: using /usr/bin/gconftool-2 to provide /usr/bin/gconftool (gconftool) in auto mode

(gconftool-2:26727): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
Setting up libnm-util2 (0.9.8.8-0ubuntu7) ...
Setting up libnm-glib4 (0.9.8.8-0ubuntu7) ...
Setting up geoclue (0.12.99-3ubuntu1) ...
Setting up geoclue-ubuntu-geoip (1.0.2+14.04.20131125-0ubuntu2) ...
Setting up gir1.2-gconf-2.0 (3.2.6-0ubuntu2) ...
Setting up libpanel-applet-4-0 (1:3.8.0-1ubuntu12.2) ...
Setting up gir1.2-panelapplet-4.0 (1:3.8.0-1ubuntu12.2) ...
Setting up gnome-applets-data (3.5.92-0ubuntu3) ...
Setting up gnome-icon-theme-symbolic (3.10.1-1ubuntu1) ...
Setting up gnome-panel (1:3.8.0-1ubuntu12.2) ...
Setting up gnome-applets (3.5.92-0ubuntu3) ...
Setting up libnm-gtk0 (0.9.8.8-0ubuntu4.3) ...
Setting up gnome-control-center (1:3.6.3-0ubuntu56.1) ...
Setting up libgnome-media-profiles-3.0-0 (3.0.0-1ubuntu2) ...
Setting up gstreamer0.10-gconf:amd64 (0.10.31-3+nmu1ubuntu5) ...
Setting up gnome-media (3.4.0-1ubuntu2) ...
Setting up gnome-screensaver (3.6.1-0ubuntu13) ...
Setting up metacity (1:2.34.13-0ubuntu4) ...
update-alternatives: using /usr/bin/metacity to provide /usr/bin/x-window-manager (x-window-manager) in auto mode
Setting up gnome-terminal-data (3.6.2-0ubuntu1) ...
Setting up gnome-terminal (3.6.2-0ubuntu1) ...
update-alternatives: using /usr/bin/gnome-terminal.wrapper to provide /usr/bin/x-terminal-emulator (x-terminal-emulator) in auto mode
Setting up gnome-user-share (3.0.4-0ubuntu1) ...
Setting up ibus (1.5.5-1ubuntu3) ...
Setting up indicator-applet-complete (12.10.2+14.04.20140403-0ubuntu1) ...
Setting up indicator-datetime (13.10.0+14.04.20140415.3-0ubuntu1) ...
Setting up system-config-printer-gnome (1.4.3+20140219-0ubuntu2.5) ...
Setting up indicator-bluetooth (0.0.6+14.04.20140207-0ubuntu2) ...
Setting up humanity-icon-theme (0.6.5) ...
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.30.7-0ubuntu1) ...
Processing triggers for dictionaries-common (1.20.5) ...
Errors were encountered while processing:
libpam-systemd:amd64
policykit-1
colord
policykit-1-gnome
gnome-session-flashback
pulseaudio
libcanberra-pulse:amd64
pulseaudio-module-x11
ubuntu-system-service
indicator-sound
unity-control-center
unity-control-center-signon
aptdaemon
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ho notato che gli errori piu significativi sono sempre questi:
Codice:
E: Sub-process /usr/bin/dpkg returned an error code (1)
start: Job failed to start
dpkg: error processing package
dpkg: dependency problems prevent configuration
GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Errors were encountered while processing:

Visto che è la seconda volta che mi restituisce errori simili (ho già creato e distrutto l'istanza cloud e reinstallato un immagine di Ubuntu pulita) mi domando se il servizio che sto usando non abbia lui qualche problema a connettersi e installare i pacchetti.

Cosa devo fare in tal caso? Ci sono troppi errori? Si puo procedere ad una riparazione dei singoli errori o devo ritentare di rinstallare di nuovo tutto?
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)