SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Libre Office Base non parte.
#11
Buongiorno.
Non vorrei dare indicazioni sbagliate prendendo come riferimento il mio pc a 32 bit (che è un po' tanto pasticciato e LibreO non è nella posizione standard) ma la cartella principale di installazione dovrebbe essere la usr/lib/jvm.
Se non trovi nulla puoi disinstallare Java con il gestore pacchetti Synaptic e reinstallarlo prestando attenzione a cosa indica come percorso (che se ricordo bene prima di installare un pacchetto lo visualizza).

aggiorno alle 21.30
Ho controllato ora sul portatile a 64 bit e la posizione indicata proprio da LibreO in Avanzate riguardo a Java è: usr/lib/jvm/java-8-openjdk/jre
Se in questa posizione non trovi nulla segui le indicazioni di Marilù e installa i pacchetti che ti ha indicato. Che mi risulti, quando installi LibreO Base dal gestore questi pacchetti però li installa in automatico. Però non uso ne Ubuntu ne Mint ultima versione.
Cita messaggio
Grazie da:
#12
Ciao,
su Ubuntu Mate 16.04, nel gestore pacchetti ho
openjdk-8-jre
openjdk-8-jre-headless
icedtea-8-plugin   web browser plugin based on OpenJDK and IcedTea to execute Java applets

ho messo anche quello della Oracle,  tramite ppa del webupd8team
vedi il wiki di Ubuntu
https://wiki.ubuntu-it.org/Programmazione/Java
https://wiki.ubuntu-it.org/Programmazione/Java/Oracle

nelle opzioni di Libreoffice viene così
[Immagine: https://i.imgur.com/cC65tlL.png]
Cita messaggio
Grazie da:
#13
Quasi ci siamo.........
Infatti dicendo in Aggiungi il percorso indicato da
Citazione:massimm
usr/lib/jvm/java-8-openjdk/jre

arrivo ad avere la schermata finalmente con contenuto aanalogo a quello di Marilù
e cioè con anche dentro   Oracle ecc ecc

   

ma poi questo contenuto va perduto, cioè non rimane salvato. Alla apertura succesiva di LibreOffice Base non c'èpiù.
Cita messaggio
Grazie da:
#14
Buongiorno.
Non so se il tuo sistema sia a 32 o 64 bit, ma come Bat ti ha correttamente fatto presente la versione di java deve essere quella giusta per LibreO.
Io ho indicato il percorso della mia versione per darti un riferimento ma da un tuo post precedente vedo che hai la versione 10.0.1 (oltre alla 8 che hai aggiunto in LO tra l'altro per sistemi a 32), forse è per questo che quando riavvi LO Base rimuove il collegamento non essendo compatibile-corretta.
Se hai tutto a 64Bit devi cercare la tua versione 10 nei percorsi giusti e aggiungerla a Base.
Non avendo un 64bit sottomano posso ipotizzare un percorso (da prendere però con le dovute molle e i molti dubbi): usr/lib64/jvm/XXXXX-openjdk/jre
Cita messaggio
Grazie da:
#15
Il pacchetto libreoffice-java-common ce l'hai installato?

(01-08-2018,22:53 )liviofa Ha scritto: .....ma poi questo contenuto va perduto, cioè non rimane salvato. Alla apertura succesiva di LibreOffice Base non c'èpiù.

A me rimane memorizzato, forse da te non è il java che viene usato di default.


Il wiki di Ubuntu dice che bisogna scegliere la versione in uso
https://wiki.ubuntu-it.org/Programmazion...one_in_uso
Cita messaggio
Grazie da:
#16
Rispondo nell'ordine
@Marilù     libreoffice-java-common se vado in Synaptic lo vedo installato.

Poi cerco anche di venir fuori da questa confusione che ho in testa sui 32 o 64 bit.
Io penso di avere il SO a 32 bit come da schermata che vi trasmetto

   

Ditemi voi se non è a 32 bit.
Poi già in passato mi avete fatto richieste al terminale su Java che dovrebbe essere a 32 bit. O no ?

E pure questa richiesta che ora rifaccio
Codice:
libreoffice  --version
LibreOffice 6.0.3.2 00m0(Build:2)

liviofa@matteofa:~$
a voi dice qualcosa ?? Si sa se è a 32 o 64 bit ??
Cita messaggio
Grazie da:
#17
il sistema operativo è a 32 bit
quindi hai per forza libreoffice a 32 bit perché la versione a 64 bit non funzionerebbe
di conseguenza hai sicuramente java a 32 bit,
non ti rimane che indicare la giusta cartella di installazione del JRE a LibreOffice (guarda l'immagine postata da Marilù, dovrebbe essere la stessa);
magari fallo avviando LibreOffice come utente root, la configurazione deve rimanere salvata
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
Supporto su Informatica Libera
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
Grazie da:
#18
Credo che ci avviciniamo sempre più............... almeno spero.
@BAT   seguo il suo consiglio e avvio libreoffice da  
Codice:
root@matteofa:/home/liviofa#

Dopo partito vado in Strumenti  ->  Avanzate  e vedo senza aver fatto nulla

   

ho addirittura 2 Oracle a scelta.   Rimango sul primo e faccio OK
Mi viene chiesto
Citazione:Devi riavviare Libre Office affinchè l'ambiente di runtime Java possa ecc ecc

e allora dico di riavviare.
Alla ripartenza la schermata Strumenti  ->  Avanzate   è vuota senza biffetto Usa un ambiente di runtime Java

AGGIUNTA 10 minuti dopo : ritorno a lanciare libreoffice da Root e la schermata di cui sopra con biffetto e due versioni Oracle c'è.
Cita messaggio
Grazie da:
#19
Buongiorno.
Quindi avviando LO come root sei riuscito a impostare Java 10, il fatto però che non mantenga al riavvio quelle impostazioni mi fa pensare che, forse, hai i permessi per quel file solo come root e non come utente.
Non so come funziona Ubuntu quindi per evitare potenziali pasticci, o peggio, a causa di pessimi suggerimenti (miei) ti conviene aspettare Bat, Marilù o altri più afferrati di me nel mondo Linux.
Cita messaggio
Grazie da:
#20
MI sto rendendo conto che sto vivendo una situazione al di sopra delle mie capacità. Ma a ben vedere non è che pretenda la luna. Già ho vissuto un percorso lungo e tortuoso e con l'aiuto dell'amico Dxgiusti sono riuscito a far funzionare LO in italiano. E anche questo non è la luna............... Tongue

Ora questa parte di LO cioè Dbase non vuole funzionare.

Se lo lancio da root parte e fa vedere nella parte -> Strumenti _> Avanzate ben due prodotti Oracle pronti ad agire.
Scelgo 1.8.0_171

dopo detto OK passa al terminale dove appare
Codice:
(soffice:2842): GLib-GObject-WARNING **: 15:55:12.598: ../../../../gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x27a6d08' of type 'OOoAtkObjCompTxt'
root@matteofa:/home/liviofa#

e Libre Office Base non c'è più. Disperato
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: