Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Link in Openoffice con Firefox
#1
Ciao a tutti,

come faccio a far capire ad Openoffice4 che i link me li deve aprire con Firefox e non con GoogleChrome?

Eppure Firefox nelle applicazioni preferite è il browser di sistema.

Prima per openoffice3 c'era un componente aggiuntivo per selezionare il browser ma non funziona più.
Ci sarà un file di configurazione annidiato da qualche parte in Ubuntu 12.04 da modificare?

Grazie
Marilù
Cita messaggio
Grazie da:
#2
controlla nelle opzioni di firefox se è il browser predefinito, vai su opzioni, scheda generale.
Metti una spunta su Controlla sempre all'avvio se Firefox è il browser predefinito, riavvia firefox e conferma che dovrà essere il browser predefinito.
Avvia openoffice e verifica se riesci ad aprire i link con firefox.
Cita messaggio
Grazie da:
#3
 Grazie d4rkheart

Ho rinominato le cartelle nascoste nella home per azzerare tutte le impostazioni precedenti sia si Chrome che di Firefox. Riavviato Firefox mettendo la spunta su predefinito come hai detto sopra e Chrome togliendo la spunta.  ... ma niente.

Allora per curiosità ho provato a mettere Chrome come browser predefinito di sistema  e ho avviato Thunderbird: quando clicco su un link di una mail prima si apriva Firefox, adesso Chrome.
Questo vuol dire che le Applicazioni Predefinite ( quelle che si selezionano da Sistema -> Preferenze) su Thunderbird hanno effetto, (risistemato il browser predefinito su Firefox è tornato tutto come prima), mentre su Openoffice no.

Ho fatto anche la prova a rinominare la cartella nascosta di Openoffice  senza risultato.

Undecided   Mi sa che non ci sta niente da fare  ...


Ciao
Marilù
Cita messaggio
Grazie da:
#4
per curiosità ho anche io provato.... non ci crederai ma a me capita esattamente l'opposto. ho opera predefinito ma i link su openoffice si aprono con firefox!! ho cercato, sfogliato ma non ho trovato nulla. il bello è che se faccio da file anteprima nel browser web, si apre il predefinito.
Cita messaggio
Grazie da:
#5
Si anche se clicco sul pulsante senza nessun indirizzo si apre firefox (mio predefinito), ma non appena ci scrivo un indirizzo fa quello che vuole lui

   
Marilù
Cita messaggio
Grazie da:
#6
Ciao @dxgiusti,

Per caso centra qualcosa questo file "open-url" che si trova in opt/openoffice4/program?

open-url

l'ho trovato perché ho letto questa discussione


io però non ci capisco niente . . . Scappo


Allegati Anteprime
   
Marilù
Cita messaggio
Grazie da:
#7
aprilo con editor di testo e copia il contenuto, incollalo qui. Vediamo se si può far qualcosa.
Stai usando gnome/kde? quale ambiente desktop stai utilizzando? perché l'utente ha modificato il file kde-open-url.
Cita messaggio
Grazie da:
#8
Codice:
#!/bin/sh
# *************************************************************
#  
#  Licensed to the Apache Software Foundation (ASF) under one
#  or more contributor license agreements.  See the NOTICE file
#  distributed with this work for additional information
#  regarding copyright ownership.  The ASF licenses this file
#  to you under the Apache License, Version 2.0 (the
#  "License"); you may not use this file except in compliance
#  with the License.  You may obtain a copy of the License at
#  
#    http://www.apache.org/licenses/LICENSE-2.0
#  
#  Unless required by applicable law or agreed to in writing,
#  software distributed under the License is distributed on an
#  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
#  KIND, either express or implied.  See the License for the
#  specific language governing permissions and limitations
#  under the License.
#  
# *************************************************************

# tries to locate the executable specified
# as first parameter in the user's path.
which() {
 if [ ! -z "$1" ]; then
   for i in `echo $PATH | sed -e 's/^:/.:/g' -e 's/:$/:./g' -e 's/::/:.:/g' -e 's/:/ /g'`; do
     if [ -x "$i/$1" -a ! -d "$i/$1" ]; then
       echo "$i/$1"
       break;
     fi
   done
 fi
}

# checks for the original mozilla start script(s)
# and restrict the "-remote" semantics to those.
run_mozilla() {
 if file "$1" | grep "script" > /dev/null && grep "NPL" "$1" > /dev/null; then
   "$1" -remote 'ping()' 2>/dev/null >/dev/null
   if [ $? -eq 2 ]; then
     "$1" "$2" &
   else
     "$1" -remote "openURL($2, new-window)" &
   fi
 else
   "$1" "$2" &
 fi
}

# checks the browser value for a %s as defined in
# http://www.catb.org/~esr/BROWSER/index.html
run_browser() {
 echo "$1|$2" | awk '
{
   FS="|";
   $syscmd="";
   if (index($1,"%s") > 0) {
       $syscmd=sprintf($1,$2);
   } else {
       $syscmd=sprintf("%s \"%s\"",$1,$2);
   }
   system($syscmd " &");
}' > /dev/null
}

# special handling for mailto: uris
if echo $1 | grep '^mailto:' > /dev/null; then
 # check for xdg-email
 mailer=`which xdg-email`
 if [ ! -z "$mailer" ]; then
   $mailer "$1" &
   exit 0
 fi
 # check $MAILER variable
 if [ ! -z "$MAILER" ]; then
   $MAILER "$1" &
   exit 0
 fi
 # mozilla derivates may need -remote semantics
 for i in thunderbird mozilla netscape; do
   mailer=`which $i`
   if [ ! -z "$mailer" ]; then
     run_mozilla "$mailer" "$1"
     exit 0
   fi
 done
 # handle all non mozilla mail clients below
 # ..
else
 # check for xdg-open
 browser=`which xdg-open`
 if [ ! -z "$browser" ]; then
   $browser "$1" &
   exit 0
 fi
 # check $BROWSER variable
 if [ ! -z "$BROWSER" ]; then
   $BROWSER "$1" &
   exit 0
 fi
 # mozilla derivates may need -remote semantics
 for i in firefox mozilla netscape; do
   browser=`which $i`
   if [ ! -z "$browser" ]; then
     run_mozilla "$browser" "$1"
     exit 0
   fi
 done
 # handle all non mozilla browers below
 # ..
fi
exit 1


Uso Ubuntu 12.04 desktop Mate , se si va in opt/openoffice4/program e poi si cerca open-url viene fuori anche gnome open-url e kde open-url e cde open-url (vedi allegato sopra)

Grazie
Marilù
Cita messaggio
Grazie da:
#9
ho aperto il file nel mio sistema operativo ubuntu ed è uguale a quello che hai postato, come browser predefinito ho firefox e mi apre i link con firefox, io ho ubuntu 12.04...sarà un problema legato al sistema operativo? :-(
Cita messaggio
Grazie da:
#10
Mi viene quasi da pensare che in Openoffice4 ci sia una classifica dei browser da aprire per prima in base a quelli che sono installati indipendentemente dalle configurazioni del computer,
ma è più probabile che dipenda da Chrome che riesca a far partire i link qualsiasi siano le applicazioni predefinite (per colpa di una carenza del sistema operativo, almeno del mio Ubuntu 12.04 MATE) per i programmi che non sono di default in ma installati in seguito, ad esempio anche sui pdf aperti con foxit reader, mentre invece con il visualizzatore documenti Atril i link nei pdf si aprono con firefox.

Questa ultima ipotesi spiegherebbe forse anche il fenomeno che si verifica a Dxgiusti.
Marilù
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)