Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Mint 18 xserver xorg non si avvia
#1
Buona sera At
ho installato Linux Mint 18 su un Acer Aspire 5741G (Processore: Intel Core i5 430M, Scheda grafica: ATI Mobility Radeon HD 5470). Quando riavvio Xserver Xorg non parte. Lo schermo resta tutto nero con un trattino lampeggiante in alto. Disperato

Come risolvo?
Notebook Dell Latitude E6410 Intel Core i5 M250 2,4 GHz x2; RAM: 4GB; SSD 250GB; Scheda Grafica NVIDIA GT218M.
Cita messaggio
Grazie da:
#2
non vorrei darti una "brutta notizia" ma penso che si tratti proprio della scheda grafica non riconosciuta
dovresti fornire maggiori informazioni comunque
posta il risultato di
lspci
per vedere se le schede sono due
Cita messaggio
Grazie da: Robert Lang
#3
Neanche manualmente se lo lanci con
startx
?
Cita messaggio
Grazie da: Robert Lang
#4
(11-09-2017,09:00 )Blackstar Ha scritto: Neanche manualmente se lo lanci con
startx ?
Ma su mint "startx" funziona ancora?
Dalla consolle per lanciare lo xorg si dovrebbe usare (da mint)
Codice:
sudo service mdm start

@Robert Lang
dallo schermo nero facendo Ctrl+Alt+F1 entri nella consolle?

Prova anche ad avviare in recovery e da lì continuare con l'avvio normale: cambia qualcosa?
Cita messaggio
Grazie da: Robert Lang
#5
(11-09-2017,13:42 )andrea111 Ha scritto: Ma su mint "startx" funziona ancora?
Dalla consolle per lanciare lo xorg si dovrebbe usare (da mint)
Codice:
sudo service mdm start

Molto probabilmente hai ragione Smile
https://community.linuxmint.com/software/view/mdm
Cita messaggio
Grazie da: Robert Lang
#6
per quanto riguarda i comandi vanno bene entrambi....
il problema è che se la scheda grafica non è riconosciuta ...
da una ricerca (veloce) che ho fatto pare proprio che la scheda sia tra quelle che
non sono supportate da amdgpu... ho visto però che il computer in questione dovrebbe essere
dotato di due schede grafiche, in quel caso si potrebbe risolvere ( se l'altra? è supportata)...
in alternativa non resta che installare una versione precedente, dove ancora si possono installare i driver
fglrx... quindi aspettiamo la risposta di robert lang
Cita messaggio
Grazie da: Robert Lang
#7
@luciano
I radeon però dovrebbero entrare sempre e comunque con tutte le schede ATI e senza la necessità di uno xorg.conf ad-hoc.
Di recente si sono visti problemi come quello di Robert Lang ripetersi con una certa frequenza.
Cita messaggio
Grazie da: Robert Lang
#8
(12-09-2017,13:13 )andrea111 Ha scritto: @luciano
I radeon però dovrebbero entrare sempre e comunque con tutte le schede ATI e senza la necessità di uno xorg.conf ad-hoc.
Di recente si sono visti problemi come quello di Robert Lang ripetersi con una certa frequenza.

purtroppo a causa del poco tempo a disposizione, non ho potuto approfondire l'argomento
però posso affermare che la nuova versione di xorg non permette l'installazione dei driver fglrx
e per quanto riguarda i radeon si, dovrebbero "entrare" e nel caso di mint che ha i firmware già installati
non dovrebbero esserci problemi, però se il pc ha doppia scheda entra in gioco
il kms (kernel mode setting) che a volte non funziona e il sistema non sa quale scheda far partire....
risultato schermo nero, stessa cosa se il firmware non è quello della scheda in oggetto.
comunque ecco un link dove si parla proprio della scheda in questione su mint e dove si evidenzia il problema
e poi si consiglia di ritornare alla versione precedente:
https://forums.linuxmint.com/viewtopic.php?t=236044

ripeto che secondo me serve che roberto ci dia maggiori informazioni sul pc per poter valutare meglio Tux
Cita messaggio
Grazie da: Blackstar , Robert Lang
#9
Buonasera. Grazie a tutti per le risposte. Non so per quale motivo, ma ho risolto installando Linux Mint 18.2 KDE. Se qualcuno di voi sa anche il motivo potrebbe illuminarmi? Grazie. :-)
Notebook Dell Latitude E6410 Intel Core i5 M250 2,4 GHz x2; RAM: 4GB; SSD 250GB; Scheda Grafica NVIDIA GT218M.
Cita messaggio
Grazie da:
#10
@robert lang
devi fornire maggiori info sulla/e scheda/e che hai nel pc
posta il risultato di
Codice:
lspci | grep -E 'VGA|Display'

per vedere le schede grafiche e quindi
Codice:
lshw -c display | grep driver
per vedere i driver caricati
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)