Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Linux: installazione framework dotNetFx35Setup.exe
#1
Ciao amici,
per dei bambini con dislessia, un istituto scolastico veneto, ha proposto una serie di applicativi tutti per ambiente windows, penso su indicazione del MIUR :-|
La maggior parte degli applicativi funziona su linux tramite wine, uno in particolare "Leggixme" necessita di installare il software dotNetFx35Setup.

Qualcuno tra di voi ha già installato con successo tali applicazioni in ambiente Linux/Ubuntu?

Nota: per ambiente Linux esiste invece  Facilitoffice qualcuno di voi lo ha già utilizzato?


grazie infinite
Cita messaggio
Grazie da:
#2
Purtroppo non sono compatibili, per quel programma ci vuole il motore che è il framework di dot net che non gira su Linux.
Al momento non vedo soluzioni, io l'ho installato sul mio windows e ci faccio anche dei programmini ma non c'è verso di renderli compatibili con linux. mi dispiace.
Si possono fare dei programmi ma su windows così non ci sarebbe alcun problema ma non con linux. il framework è un software piuttosto potente che coinvolge a tutti i livelli il sistema e non ha alcuna compatibilità con linux. Tuttavia si possono fare su windows se occorre. Ciao
Per quanto riguarda Facilitoffice non ne ho mai sentito parlare, forse qualcuno è più aggiornato di me, senz'altro.
Quello che posso fare è provare a vedere se wine supporta il framework, ma ne dubito comunque è una prova che si può tentare...
Forse ci sono delle possibilità, c'è un'adattatore diciamo così che si chiama sharpDevelopFidalcoRC2setup.exe che permette di sviluppare in c# che è uno dei sistemi di programmazione del dotNet. ora sto leggendo questo articolo sulla compatibilità in ambienti Linux e ti farò sapere...
il link è questo: http://javagio.altervista.org/cppcs_cap01.pdf
Cita messaggio
Grazie da:
#3
(15-01-2015,16:47 )danjde Ha scritto: La maggior parte degli applicativi funziona su linux tramite wine, uno in particolare "Leggixme" necessita di installare il software dotNetFx35Setup.

Qualcuno tra di voi ha già installato con successo tali applicazioni in ambiente Linux/Ubuntu?

L'unica soluzione sicura di far girare programmi per Windows su Linux è quella di creare una machina virtuale per Windows XP (o altra versione) usando Virtualbox, dopodiché l'installazione potrà essere effettuata direttamente in XP virtualizzato esattamente come se fosse un sistema reale.
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
VERSIONE QUANTISTICA DELLA LEGGE DI MURPHY: TUTTO VA MALE CONTEMPORANEAMENTE
Cita messaggio
Grazie da:
#4
Senz'altro Bat ha ragione, io ho provato tramite la procedura descritta ad installare il framework ma dà inevitabilmente errore, come mi aspettavo del resto. La macchina virtuale è l'unica soluzione possibile senza alternative e con sicuro successo. Io ho provato due volte a ripetere l'installazione ma non ce la fa a reggere il sistema, L'unica è la via di Bat. Wine può andare bene per dei piccoli file, dei giochini o simili ma non con un sig. framework. Ciao
Cita messaggio
Grazie da:
#5
Intanto grazie a tutti per le gentilissimi ed esaustive indicazioni,
proverò con Virtualbox,
curioso del resto che un applicativo come leggixme si "tiri dietro" l'installazione di un framework, proverò a farlo notare allo sviluppatore..


ciao e grazie ancora
Cita messaggio
Grazie da:
#6
Grazie a tutti per il vostro contributo.
RADICALLY SIMPLE
[Immagine: http://i68.tinypic.com/a3nigh.png]


Cita messaggio
Grazie da:
#7
(16-01-2015,10:16 )danjde Ha scritto: curioso del resto che un applicativo come leggixme si "tiri dietro" l'installazione di un framework, proverò a farlo notare allo sviluppatore..

Per tua informazione, i vari .NET Framework costituiscono l'intelaiatura basilare di tutte le moderne applicazioni Windows.
E' perfettamente inutile dire allo sviluppatore una cosa del genere perché per i programmi moderni non si può farne a meno;
E' praticamente impossibile trovare un'applicazione relativamwente moderna che nion necessiti come minimo del .NET framerk 3.5 anche su Windows XP,
Windows 7 ha incoprorato .NET 3.5.1
Windows 8 e 8.1 incoprorano .NET 4.5
perfino Paint.NET dalla versione 4 necessita del .NET v4.5, e parliamo di un semplice programma di disegno
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
VERSIONE QUANTISTICA DELLA LEGGE DI MURPHY: TUTTO VA MALE CONTEMPORANEAMENTE
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)