SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Localhost, non riesco ad accedere
#11
(30-12-2014,15:05 )Max4me Ha scritto: Ciao,
allora la verifica era volta ad escludere che nella configurazione ci fosse un percorso diverso da quello di default che è appunto localhost/phpmyadmin (infatti dopo alias c'è /phpmyadmin).
Quindi, non avendo un server come il tuo sotto mano (e non ho neanche il tempo di provare), non posso far altro che consigliarti di verificare i link, come già ti ha detto menhir.
Un altro tentativo che puoi fare, non sapendo come hai installato il phpadmin, è verificare se in /etc/apache2/apache2.conf hai inserito la riga:
Include /etc/phpmyadmin/apache.conf
Prova a inserirla, riavvia apache2 e vedi se funziona.
Ciao
Due semplici domande:
1) come verifico i link (lo avevo chiesto anche a menhir ma non ho avuto risposte);
2) dove inserisco la riga che mi suggerisci nel file?
Grazie e ciao
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#12
Scusa il ritardo, ma in questigiorni sono un pò preso...
Per verificare i link puoi come anche suggerito nella guida che hai postato inserire nella directory
"/var/www/" o se al suo interno hai anche la cartella "html" in "/var/www/html" un file di poche righe in html nominandolo "index.html" od un file .php come spiegato nella guida.
dovresti poi accedere a questi files da browser inserendo il percorso:
Codice:
localhost/nome_file
Se i suddetti file non vengono correttamente visualizzati e/o ricevi un errore potrebbe in effetti essere un errore di configurazione come detto da Max4me.
Quando hai reinstallato hai prima fatto una rimozione completa? ( compresi i files di configurazione)
Citazione:ho rinominato le cartelle /var/www e /etc/mysql (se non ricordo male, potrei controllare se serve)
questo passaggio non so a cosa serva, non lo ho trovato nella guida, ma non vorrei che se messo in pratica, sia la causa del problema. Undecided
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#13
Ciao,
Puoi inserire la riga Include .... in fondo al file ....apache2.conf
Buona notte
just my two cents
Cita messaggio
Grazie da:
#14
Provato di tutto ma senza esito, mi sono però accorto che forse Apache2 non si riavvia infatti sul terminale se do il comando
Codice:
nicolo@nicolo-System-Product-Name:~$ sudo /etc/init.d/apache2 restart
Mi restituisce, dopo la password:
Codice:
* Restarting web server apache2                                                AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
                                                                         [fail]
* The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
nicolo@nicolo-System-Product-Name:~$
è quel [fail] che mi mette un sacco di dubbi, ho visto bene?
Grazie a tutti per la pazienza
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#15
Citazione:è quel [fail] che mi mette un sacco di dubbi, ho visto bene?
Grazie a tutti per la pazienza
dici bene. Quando riavvi apache2 il messaggio:
Citazione:apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
è "normale", lo ricevo anche io ogni volta che devo riavviare il webserver, ma come dice il messaggio stesso basta settare opportunamente il file di configurazione. Tutto il resto no.
Prova a reinstallare apache2, facendo prima anche la rimozione dei files di configurazione.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#16
(02-01-2015,14:18 )m3nhir Ha scritto:
Citazione:è quel [fail] che mi mette un sacco di dubbi, ho visto bene?
Grazie a tutti per la pazienza
dici bene. Quando riavvi apache2 il messaggio:


Citazione:apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Citazione:è quel [fail] che mi mette un sacco di dubbi, ho visto bene?
Grazie a tutti per la pazienza
dici bene. Quando riavvi apache2 il messaggio:

Citazione:apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
è "normale", lo ricevo anche io ogni volta che devo riavviare il webserver, ma come dice il messaggio stesso basta settare opportunamente il file di configurazione. Tutto il resto no.
è "normale", lo ricevo anche io ogni volta che devo riavviare il webserver, ma come dice il messaggio stesso basta settare opportunamente il file di configurazione. Tutto il resto no.
Come da firma non conosco l'inglese e mi rifiuto di impararlo; detto questo non so a cosa di riferisci con "settare opportunamente il file di configurazione".

(02-01-2015,14:18 )m3nhir Ha scritto: Prova a reinstallare apache2, facendo prima anche la rimozione dei files di configurazione.
Cioè devo rimuovere ancora apache e la cartella "/var/wwww"?
Grazie ancora
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#17
per la prima parte del messaggio, puoi anche fregartene, non inficia il funzionamento di apache.
Per il resto, no, non devi rimuovere quelle cartelle, ma da gestore pacchetti prima selezioni apache2 e dal menu scegli "rimozione completa - compresi i files di configurazione", dai ok. Successivamente reinstalli apache2 e verifichi se qualcosa è cambiato.
Per curiosità, da terminale riesci ad accedere ai databases, interrogarli e/o apportare modifiche?
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#18
(02-01-2015,16:06 )m3nhir Ha scritto: per la prima parte del messaggio, puoi anche fregartene, non inficia il funzionamento di apache.
Per il resto, no, non devi rimuovere quelle cartelle, ma da gestore pacchetti prima selezioni apache2 e dal menu scegli "rimozione completa - compresi i files di configurazione", dai ok. Successivamente reinstalli apache2 e verifichi se qualcosa è cambiato.
Ok anche se ho già rimosso le cartelle si ricreano ogni volta che installo apache2
Ho trovato questa guida e poi anche questa che mi sembrano valide ma io continuo a preferire di installare LAMP attraverso la guida postata in questo forum (per essere precisi questa guida)

(02-01-2015,16:06 )m3nhir Ha scritto: Per curiosità, da terminale riesci ad accedere ai databases, interrogarli e/o apportare modifiche?
Se intenti attraverso il comando
Codice:
mysql -u root -p
si riesco ad accedere e subito esco col comando \q per evitare di far danni
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#19
ok, non ci sono differenze sostanziali dall'installare LAMP o i singoli elementi separatamente, io per esempio installo tutto selezionando i vari pacchetti nel gestore pacchetti, ma il risultato non cambia. Hai provato a creare/salvare nella directory di default di localhost (/var/www o /var/www/html) il file "phpinfo.php" come spiegato nelle guide che hai postato?, funziona?
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#20
Allora se provo a creare il file phpinfo.php con dentro
Codice:
<?php phpinfo(); ?>
dopo averlo inserito in /var/www appena provo ad aprire su firefox /localohost/phpinfo.php mi chiede come aprire il file e se vado con gedit mi apre il file come contenuto, ho anche provato a dare al file i permessi di aprirsi come applicazione ma con lo stesso risultato.
Ho inserito nel file /etc/apache2/apache2.conf alla fine la riga
Codice:
Include /etc/phpmyadmin/apache.conf
, riavviato ma senza esito positivo (/localhost/phpmyadmin mi da sempre "spiacenti ...).
Ho notato invece che il file index.html presente in /var/www/html ha contenuto diverso che in precedenza ed infatti con /localhost si apre il suo contenuto che è:
Codice:
Debian Logo Apache2 Debian Default Page
It works!

This is the default welcome page used to test the correct operation of the Apache2 server after installation on Debian systems. If you can read this page, it means that the Apache HTTP server installed at this site is working properly. You should replace this file (located at /var/www/html/index.html) before continuing to operate your HTTP server.

If you are a normal user of this web site and don't know what this page is about, this probably means that the site is currently unavailable due to maintenance. If the problem persists, please contact the site's administrator.
Configuration Overview

Debian's Apache2 default configuration is different from the upstream default configuration, and split into several files optimized for interaction with Debian tools. The configuration system is fully documented in /usr/share/doc/apache2/README.Debian.gz. Refer to this for the full documentation. Documentation for the web server itself can be found by accessing the manual if the apache2-doc package was installed on this server.

The configuration layout for an Apache2 web server installation on Debian systems is as follows:

/etc/apache2/
|-- apache2.conf
|       `--  ports.conf
|-- mods-enabled
|       |-- *.load
|       `-- *.conf
|-- conf-enabled
|       `-- *.conf
|-- sites-enabled
|       `-- *.conf
          

    apache2.conf is the main configuration file. It puts the pieces together by including all remaining configuration files when starting up the web server.
    ports.conf is always included from the main configuration file. It is used to determine the listening ports for incoming connections, and this file can be customized anytime.
    Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/ directories contain particular configuration snippets which manage modules, global configuration fragments, or virtual host configurations, respectively.
    They are activated by symlinking available configuration files from their respective *-available/ counterparts. These should be managed by using our helpers a2enmod, a2dismod, a2ensite, a2dissite, and a2enconf, a2disconf . See their respective man pages for detailed information.
    The binary is called apache2. Due to the use of environment variables, in the default configuration, apache2 needs to be started/stopped with /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not work with the default configuration.

Document Roots

By default, Debian does not allow access through the web browser to any file apart of those located in /var/www, public_html directories (when enabled) and /usr/share (for web applications). If your site is using a web document root located elsewhere (such as in /srv) you may need to whitelist your document root directory in /etc/apache2/apache2.conf.

The default Debian document root is /var/www/html. You can make your own virtual hosts under /var/www. This is different to previous releases which provides better security out of the box.
Reporting Problems

Please use the reportbug tool to report bugs in the Apache2 package with Debian. However, check existing bug reports before reporting a new bug.

Please report bugs specific to modules (such as PHP and others) to respective packages, not to the web server itself.
Tradotto con strumenti in rete ho notato che all'inizio dice di cambiare il file index.html ma come?
Grazie ancora
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)