SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Localhost, non riesco ad accedere
#21
per cambiare nome al file apri il gestore file da root:
Codice:
sudo nautilus
vai nella cartella /var/www/ clicchi con il pulsante destro del mouse e scegli rinomina.
Io lo ho rinominato index-old.html.
prova poi a creare la cartella html all'interno della /var/www/
Codice:
sudo mkdir /var/www/html
e a copiarci dentro il file phpinfo.php
poi riprova con l'indirizzo "localhost/phpinfo.php"
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#22
(02-01-2015,21:13 )m3nhir Ha scritto: per cambiare nome al file apri il gestore file da root:

Codice:
sudo nautilus
vai nella cartella /var/www/ clicchi con il pulsante destro del mouse e scegli rinomina.
Io lo ho rinominato index-old.html.
prova poi a creare la cartella html all'interno della /var/www/

Codice:
sudo mkdir /var/www/html
e a copiarci dentro il file phpinfo.php
poi riprova con l'indirizzo "localhost/phpinfo.php"

Procedo con ordine: intanto la cartella /var/www/html esiste di suo dopo l'installazione di LAMP; se provo a rinominare il file index.html poi se apro localhost su firefox:
Codice:
Index of /
html/    Fri Jan 2 21:59:23 2015     4096 bytes

Files
index old.html    Fri Jan 2 18:23:50 2015     11104bytes
phpinfo.html    Fri Jan 2 19:19:23 2015     49bytes
phpinfo.php    Fri Jan 2 19:19:23 2015     49bytes
phpinfo.php~    Fri Jan 2 18:38:22 2015     20bytes
Index generated Fri Jan 2 20:59:42 2015 UTC
per quando riguarda da ultimo il file phpinfo.php lo avevo creato sia in /var/www che in /var/www/html ma da sempre lo stesso esito, si apre il file ...
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#23
Siccome ogni errore si scopre dal terminale ho provata a lanciare apache2 da lì, questo il risultato
Codice:
[Sat Jan 03 10:39:55.205314 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_LOCK_DIR} is not defined
[Sat Jan 03 10:39:55.205395 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_PID_FILE} is not defined
[Sat Jan 03 10:39:55.205414 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_RUN_USER} is not defined
[Sat Jan 03 10:39:55.205435 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_RUN_GROUP} is not defined
[Sat Jan 03 10:39:55.205513 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Sat Jan 03 10:39:55.210737 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Sat Jan 03 10:39:55.210872 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Sat Jan 03 10:39:55.210890 2015] [core:warn] [pid 6205] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
AH00526: Syntax error on line 43 of /etc/apache2/apache2.conf:
Invalid command 'Debian', perhaps misspelled or defined by a module not included in the server configuration
Secondo me qualcosa non va ma non so cosa; inoltre se provo a lanciare phpmyadmin o msql mi da "comando non valido".
Spero che queste informazioni siano utili per aiutarmi a risolvere il problema.
Grazie ancora
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#24
Se dopo aver rinominato il file "index.html" l'indirizzo "localhost" ti restituisce il contenuto della directory è ok.
Secondo me non è apache2 che crea problemi ma il php.
Controlla di avere installato correttamente tutto quello che serve.
Da terminale, per vedere i pacchetti installati:
Codice:
dpkg --get-selections | grep php
Ti posto di seguito il risultato sul mio pc, in modo da poter fare un raffronto:
Citazione:dpkg --get-selections | grep php
libapache2-mod-php5 install
php-gettext install
php5 install
php5-cli install
php5-common install
php5-gd install
php5-json install
php5-ldap install
php5-mcrypt install
php5-mysql install
php5-readline install
phpmyadmin install
zabbix-frontend-php install
prova anche a dare i permessi di esecuzione al file "phpinfo.php", anche se non credo risolva, non si sa mai.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#25
Questo invece il mio risultato:
Codice:
dpkg --get-selections | grep php
libapache2-mod-php5 install
php5 install
php5-cli install
php5-common install
php5-gd install
php5-json install
php5-mcrypt install
php5-mysql install
php5-readline install
phpmyadmin install
mancano tre pacchetti: php5-gettext e php5-ldap e zabbix-frontend-php, posso installare con
Codice:
sudo apt-get install php-gettext
;
Codice:
sudo apt-get install php5-ldap
e
Codice:
sudo apt-get install zabbix-frontend-php
o conviene da gestore pacchetti?
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#26
Controlla a cosa servono quei pacchetti prima di installarli (guarda la descrizione nel gestore pacchetti).
quello riguardante zabbix puoi escluderlo tranquillamente, è solo un'interfaccia grafica per zabbix, niente a che vedere con apache.
Nel caso siano pacchetti non necessari al corretto funzionamento di un web server, penso tu possa escluderli. prova invece a selezionare gli altri per una reinstallazione completa.

Edit: dimenticavo, a volte quando si salva un files nella directory di default di localhost, non sempre viene subito visto, se prima non riavvi apache.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#27
Li ho installati anche perché la descrizione dei primi due è in inglese e non capisco a cosa servono, l'ultimo (zabbix-frontend-php) l'installazione non è andata a buon fine anche se in gestore pacchetti risulta installato e non riesco a riavviarlo per via del fatto che apache2 non si riavvia; quindi il problema deve proprio essere apache2 secondo me.
Riporto, per completezza, l'errore nella disinstallazione di zabbix-frontend-php dal terminale:
Codice:
nicolo@nicolo-System-Product-Name:~$ sudo apt-get remove zabbix-frontend-php
[sudo] password for nicolo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  zabbix-frontend-php
0 aggiornati, 0 installati, 1 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 6395 kB di spazio su disco.
Continuare [S/n]? s
(Lettura del database... 250753 file e directory attualmente installati.)
Rimozione di zabbix-frontend-php...
* Restarting web server apache2                                         [fail]
* The apache2 configtest failed.
Output of config test was:
AH00526: Syntax error on line 43 of /etc/apache2/apache2.conf:
Invalid command 'It', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
invoke-rc.d: initscript apache2, action "restart" failed.
dpkg: errore nell'elaborare zabbix-frontend-php (--remove):
il sottoprocesso vecchio script di post-removal ha restituito lo stato di errore 1
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
        Si sono verificati degli errori nell'elaborazione:
zabbix-frontend-php
E: Sub-process /usr/bin/dpkg returned an error code (1)
Anche da gestore pacchetti e da Ubuntu Sofware center stesso risultato, non si disinstalla
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#28
Forse dipende dal fatto che apache è in esecuzione.
Riesci ad arrestare apache?
Codice:
sudo service apache2 stop
Ti posto i pacchetti relativi ad apache che ho installato. Verifica se corrispondono, ma aspetta ad installare.
Citazione:dpkg --get-selections | grep apache
apache2 install
apache2-bin install
apache2-data install
apache2-mpm-prefork install
libapache2-mod-auth-mysql install
libapache2-mod-php5 install
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#29
Al codice mi da:
Codice:
nicolo@nicolo-System-Product-Name:~$ sudo service apache2 stop
[sudo] password for nicolo:
* Stopping web server apache2                                                   *
nicolo@nicolo-System-Product-Name:~$
Non so se così apache2 sia fermo, resta il fatto che non riesco a rimuovere zabbix-frontend-php
per il resto sto verificando ...
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#30
Verifica effettuata, posto il risultato:
nicolo@nicolo-System-Product-Name:~$ dpkg --get-selections | grep apache
apache2 install
apache2-bin install
apache2-data install
apache2-utils install
libapache2-mod-php5 install
nicolo@nicolo-System-Product-Name:~$
mancano due pacchetti: apache2-mpm-prefork e libapache2-mod-auth-mysql li installo?
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)