SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Localhost, non riesco ad accedere
#41
(03-01-2015,20:40 )nicolo74 Ha scritto: Risolto il problema di disinstallazione (vedi qui), ho reinstallato lamp, php5 e phpmyadmin solo che mentre il comando dpkg --get-selections | grep php mi ha dato gli stessi pacchetti che hai elencato caro @m3nhir il comando dpkg --get-selections | grep apache mi da un pacchetto in meno: libapache2-mod-auth-mysql che non riesco ad installare per via del fatto che ha come dipendenza apache2.2 e non me lo fa installare.
Peraltro ho notato durante l'installazione che ho inserito i dati per mysql ma non mi ha chiesto dati per phpmyadmin, forse perché non ho rimosso la cartella /etc/phpmyadmin?
Adesso devo andare, ci si legge domani.
Grazie ancora per la pazienza, buona serata
per phpmyadmin penso proprio che sia per il fatto che erano rimasti i files di configurazione , la non richiesta di inserire un password.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#42
Buon giorno, resta il fatto che il file /localhost/phpinfo.php non apre le caratteristiche di phpmyadmin bensì il file di testo e questo anche laddove do tutti i permessi (con sudo chmod 777 /percorso_del_file), adesso provo per l'ennesima volta a disinstallare tutto ed eliminare le cartelle; vi faccio sapere.
Grazie
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#43
Niente di fatto, reinstallato apache2 (ma non apache2.2 e libapache2-mod-auth-mysql), php5 e tutto il resto, phpmyadmin (la cartella /etc/phpmyamdi non esisteva e pur non di meno non mi ha chiesto password per la configurazione di phpmyadmin, ho poi scoperto che esiste la cartella /usr/share/phpmyadmin); continua a non funzionare il file phpinfo.php.
Nel pomeriggio proverò a rimuovere le cartelle in /usr/share (ci sono mysql, php5, phpmydamin e apache2) rinominandole e poi rifacendo l'installazione; magari funziona altrimenti non so che pesci prendere.
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#44
hai provato a copiare il file phpinfo.php in /var/www/html/ ?
controlla il contenuto del file:
/etc/apache2/sites-enabled/000-default.conf
al suo interno viene descritta la directory di default per localhost.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#45
(04-01-2015,17:27 )m3nhir Ha scritto: hai provato a copiare il file phpinfo.php in /var/www/html/ ?
Fatto, stesso risultato l'indirizzo /localhost/html/phpinfo.php apre il file


[quote='m3nhir' pid='13852' dateline='1420388843']
controlla il contenuto del file:
Codice:
/etc/apache2/sites-enabled/000-default.conf
al suo interno viene descritta la directory di default per localhost.
[/quote]
Il contenuto del file è:
<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
la directory, per quando ho capitio, è /var/www/html
Qui mi fermo, sto cominciando a stancarmi con questo problema, non so come venirne a capo e nutro qualche dubbio sul fatto che ci riuscirò.
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#46
il file è identico al mio.
hai provato a digitare "localhost/phpmyadmin" ? cosa ti restituisce?
Non sapendo più cosa suggeriti proverei ad aprire l'indirizzo con un altro browser, nella speranza che questi problemi siano dati
da un problema di visualizzazione del browser.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#47
(04-01-2015,17:56 )m3nhir Ha scritto: il file è identico al mio.
hai provato a digitare "localhost/phpmyadmin" ? cosa ti restituisce?
Non sapendo più cosa suggeriti proverei ad aprire l'indirizzo con un altro browser, nella speranza che questi problemi siano dati
da un problema di visualizzazione del browser.
Fatto e su firefox mi da "spiacenti ..., su Croome mi da
Codice:
404 Not Found
The requested URL /phpmyadmin was not found on this server.
che poi è la stessa cosa; credo che il problema stia nel fatto che apache2 non si avvi o riavvi infatti i comandi
Codice:
sudo /etc/init.d/apache2 restart
e
Codice:
sudo /etc/init.d/apache2 start
mi danno errore come ho scritto prima ...
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#48
Sto resettanto apache e tutto il resto; stavo pensando di avviare una discussione dal titolo "installare server locale in ubuntu 12.04+1" spiegando la situazione, magari qualcuno sa come risolvere ...
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:
#49
Hai una partizione libera dove installare una versione pulita? magari ubuntu 14.04.
Dopo l'installazione standard installa LAMP, o i pacchetti separati, come meglio credi. cosi, se tutto funziona, potrai fare i riscontri con l'altra installazione e riuscire a capire quale sia la ragione del malfunzionamento.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#50
(04-01-2015,19:55 )m3nhir Ha scritto: Hai una partizione libera dove installare una versione pulita? magari ubuntu 14.04.
Dopo l'installazione standard installa LAMP, o i pacchetti separati, come meglio credi. cosi, se tutto funziona, potrai fare i riscontri con l'altra installazione e riuscire a capire quale sia la ragione del malfunzionamento.
Buona idea, era tempo che volevo installare Ubuntu 14.04, in una partizione se non ricordo male dovrei avere ancora Ubunt 13.04 che non uso (sono "bloccato" alla 12.04 per via di un dispositivo di firma digitale che non funziona su versioni successive e su sistemi a 64bit); magari prima vedo su quale partizione è installato, tolgo tutto e poi installo 14.04 plus che peraltro ho già su pen drive e che uso per accessi live (non posso provare lamp da lì perché dopo l'installazione dovrei riavviare il che significa perdere tutto).
Ci lavorerò domani in serata, adesso devo completare un lavoro; ciao e grazie ancora di tutto.
P.S. lascio aperta la discussione, hai visto mai qualcuno ha la soluzione ...
Heart  Una petizione per il prof. Cantaro

Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Affettuosamente Buona Vita Heart
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: