Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Lubuntu 18.04 LXQt 64 bit: il WIFi non funziona.
#1
Salve a tutti.
Volendo installare Lubuntu 18.04 LXQt 64 bit LTS su un vecchio PC (quindi ante UEFI) dotato dell'hardware seguente
Codice:
lubuntu18q04@AthlonX2:~$ inxi -v4
System:    Host: AthlonX2 Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0 Desktop: LXQt
          Distro: Ubuntu 18.04 LTS
Machine:   Device: desktop Mobo: N/A model: ALiveNF6G-VSTA serial: N/A
          BIOS: American Megatrends v: P1.60 date: 06/12/2007
CPU:       Dual core AMD Athlon 64 X2 4000+ (-MCP-) arch: K8 rev.F+ cache: 1024 KB
          flags: (lm nx sse sse2 sse3 svm) bmips: 7232
          clock speeds: max: 2100 MHz 1: 1800 MHz 2: 1800 MHz
Graphics:  Card: NVIDIA C61 [GeForce 6150SE nForce 430] bus-ID: 00:0d.0
          Display Server: x11 (X.Org 1.19.6 )
          drivers: nouveau (unloaded: modesetting,fbdev,vesa)
          Resolution: 1024x768@60.00hz
          OpenGL: renderer: NV4C version: 2.1 Mesa 18.0.0-rc5 Direct Render: Yes
Network:   Card-1: NVIDIA MCP61 Ethernet driver: forcedeth port: e480 bus-ID: 00:07.0
          IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: 00:19:66:30:48:b2
          Card-2: D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink RT3072]
          driver: rt2800usb v: 2.3.0 usb-ID: 001-003
          IF: wlxf07d686f9f7e state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (1.4% used)
          ID-1: /dev/sda model: ST3500418AS size: 500.1GB
Partition: ID-1: / size: 20G used: 5.1G (28%) fs: ext4 dev: /dev/sda7
          ID-2: swap-1 size: 1.60GB used: 0.00GB (0%) fs: swap dev: /dev/sda16
Info:      Processes: 147 Uptime: 31 min Memory: 900.3/2875.6MB
          Init: systemd runlevel: 5 Gcc sys: 7.3.0 Client: Shell (bash 4.4.191) inxi: 2.3.56
lubuntu18q04@AthlonX2:~$

ho scaricato la mini.iso da qui
http://archive.ubuntu.com/ubuntu/dists/b...es/netboot
ed ho seguito sommariamente questa guida:
http://www.istitutomajorana.it/scarica2/...ntu_v1.pdf
Dico "sommariamente" perché, pur avendo l'intenzione di seguirla puntigliosamente, io ho preferito avviare la mini.iso tramite GRUB2 previo modifica del boot menù (ho aggiunto le righe
Codice:
menuentry "ubuntu-mini.iso-18.04-amd64.iso (/dev/sd_UUID E010C41510C3F098)" {
     set root=UUID=E010C41510C3F098
     search --no-floppy --fs-uuid --set=root E010C41510C3F098
     set isofile="/iso2/Ubuntu/mini.iso"
     loopback loop $isofile
     linux (loop)/linux  -- quiet
     initrd (loop)/initrd.gz
}
al file 40_custom ed ho aggiornato il menù di GRUB2), ed ho installato l'ambiente grafico LXQt, cose che in quella guida non sono spiegate.

In pratica, al fine di adattare la guida alle mie esigenze, mi sono scostato da essa solo nei casi seguenti:
A) Anziché preparare un CD di installazione come spiegato a pag. 5 della guida, ho avviato direttamente da GRUB2 la mini.iso da me depositata nella cartella /iso2/Ubuntu/ della partizione avente UUID=E010C41510C3F098
B) Arrivato il momento di impostare Internet, anziché affidarmi alla rete ethernet come descritto a pag.8 della guida, ho configurato la connessione WiFi, che ha funzionato correttamente per tutta la durata dell'installazione.
C) Per quanto concerne il partizionamento del disco fisso, arrivato alla pag. 11 della guida ho selezionato il partizionamento MANUALE, ed ho proceduto di conseguenza
D) Arrivato al punto in cui l'installer chiede quale altro software installare (pag. 16 della guida), visto che la guida non affrontava il caso specifico dell'installazione di Lubuntu LXQt, ho selezionato le voci relative all'installazione di "Lubuntu Qt desktop" ed ho portato a termine l'installazione.
E) Le istruzioni della guida, da pag. 18 in poi, non si applicano a Lubuntu LXQt; io quindi ho spento il pc ed ho proceduto come segue:

1) Avvio il PC, al menù di Grub2 seleziono Ubuntu.
2) Al LOGIN, tramite un menù a tendina, seleziono l'ambiente grafico [LXqt desktop] ed inserisco la password.
3) All'avvio della sessione di lavoro, lo schermo è completamente nero, ed io subito penso ad un problema con la scheda grafica, ma non è così. Se si clicca col tasto destro sullo schermo nero, compare un menù. dal quale è possibile selezionare che questo menù venga sostituito con quello di OpenBox; lo seleziono, così ora, tramite il menù di OpenBox (in inglese) posso accedere a tutti i programmi, ma l'aspetto del desktop non è certo quello di Lubuntu LXqt.
4) Dal menù di OpenBox seleziono
[Applications] > [Settings] > [LXQt configuration center] e, dal pannello che si apre, seleziono [Scrivania]; qui, nella sezione [Generale], imposto lo sfondo azzurro.
Ora distinguo chiaramente lo sfondo del desktop di colore azzurro e completamente vuoto.
A quanto pare, il pannello principale è rimasto completamente nero e vuoto.
5) Mi rendo conto che il browser web preinstallato è Falkon; siccome non ci sono abituato, apro Synaptic e tento di installare FireFox ma non ci riesco: la connessione WiFi, che ha funzionato benissimo durante tutta la procedura di installazione, non funziona. Pongo in essere una connessione ad internet via Cavo Ethernet, ed installo FireFox; già che ci sono, installo anche inxi.
6) Dal menù di OpenBox seleziono
[Applications] > [Settings] > [LXQt configuration center] e, dal pannello che si apre, seleziono [Aspetto]; qui, nella sezione [Tema di LXQt], imposto il tema [Light].
Ora il pannello principale è chiaramente visibile, ma inesorabilmente vuoto.
7) Clicco sul pannello principale col tasto destro del mouse e, dal menù che si apre, seleziono [Configura pannello]
Nella sezione [Elementi] clicco su [+] per attivare la modalità "Aggiungi elemento", ed aggiungo: (mainmenu)+(desktopswitch)+(quicklaunch)+(taskbar)+(tray)+(statusnotifier)+(mount)+(volume)+(worldclock)+(showdwsktop)
8 ) Dopo aver chiuso [Configura pannello], è possibile trascinare sull'area di avvio rapido le icone del menù a tendina. Ne approfitto per inserire in quest'area le icone del file-manager, del browser web, del terminale, e del text editor

Ora Lubuntu 18.04 LXQt 64 bit LTS ha un aspetto decente, ma la connessione ad Internet è possibile solo via cavo. Se scollego il cavo, l'icona della connessione cambia aspetto; cliccandoci sopra, posso selezionare le reti WiFi disponibili, ed inserire la password. Compare un messaggio che dice che la connessione è stabilita, ma comunque non riesco a navigare.
Come risolvo?
Linux: PCLinuxOS + OpenSUSE + Ubuntu + Linux Mint + Fedora
Smartphone: Alcatel PIXI4 +tablet AMTC MD7305 (Android 4.1) +tablet SurfTab® wintron 7.0 (Windows™ 10©)
http://sargonsei.altervista.org/hardware...r-fisso-2/
Cita messaggio
Grazie da:
#2
Codice:
Network:   Card-1: NVIDIA MCP61 Ethernet driver: forcedeth port: e480 bus-ID: 00:07.0
          IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: 00:19:66:30:48:b2
          Card-2: D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink RT3072]
          driver: rt2800usb v: 2.3.0 usb-ID: 001-003
          IF: wlxf07d686f9f7e state: N/A speed: N/A duplex: N/A mac: N/A
Sei sicuro di avere il wifi sul portatile? Da qui non sembra.

Codice:
iwconfig
cosa dice?
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....

PCLinuxOS Mate - Manjaro Mate/Xfce - Uplos32 Mate/Trinity - Kali Linux Mate64
Cita messaggio
Grazie da:
#3
Citazione:Card-2: D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink RT3072]
driver: rt2800usb v: 2.3.0 usb-ID: 001-003
Se non erro è una chiavetta wifi collegata via usb.
Prova a verificare sul sito del produttore se ci sono dei driver per linux.
non so se faccia al caso tuo ma se vuoi dare un'occhiata QUI hanno risolto, al post #32
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#4
Vero è una chiavetta wifi Sleepy , non l'avevo considerata, perchè è strano come possa aver funzionato durante l'installazione.
Normalmente un dispositivo usb esteno difficilmente funziona da solo, se non altro perchè occorre almeno la prima volta inserire una password per accedere alla rete.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....

PCLinuxOS Mate - Manjaro Mate/Xfce - Uplos32 Mate/Trinity - Kali Linux Mate64
Cita messaggio
Grazie da:
#5
Quello che mi lascia perplesso è il fatto che durante l'installazione ha funzionato ed ora no. Se i driver o qunt'altro necessitava al suo funzionamento c'era perchè ora non è presente? Strano che non sia stato caricato. Farei un tentativo cercando nei repo se ci sono driver disponibili.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#6
La WiFi USB  D-Link modello DWA-140 è chiaramente indicata alla voce Card-2 della sezione Network dell'output di inxi....
E poi non si tratta di un portatile, ma di un PC fisso...
Sicuramente occorre almeno la prima volta inserire una password per accedere alla rete, ed è quello che ho fatto in fase di installazione.
in ogni caso, ecco l'output richiesto.
Codice:
lubuntu18q04@AthlonX2:~$ iwconfig
enp0s7    no wireless extensions.

lo        no wireless extensions.

wlxf07d686f9f7e  IEEE 802.11  ESSID:"TP-LINK_2.4GHz_928511"  
         Mode:Managed  Frequency:2.472 GHz  Access Point: 30:B5:C2:92:85:11  
         Bit Rate=144.4 Mb/s   Tx-Power=20 dBm  
         Retry short  long limit:2   RTS thr:off   Fragment thr:off
         Power Management:on
         Link Quality=70/70  Signal level=-31 dBm  
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:59   Missed beacon:0

lubuntu18q04@AthlonX2:~$
ed aggiungo
Codice:
lubuntu18q04@AthlonX2:~$ lsusb|grep -i adapter
Bus 001 Device 003: ID 07d1:3c0a D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink RT3072]
lubuntu18q04@AthlonX2:~
Non può essere un problema di driver, perchè durante l'installazione il WiFi ha funzionato senza problemi.
Forse è un problema di Connman.
Non riesco a capire come configurarlo.
Se clicco col tasto destro sull'icona del gestore della connessione, compare un pannello con la voce "Edit Connections", ma questa voce è impossibile da selezionare: se ci clicco sopra, non succede nulla.
Linux: PCLinuxOS + OpenSUSE + Ubuntu + Linux Mint + Fedora
Smartphone: Alcatel PIXI4 +tablet AMTC MD7305 (Android 4.1) +tablet SurfTab® wintron 7.0 (Windows™ 10©)
http://sargonsei.altervista.org/hardware...r-fisso-2/
Cita messaggio
Grazie da:
#7
Prova a vedere (questo post ultimo intervento).
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....

PCLinuxOS Mate - Manjaro Mate/Xfce - Uplos32 Mate/Trinity - Kali Linux Mate64
Cita messaggio
Grazie da:
#8
(02-05-2018,06:29 )D-BARTO Ha scritto: Prova a vedere (questo post ultimo intervento).
nulla da fare. ho provato sia sostituendo
Codice:
[device]
wifi.scan-rand-mac-address=no
con
Codice:
[device]
wifi.scan-rand-mac-address=0
sia AGGIUNGENDO le ultime 2 rigne, ottenendo qualcosa tipo questo:
Codice:
lubuntu18q04@AthlonX2:~$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

[device]
wifi.scan-rand-mac-address=0
lubuntu18q04@AthlonX2:~$
Qpengo e riaccendo il PC, tento di connettermi via WiFi, ma nulla da fare: internet non va.
Linux: PCLinuxOS + OpenSUSE + Ubuntu + Linux Mint + Fedora
Smartphone: Alcatel PIXI4 +tablet AMTC MD7305 (Android 4.1) +tablet SurfTab® wintron 7.0 (Windows™ 10©)
http://sargonsei.altervista.org/hardware...r-fisso-2/
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)