Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Ndiswrapper e driver netgear wna 3100 usb
#1
Buongiorno eccomi al problema,installo da synaptic ndiswrapper per poter configurare la rete wireless alla chiavetta usb della netgear la WNA 3100,come saprete bisogna installare ndiswrapper in modo che legga il driver windows della chiavetta,operazione che avevo già fatto con successo in linux extremamint(mate)su pclos mate invece quando gli faccio leggere il driver mi comunica che non trova ndiswrapper come se non fosse installato ma il l'ho intallato invece,al momento uso il kernel 4.4.8 se può esser utile.
Buona giornata.
Cita messaggio
Grazie da:
#2
posso solo dirti di controllare se è installato:
dkms-ndiswrapper
Cita messaggio
Grazie da:
#3
mai usato, prova a vedere questa

http://pclosmag.com/html/issues/200712/page03.html
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#4
Grazie DX,si provato anche installando dkms ma sempre la stessa risposta,grazie tuxino ora controllo.
Ciao
Cita messaggio
Grazie da:
#5
Ora premetto che io e l'inglese non andiamo d'accordo però per prima cosa ho reinstallato ndiswrapper poi da terminale ho digitato ndiswrapper -v e mi dice comando ndiswrapper non trovato mentre a mio avviso dovrebbe restituirmi la versione installata o sbaglio?
Cita messaggio
Grazie da:
#6
Citazione:[palla@localhost ~]$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/4.4.10-pclos1/kernel/3rdparty/ndiswrapper/ndiswrapper.ko
version: 1.59
vermagic: 4.4.10-pclos1 SMP mod_unload
[palla@localhost ~]$
questo è quello che mi restituisce. io non lo uso ma lui è installato. hai installato dkms-ndiswrapper e fatto un riavvio del sistema?
Cita messaggio
Grazie da:
#7
Si certo fatte tutte e due le cose può essere che ho il kernel 4.4.06 e 4.4.08?
Cita messaggio
Grazie da:
#8
non lo so. io ho 4.4.10, prova.
Cita messaggio
Grazie da:
#9
Nisba,aggiornato alla 10 ma rimanda sempre comando non trovato sarà colpa dell'hd che è un ssd?non sò cosa pensare.potrei provare a disinstallare e ho scaricat l'ultima versione di ndiswrapper scompattando il file compresso in ...usr\src come faccio aprendo il terminale in src ad installare ndiswrapper?si potrebbe provare così e vedere che succede!
Cita messaggio
Grazie da:
#10
........Intanto cerco di cavarmela un pò da solo,ho disinstallato la versione di synaptic e scompattato il file compresso di ndiwrapper versione 1.6(rispetto a quella di synaptic che è la 1.59)copiato e incollato la cartella scompattata in usr/src poi aperta la cartella ndiswrapper e al suo inyerno aperto terminale come amministratore ho provato l'installazione ma dopo che sembrava andare tutto ok ecco l'errore che riporto.

Codice:
[root@localhost ndiswrapper-1.60]# make install
make -C driver install
make[1]: ingresso nella directory "/usr/src/ndiswrapper-1.60/driver"
make modules
make[2]: ingresso nella directory "/usr/src/ndiswrapper-1.60/driver"
make -C /usr/src/kernel-devel-4.4.10-pclos1 M=/usr/src/ndiswrapper-1.60/driver
make[3]: ingresso nella directory "/usr/src/kernel-devel-4.4.10-pclos1"
  LD      /usr/src/ndiswrapper-1.60/driver/built-in.o
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/crt_exports.h
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/hal_exports.h
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/ndis_exports.h
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/ntoskernel_exports.h
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/ntoskernel_io_exports.h
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/rtl_exports.h
  MKEXPORT /usr/src/ndiswrapper-1.60/driver/usb_exports.h
  MKSTUBS /usr/src/ndiswrapper-1.60/driver/win2lin_stubs.h
  CC [M]  /usr/src/ndiswrapper-1.60/driver/crt.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/hal.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/iw_ndis.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/loader.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/ndis.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/ntoskernel.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/ntoskernel_io.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/pe_linker.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/pnp.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/proc.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/rtl.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/wrapmem.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/wrapndis.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/wrapper.o
  CC [M]  /usr/src/ndiswrapper-1.60/driver/usb.o
  AS [M]  /usr/src/ndiswrapper-1.60/driver/win2lin_stubs.o
  AS [M]  /usr/src/ndiswrapper-1.60/driver/lin2win.o
  LD [M]  /usr/src/ndiswrapper-1.60/driver/ndiswrapper.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /usr/src/ndiswrapper-1.60/driver/ndiswrapper.mod.o
  LD [M]  /usr/src/ndiswrapper-1.60/driver/ndiswrapper.ko
make[3]: uscita dalla directory "/usr/src/kernel-devel-4.4.10-pclos1"
make[2]: uscita dalla directory "/usr/src/ndiswrapper-1.60/driver"
mkdir -p -m 755 /lib/modules/4.4.10-pclos1/misc
install -m 0644 ndiswrapper.ko /lib/modules/4.4.10-pclos1/misc
/sbin/depmod -a 4.4.10-pclos1
make[1]: uscita dalla directory "/usr/src/ndiswrapper-1.60/driver"
make -C utils install
make[1]: ingresso nella directory "/usr/src/ndiswrapper-1.60/utils"
gcc -g -Wall -I../driver  -o loadndisdriver loadndisdriver.c
In file included from loadndisdriver.c:37:0:
../driver/loader.h:19:40: error: Manca l'operatore binario prima del token "("
#if LINUX_VERSION_CODE > KERNEL_VERSION(4,0,0)
                                        ^
Makefile:16: set di istruzioni per l'obiettivo "loadndisdriver" non riuscito
make[1]: *** [loadndisdriver] Errore 1
make[1]: uscita dalla directory "/usr/src/ndiswrapper-1.60/utils"
Makefile:27: set di istruzioni per l'obiettivo "install" non riuscito
make: *** [install] Errore 2
[root@localhost ndiswrapper-1.60]#
Saluti
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)