SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Non Risolto] - PcLinuxOs-KDE - errori dopo aggiornamento e xserver
#11
si. installa pclinuxos una delle ultime immagini. arrivato a dove/come installare l'avvio, a sx scegli annulla. continua in questo modo senza installare nessun bootloader. al termine, riavvia. ora avvia la distribuzione che gestisce il grub. da quella distribuzione aggiorna il grub >>>> update-grub dato come amministratore. riavviando troverai pclinuxos come scelta nel tuo grub.
in parole semplici, grub è quel programma che trova i vari sistemi operativi per avviarli. tu usi quello di buntu, quello di pclos non ti serve.
però e c'è sempre un però..... avendo tu annullato l'installazione di pclos alla pagina del grub lui non si avvierà. ti darà un kernel panic!!
non demordere, avvia supergrubdisk, tu lo hai se ben ricordo. avvierai quanto hai installato. ora da configura il computer di pclos, system/utenti sistema, crea il tuo utente ( verifica di avere i permessi 500 ). elimina l'utente guest. direi che abbiamo terminato. aggiorna ora il tuo pclos, fallo parlare in italiano, ecc.ecc. verifica di aver installato sddm, quello sarà il tuo gestore grafico ( sempre da configura il computer, avvio, gestore impostazioni grafiche )riavvia.
ti ricordo che la pswd di amministratore sarà >>> root. cambiarla sarà molto semplice, lasciamolo alla fine.
Cita messaggio
Grazie da:
#12
Mario,
prima di fare come suggerisci, vorrei capire se installando pclos su altro hdd (sdb) es. nella partizione sdb2, installando poi il bootloader su sdb, poi lo vedrò dal grub di ubuntu messo su sda, ovviamente updatando il grub.
nel post precedente al tuo, volevo capire se pur installando il bootloader di pclos su sdb, potevo comunque accedere alla partizione dati in sdb3 senza problemi
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#13
si, puoi tranquillamente installare e mettere l'avvio sul disco sdb, tanto verrà usato quello sul disco principale, se non erro 16.04. alla partizione accederai sempre e comunque con qualsiasi distribuzione.
se la partizione dati viene creata dopo l'installazione del sistema ( qualsiasi sistema ) bisognerà dare i giusti permessi ma questo è un altro discorso.
Cita messaggio
Grazie da:
#14
Aggiornamento:
ho installato pclos 5 kde desktop su partizione dedicata (sdc5) e installato il bootloader in sdc.
avvio il pc e al grub di ubuntu 16.04 scelgo ubuntu 16.04.
a sistema avviato, apro il terminale e faccio un bel  "sudo upgrade-grub"
compare tra gli altri, anche pclinuxos kde.
chiudo terminale e riavvio, scegliendo PcLinuxOs sul grub,  parte il caricamento, con lo sfondo bellissimo e poi . . . .  si blocca al momento di caricare l'interfaccia grafica.
I messaggi sono gli stessi di prima, che riporto per completezza di info:
   
   
   
   

Evidenzio che è la seconda installazione fatta e sempre con le stesse risposte ( ma la mia scheda grafica GTS450 nvidia, con gli altri 4 sistemi operativi va come un razzo)
Aggiungo di aver avviato pclos in recovery mode, ma non ho trovato come risolvere, ovviamente per mia incapacità.
Attendo lumi.
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#15
facciamo un breve riepilogo.
tu hai installato pclos, nelle modalità elencate per l'avvio. bene.
al primo avvio hai quei problemi postati. ricordati che tu non hai ancora creato nessun utente apanta o altro nome quindi non metterlo al login altrimenti ti dirà >>>incorrect
vediamo come procedere. avvia dal grub di 16.04 pclos in recovery, arrivato a sh-4.4#scrivi:
Citazione:init 3
invio. ti si aprirà la tty e ti richiederà le credenziali. saranno root per l'utente e root per la pswd. invio.
nella nuova riga che ti appare dopo il # scrivi:
Citazione:apt-get update
invio ed al termine:
Citazione:apt-get dist-upgrade
invio. ti chiederà se continuare, rispodi s , lascialo lavorare. aggiornerà installerà ecc.ecc. una volta terminato, installa un kernel tra questi:
  • kernel-5.0.9-pclos1
  • kernel-4.19.34-pclos1
  • kernel-4.9.168-pclos1
  • kernel-4.4.178-pclos1
scrivendo dopo il #:
apt-get install kernel-numero che vuoi tu tra quelli elencati sopra. al termine >>> reboot per avviare. dovrai necessariamente passare da 16.04 per aggiornare il grub altrimenti non vedrà il nuovo kernel installato.
ora avvia pclos utilizzando il nuovo kernel installato. io spero che tutto si avvii ma potrebbe anche non essere. nel caso peggiore, quello dove ti appaiono le finestre grige di xserver, dobbiamo smanettare ancora un pochino ma non è complicato. è più complicato scriverlo che farlo.
il comando startx io lo lascierei alle distribuzioni di altri. pclos ha un suo programma dedicato.
per adesso direi che va bene cosi, io intanto preparo lo specchietto per cosa fare se....... anche se io sono ottimista.
questo per cosa fare nella malaugurata ipotesi.....
procedi come prima ed arriva alla tty. loggati ( ricordati che sei root di nome e di pswd ). dopo il #
  • apt-get remove dkms-nvidia*
  • apt-get remove x11-driver-video-nvidia-current
  • apt-get remove x11-driver-video-nvidia340
  • apt-get remove x11-driver-video-nvidia390
  • rm -rf /etc/nvidia*
  • rm -f /etc/alternatives/*nvidia*
  • rm -f /etc/alternatives/gl_conf
  • rm -f /etc/alternatives/display-driver.conf
  • rm -f /etc/alternatives/xorg_extra_modules
  • rm -rf /var/lib/dkms/nvidia*
ogni riga è un comando, dovrà seguire invio.
al termine del "purgamento" digita dopo il #:
Citazione:XFdrake --auto
invio. presta attenzione alla XF devono essere maiuscole. XFdrake è il programma per riconfigurare la grafica in pclos.
al termine, reboot per riavviare.
questi passaggi li ho copiati pari pari da un post di Tex su pc:
https://www.pclinuxos.com/forum/index.ph...msg1269767
Cita messaggio
Grazie da:
#16
Eccomi.
ho seguito le tue indicazioni, ma dopo il prompt sh-4.4# dando il comando
Codice PHP:
init 3 
non succede nulla e non compare una richiesta di accesso con credenziali di root.
Ho riavviato in recovery mode come in precedenza e al prompt sh-4.4#, ho digitato "root" e poi data la password "root",
quindi ho dato un
Codice PHP:
apt-get update 
e la risposta è stato un elenco di fail to fetch (errore nello scaricamento), per tutte le voci elencate.
ho ridato il comando per tre volte e per tre volte mi ha elencato il mancato scaricamento.
ho comunque dato, dopo, il comando:
Codice PHP:
apt-get dist-upgrade 
e ha cominciato a lavorare come se dovesse installare qualcosa, fino a quando è comparsa la videata dove chiedeva di dare un "yes" o un "No" ; ho dato Y ed ha proseguito per un pò, poi si è fermato al prompt.
A questo punto ho cercato di installare uno dei kernel da te suggeriti, dando il comando:
Codice PHP:
apt-get install kernel-5.0.9-pclos1 
ma mi dice che non trova il kernel.
la stessa risposta pure per gli altri kernel.
stavo per lasciare ma ho voluto fare un ultimo tentativo.
avvio in recovery mode e al prompt digito:
Codice PHP:
startx 
ci mette mezzo secolo, ma alla fine mi compare il desktop, con una mezza finestra di interfaccia dove per prima cosa ho scelto la località che era scritta dando un Oh e poi alla successiva schermata digito il mio nome utente e la password, per creare, evidentemente, un utente.
a questo punto si carica il sistema.
Vado in synaptic e tento di aggiornare, ma si blocca dopo qualche secondo.
Insisto per 5 o 6 volte ed alla fine parte un aggiornamento che dura circa 20 minuti.
Finito, clicco ancora su "marca gli aggiornamenti", ma non carica più alcun file.
Poichè l'icona in basso a sinistra sul pannello non era attiva, ho aperto un terminale sul desktop e dato un "reboot".
Ho aggiornato, comunque, il grub da ubuntu e poi avviato PcLinuxOs in modo normale.
Stavolta si avvia e compare la finestra di dialogo col mio nome utente. Accedo e vado a ricontrollare glim aggiornamenti, facendo ancora una decina di minuti di lavoro.
poi torna tutto tranquillo.
Provo ad installare il kernel e ci riesco:
   
   
Ho quindi cercato di avviare "nVidia Display Settings", ma il lanciatore parte e si stoppa dopo qualche secondo;  Lo stesso anche da terminale.
   
Verifico su synaptic e installo il driver 390 che è quello in uso e raccomandato da nVida su tutiie e quattro gli altri sistemi operativi installati.
riavvio ma non carica il driver in questione.
Difatti da terminale mi segnala:
   
La scheda video c'è ed è funzionante:
   
A questo punto come faccio a fargli cambiare il driver ed usare quello proprietario?

Ci sono altre cosa, ma aprirò una discussione apposita.
Grazie per la pazienza.
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#17
in configura computer, hardware, configura grafica. dovresti avere impostato quello che dovrebbe. prova a metterne un altro e poi ritorna subito a quello di prima. continua chiudendo tutto. dovrebbe segnalarti la presenza di un driver proprietario, digli di si.
Cita messaggio
Grazie da:
#18
Ciao Mario.
Non c'è che dire, abbiamo proprio una nutrita corrispondenza epistolare  Cool  Sfascio  Cool  Sfascio
Premetto che ero già andato in Configure---hardware---configura sistema grafico, scegliendo la scheda nvidia GEForce 420 to GEForce 630 e poi spuntando l'opzione abilita interfaccia grafica xorg-nvidia

Ho ripetuto comunque le operazioni e poi seguito le istruzioni per la scelta del driver proprietario.
Alla fine compare il messaggio che occorre un riavvio per completare la scelta.
Riavvio il s.o. e compare:

.png   tmp1.png (Dimensione: 130,71 KB / Download: 41)
armato col coraggio della disperazione, riavvio e stavolta compare:
   
mi loggo come root e poi do il comando che tu mi avevi detto di evitare, ma non ne conosco altri:
Codice PHP:
startx 
vedo schermata di avvio per uno o due secondi e poi compare:
   
Clicco su Ok e parte la videata di login grafico, inserisco utente e password e accedo al sistema operativo, che sembra funzionare regolarmente, se non fosse per qualche scatto nell'apertura e chiusura delle finestre o dei menu.

Sto quindi usando i driver nouveau pur essendo installati i driver nvidia proprietari che ho pure disinstallato e reinstallato da synaptic.
A questo punto, onestamente, non so se lasciare tutto così com'è o piallare e reinstallare, ma diventa proprio pesante.

Tra le altre cose, pur avendo installato in passato i driver per la mia multifunzione WF-2520, adesso usando rpm-installer e con i pacchetti scaricati direttamente dal sito Epson, parte l'installazione e poi compare un avviso che il pacchetto non è stato trovato (sia per la stampante, sia per lo scanner).  ovviamente ho scaricato nuovamente i driver, con lo stesso risultato: Nisba.-
Ma per questo problema aprirò un'altra discussione.

Ho anche fatto una googolata e letto che il problema kde-nvidia, si trascina da anni ( ho letto pure una discussione sul forum pclos, in cui Zafran affermava di "essere uscito dal convento in cui si era ritirato", per dare una info che non ricordo più.
che idea ti sei fatto?.
grazie comunque At

edit:
provando ad installare i driver nvidia da terminale mi da:
Codice PHP:
[apanta@localhost ~]$ apt install nvidia-driver-390
bash
aptcomando non trovato
[apanta@localhost ~]$ apt-get  install nvidia-driver-390
E
Unable to write to /var/cache/apt/
ENon è stato possibile aprire la lista di pacchetti o il file di status.
[
apanta@localhost ~]$ su
[root@localhost apanta]# apt-get install nvidia-driver-390
Lettura della lista di pacchetti... Done
Calcolo dell
'albero delle dipendenze... Done
E: Il pacchetto nvidia-driver-390 non è stato trovato
[root@localhost apanta]# 

Ho pure rimosso synaptic e reinstallato da terminale, ma niente.
inoltre ho provato a installare il server nvidia:
Codice PHP:
apt-get install nvidia-glx nvidia-settings linux-headers-VERSIONE_KERNEL 
ma niente.
Non trova alcun file.
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#19
inxi -G cosa dice? ti posto il mio:
Codice:
[mario@mario ~]$ inxi -G
Graphics:  Device-1: NVIDIA GF106 [GeForce GT 440] driver: nouveau v: kernel
           Display: server: X.Org 1.20.4 driver: nouveau,v4l tty: N/A
           OpenGL: renderer: NVC3 v: 4.3 Mesa 19.0.3
io ho la tua stessa scheda nvidia, non ho installato quanto hai tu. io ho solamente:

Citazione:dkms-nvidia-current
x11-driver-video-nvidia-current
tutto mi funziona senza problemi. provai ad impostare i nvidia390 ma con il nuovo xorg non servono >>>>
https://www.pclinuxos.com/xorg-1-20-4-an...ia-418-56/
quei comandi che hai dato non esistono oppure non sono corretti. come ti ho detto con il nuovo xorg molto è cambiato.

due consigli:
se avvii da recovery, quando lui ha terminato, scrivendo >>> exit si dovrebbe riavviare. questo serve quando non carica in automatico eventuali nuovi driver.

startx come ti ho detto lascialo. al suo posto nella stessa modalità ( devi quindi essere amministratore ), scrivi:
Citazione:XFdrake
invio. ti apparirà una finestra, con le freccette, tab, enter, muoviti nella parte superiore e se hai problemi seleziona la grafica:
Citazione:other vesa
conferma ecc. quindi reboot. avvierai con i driver generici.
Cita messaggio
Grazie da:
#20
Eccolo:
Codice PHP:
[apanta@localhost ~]$ inxi -G
Graphics
 Device-1NVIDIA C77 [GeForce 8200driverN/
          Device
-2NVIDIA GF106 [GeForce GTS 450drivernouveau vkernel 
          Display
serverX.Org 1.20.4 drivernouveau,v4l resolution1280x1024~60Hz 
          OpenGL
rendererNVC3 v4.3 Mesa 19.0.3 
[apanta@localhost ~]$ 

I comandi li ho trovati in una discussione relativa a stessi problemi su pclos.
Avevo scritto nel post precedente che ora si avvia e compare la schermata di login
La novità è che cliccando su "Spegni", parte il caricamento del comando, ma rimane bloccato sulla schermata in corso. e devo arrestare premendo il pulsante di alimentazione del pc.

Proverò ad installare il driver 418, anche se su synaptic mi dice che il 418 vale per altro tipo di scheda.
Citazione:NVIDIA kernel module for GeForce 635 and later cards
NVIDIA kernel module for GeForce 635 and later cards. This
is to be used with the x11-driver-video-nvidia-current package.

Citazione:NVIDIA proprietary X.org graphics driver, related libraries and
configuration tools for GeForce 635 and later cards,
including the associated Quadro cards.

NOTE: You should use XFdrake to configure your NVIDIA card. The
correct packages will be automatically installed and configured.

If you do not want to use XFdrake, see README.manual-setup.

This NVIDIA driver should be used with GeForce 635 and later cards,
including the associated Quadro cards.
Provo e ti faccio sapere.

edit:
riprovato in tutte le salse. non ho risolto.
lascio stare tutto; ne riparliamo tra qualche tempo, forse.
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: