SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Non c'è il boot di ubuntu
#31
ecco la schermata


Allegati Anteprime
   
Cita messaggio
Grazie da:
#32
supergrubdisk "vede" la partizione win e riesce ad avviarla? se sì, è solo questione di farla "vedere" anche a grub.
Vogliamo continuare con spirito di condivisione quanto ci ha insegnato il Prof Antonio...
Ci trovate qui:
https://www.ergosumracalmuto.org/informa...era/forum/

[Immagine: https://www.ergosumracalmuto.org/informa...o_Mary.png]
Cita messaggio
Grazie da:
#33
Grazie della risposta. Supergrub vede windows però non lo avvia, da l'errore EFI. In effetti io non ho fatto una partizione in fat 32 per il boot di win.
Cita messaggio
Grazie da:
#34
ma hai un partizionamento gpt-efi? e perché allora hai inserito una partizione logica e non l'hai fatta primaria (puoi farne fino a 128 con il partizionamento gpt)?
in ogni caso, se hai un partizionamento gpt-efi, condivido la tua osservazione che va creata la partizione efi all'inizio del disco (min 100mb, meglio 250/300mb); potresti provare a creare lo spazio all'inizio del disco riducendo la partizione win e poi provare ad aggiustare l'avvio con il dvd di win; oppure elimini la partizione di win, rifai le due partizioni e reinstalli win (non so cosa sia più veloce, installare win o aspettare che il programma di partizionamento sposti pazientemente a destra i dati della partizione win da ridurre). in entrambi i casi, poi dovrai riutilizzare supergrubdisk per ripristinare grub.

EDIT: ho controllato è non è possibile inserire partizioni logiche in tabelle gpt; quindi la tua tabella partizioni è mbr
EDIT2: quindi il tuo problema è che win cerca un partizionamento efi... cos'hai win8?
Vogliamo continuare con spirito di condivisione quanto ci ha insegnato il Prof Antonio...
Ci trovate qui:
https://www.ergosumracalmuto.org/informa...era/forum/

[Immagine: https://www.ergosumracalmuto.org/informa...o_Mary.png]
Cita messaggio
Grazie da:
#35
Ho windows 7 da cd originale. Non ho più una partizione GPT. Quando ho reinstallato win ho partizionato un'altra volta tutto l'hard disk msdos, ho messo ubuntu e poi win. Prima di installare ubuntu windows si avviava.
Potrebbe andar bene se reinstallo tutto seguendo il metodo UEFI tabella partizioni GPT. E poi in questo modo devo installare prima ubuntu o no?

Citazione:Nel tentativo di installare ubuntu in modalita “UEFI - Tabella partizioni GPT”  come suggerito da dxgiusti http://wiki.ubuntu-it.org/Hardware/Dispo...izioni_GPT
ho avuto un incidente. Credendo di partizionare in gpt la sola partizione dove era installato ubuntu, ho partizionato tutto l'hard disk, quindi addio windows. Pertanto, non avendo mai installato win, ho fatto prima una prova su virtual box ed è andato bene.
Sul sito ho trovato IL SUPER GRUB DISK e mi sono regolato nel seguente modo: ho ripartizionato tutto l'hard disk msdos ed ho fatto la partizione per ubuntu  in dev/sda/1 più una grande partizione estesa con dentro la swap. Ho installato Ubuntu e funzionava. Poi ho creato la partizione ntfs di win  spostando la partizione di ubuntu a destra sapendo che win vuole la prima partizione. Ho installato win.
Ovviamente al riavvio partiva solo win. Ho usato il super Grub seguendo esattamente le indicazioni (su terminale sudo grub-install /dev/sda  e poi ancora sudo update-grub) .Ha installato correttamente il Grub. Ma al riavvio il grub vede solo ubuntu. C 'è un modo per rimediare o no?
Oppure mi conviene reinstallare tutto da capo seguendo il metodo UEFI tabella partizioni GPT con i seguenti passaggi:  partiziono tutto l'hard disk gpt e poi creo le  partizioni in questo ordine. Prima la partizione fat 32 da 100 MB con il flag boot, la partizione ntfs dove installo win, una partizione dati ntfs, la partizione di ubuntu ext4 e lo swap. Durante l' installazione di Ubuntu, come punto di mount dovrò indicare la partizione EFI (quella da 100 MB) come EFI boot partition. A questo punto devo installare prima ubuntu e poi windows?, altrimenti non potrò indicare la partizione efi come punto di mount perché sarà già occupata dal boot di windows? E' tutto esatto anche nell'ordine delle cose oppure c'è qualcosa che non va? Vorrei saperlo prima di farlo.Grazie


Aggiungo una schermata del mio attuale hard disk.
Cita messaggio
Grazie da:
#36
entra nel tuo bios e nella sezione boot, metti efi all'ultimo posto, il primo al lettore cd/dvd, il secondo al tuo hd. salva prima di uscire. riavvia. se non parte il grub lo dovrai reistallare da live.
Cita messaggio
Grazie da:
#37
Nel boot al primo posto ho il dvd, al secondo l'hard disk ma non c'è l'efi. Il grub di ubuntu c'è ma posso scegliere solo ubuntu, windows non c'è.
Cita messaggio
Grazie da:
#38
allora ubuntu si avvia, è win che non parte. se è cosi, con il disco di installazione di seven ripristina il suo avvio.
http://www.istitutomajorana.it/index.php...Itemid=191
guarda solo il caso 2.
poi partirà solo seven. dovrai riscrivere il grub.
Cita messaggio
Grazie da:
#39
Sono disperato. Col cd di windows ho tentato di fare il ripristino ma dopo aver cliccato ripristina il computer mi dice che la versione di opzioni di ripristino di sistema non è compatibile con la versione di windows. Utilizzare un disco compatibile con la versione di windows in uso Non lo riconosce probabilmente perchè ho installato win su partizione msdos e non c'è la piccola partizione fat 32 come nella prima schermata del mio hard disk, prima di ripartizionare. Questa

Citazione:Ecco il mio hard disk -allego la schermata



Allegati Anteprime
[Immagine: http://www.istitutomajorana.it/forum2/at...bnail=1901]   

Che altro posso fare?
   
Cita messaggio
Grazie da:
#40
le tue immagini del hd spaziano da uno in msdos, a una un gpt. ma attualmente come è il tuo disco altrimenti non si capisce più nulla.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: