Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema Wi-Fi Xubuntu 17.10 64Bit
#1
Buonasera,
da circa due settimane mi si è presentato questo problema (non so cosa l'ha causato). Ho seguito diverse guide ma non hanno portato miglioramenti (penso è una problematica soggettiva per ogni computer). Ad ogni modo riporto qui sotto quello l'output di alcuni comandi visti su internet. Il wifi mi si disconnette un po' a cavolo, nel senso che a volte si disconnette dopo 10 minuti e a volte dopo 3 ore. Una volta che si interrompe la connessione devo per forza riavviare in quanto la scheda di rete del PC non rileva più nessuna rete.

Codice:
paolo@paolo-Extensa-5620:~$ sudo rfkill list
[sudo] password di paolo:
0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Codice:
paolo@paolo-Extensa-5620:~$ sudo lshw -c network
  *-network                 
       description: Ethernet interface
       product: NetLink BCM5787M Gigabit Ethernet PCI Express
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 02
       serial: 00:1d:72:00:99:80
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=5787m-v3.23 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 memory:f6000000-f600ffff
  *-network
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 02
       serial: 00:1c:bf:1b:4f:33
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=4.13.0-16-generic firmware=15.32.2.9 ip=192.168.1.7 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:26 memory:f8000000-f8000fff

Codice:
paolo@paolo-Extensa-5620:~$ sudo ifconfig -a
enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:1d:72:00:99:80  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  

irda0: flags=128<NOARP>  mtu 2048
        irda 00:00:00:00  txqueuelen 8  (IrLAP)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback locale)
        RX packets 145  bytes 10600 (10.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 145  bytes 10600 (10.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.7  netmask 255.255.255.0  broadcast 192.168.1.255
        ether 00:1c:bf:1b:4f:33  txqueuelen 1000  (Ethernet)
        RX packets 135306  bytes 152081743 (152.0 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 101576  bytes 16209633 (16.2 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Codice:
paolo@paolo-Extensa-5620:~$ iwconfig
lo        no wireless extensions.

enp2s0    no wireless extensions.

wlp4s0    IEEE 802.11  ESSID:"InfostradaWiFi-f29b86"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: BC:F6:85:F2:9B:87   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=55/70  Signal level=-55 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:181   Missed beacon:0

irda0     no wireless extensions.

Codice:
paolo@paolo-Extensa-5620:~$ lspci -nn | grep -i net
02:00.0 Ethernet controller [0200]: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
04:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)


Ho letto che l'installazione di Wicd avrebbe potuto risolvere il problema infatti l'ho installato e da allora si disconnette meno frequentemente.

Il problema si presenta in maniera molto fastidioso e lo vorrei risolvere il prima possibile, confido in voi e nella vostra esperienza. Grazie
Cita messaggio
Grazie da:
#2
Prima di tutto dovresti disattivare il risparmio energetico del wifi(dal terminale vedo che e on)poi segui questa guida e forse risolvi
https://www.lffl.org/2014/06/ubuntu-conn...sione.html
Cita messaggio
Grazie da:
#3
Ciao, innanzi tutto grazie per aver risposto dopo qualche giorno, avevo paura di essere caduto nel dimenticatoio.
In ogni caso, quando vado a fare "Ctrl + X" e poi "S" mi esce questo:
   
Cita messaggio
Grazie da:
#4
Farlo dal terminale e difficile, usa il tuo editor di testo predefinito pero come utente root così riesci a modificare il file
Cita messaggio
Grazie da:
#5
Come si fa? Io sul PC ho Kate e Mousepad. Ho provato vari comandi su internet ma mi si apre la pagina dell'editor vuota
Cita messaggio
Grazie da:
#6
sudo mousepad /etc/pm/config.d/unload_modules
oppure
sudo kate /etc/pm/config.d/unload_modules
Scusate il ritardo...  Angel
Grazie a chi dice Grazie  At
Usate l'errore come chiave di ricerca su Google
Cita messaggio
Grazie da:
#7
Esatto come ha scritto l'utente sopra,non preoccuparti che e vuota,devi inserire tu il comando che hai provato a inserire dal terminale sull'immagine
Cita messaggio
Grazie da:
#8
Ho provato in entrambi i modi e mi da questi problemi
       
Cita messaggio
Grazie da:
#9
Ciao ragazzi!
Posto qui sotto l'output dei comandi dopo la disconnesione. Credo in voi!

Codice:
paolo@paolo-Extensa-5620:~$ sudo rfkill list
[sudo] password di paolo: 
0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
paolo@paolo-Extensa-5620:~$ sudo lshw -c network
  *-network                 
       description: Ethernet interface
       product: NetLink BCM5787M Gigabit Ethernet PCI Express
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 02
       serial: 00:1d:72:00:99:80
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=5787m-v3.23 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 memory:f6000000-f600ffff
  *-network DISABLED
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 02
       serial: 00:1c:bf:1b:4f:33
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=4.13.0-16-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:25 memory:f8000000-f8000fff
paolo@paolo-Extensa-5620:~$ sudo ifconfig -a
enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:1d:72:00:99:80  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  

irda0: flags=128<NOARP>  mtu 2048
        irda 00:00:00:00  txqueuelen 8  (IrLAP)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback locale)
        RX packets 129  bytes 9372 (9.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 129  bytes 9372 (9.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:1c:bf:1b:4f:33  txqueuelen 1000  (Ethernet)
        RX packets 231010  bytes 328048548 (328.0 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 123285  bytes 13797704 (13.7 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

paolo@paolo-Extensa-5620:~$ iwconfig
wlp4s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          
lo        no wireless extensions.

irda0     no wireless extensions.

enp2s0    no wireless extensions.

paolo@paolo-Extensa-5620:~$ lspci -nn | grep -i net
02:00.0 Ethernet controller [0200]: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
04:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
paolo@paolo-Extensa-5620:~$ 
Cita messaggio
Grazie da:
#10
il modulo è giusto, dai un'occhiata a questo, verifica se può aiutarti a risolvere il problema: https://ubuntuforums.org/showthread.php?t=2222374
Scusate il ritardo...  Angel
Grazie a chi dice Grazie  At
Usate l'errore come chiave di ricerca su Google
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)